summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-12-04 23:10:18 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-12-04 23:10:18 +0000
commit026f44e1e357d823ef0eb99cf7e98525e4893c8f (patch)
tree222dbcb6859a93b160d4bc2b6f25989d8d5f6a0a /app-emulation/virt-viewer
parentAdd patch fixing fgpanel support, bug 443766. (diff)
downloadgentoo-2-026f44e1e357d823ef0eb99cf7e98525e4893c8f.tar.gz
gentoo-2-026f44e1e357d823ef0eb99cf7e98525e4893c8f.tar.bz2
gentoo-2-026f44e1e357d823ef0eb99cf7e98525e4893c8f.zip
Support USE=nsplugin and USE=gtk3 at the same time by doing two builds.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation/virt-viewer')
-rw-r--r--app-emulation/virt-viewer/ChangeLog7
-rw-r--r--app-emulation/virt-viewer/virt-viewer-0.5.4-r1.ebuild107
2 files changed, 113 insertions, 1 deletions
diff --git a/app-emulation/virt-viewer/ChangeLog b/app-emulation/virt-viewer/ChangeLog
index a665f5e71a61..f178ccdae42e 100644
--- a/app-emulation/virt-viewer/ChangeLog
+++ b/app-emulation/virt-viewer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virt-viewer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/ChangeLog,v 1.20 2012/09/21 18:02:15 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/ChangeLog,v 1.21 2012/12/04 23:10:18 cardoe Exp $
+
+*virt-viewer-0.5.4-r1 (04 Dec 2012)
+
+ 04 Dec 2012; Doug Goldstein <cardoe@gentoo.org> +virt-viewer-0.5.4-r1.ebuild:
+ Support USE=nsplugin and USE=gtk3 at the same time by doing two builds.
21 Sep 2012; Doug Goldstein <cardoe@gentoo.org> virt-viewer-0.5.4.ebuild:
Fix spice-gtk depend. bug #435678
diff --git a/app-emulation/virt-viewer/virt-viewer-0.5.4-r1.ebuild b/app-emulation/virt-viewer/virt-viewer-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..a04535fdc9b6
--- /dev/null
+++ b/app-emulation/virt-viewer/virt-viewer-0.5.4-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/virt-viewer-0.5.4-r1.ebuild,v 1.1 2012/12/04 23:10:18 cardoe Exp $
+
+EAPI=5
+inherit eutils gnome2 toolchain-funcs
+
+DESCRIPTION="Graphical console client for connecting to virtual machines"
+HOMEPAGE="http://virt-manager.org/"
+SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk3 nsplugin sasl +spice +vnc"
+
+RDEPEND=">=app-emulation/libvirt-0.10.0[sasl?]
+ >=dev-libs/libxml2-2.6
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( >=x11-libs/gtk+-2.18:2 )
+ nsplugin? (
+ >=dev-libs/nspr-4
+ >=x11-libs/gtk+-2.18:2
+ )
+ spice? ( >=net-misc/spice-gtk-0.12.101[sasl?,gtk3=] )
+ vnc? ( >=net-libs/gtk-vnc-0.5.0[sasl?,gtk3=] )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ nsplugin? ( =net-misc/npapi-sdk-0.27 )
+ spice? ( >=app-emulation/spice-protocol-0.10.1 )"
+
+REQUIRED_USE="|| ( spice vnc )"
+
+GTK2_BUILDDIR="${WORKDIR}/${P}_nsplugin"
+GTK3_BUILDDIR="${WORKDIR}/${P}_gtk"
+
+pkg_setup() {
+ G2CONF="$(use_with vnc gtk-vnc) $(use_with spice spice-gtk)"
+
+ GTK2_G2CONF="${G2CONF} $(use_enable nsplugin plugin)"
+ GTK2_G2CONF="${G2CONF} --with-gtk=2.0"
+
+ GTK3_G2CONF="${G2CONF} --with-gtk=3.0"
+}
+
+src_prepare() {
+ mkdir ${GTK2_BUILDDIR} || die
+ mkdir ${GTK3_BUILDDIR} || die
+
+ epatch "${FILESDIR}"/${PN}-0.5.x-npapi-sdk.patch
+}
+
+src_configure() {
+ if use nsplugin; then
+ export MOZILLA_PLUGIN_CFLAGS="$($(tc-getPKG_CONFIG) --cflags npapi-sdk nspr)"
+ export MOZILLA_PLUGIN_LIBS="$($(tc-getPKG_CONFIG) --libs npapi-sdk nspr)"
+ fi
+
+ export ECONF_SOURCE="${S}"
+
+ cd ${GTK2_BUILDDIR}
+ echo "Running configure in ${GTK2_BUILDDIR}"
+ G2CONF="${GTK2_G2CONF}" gnome2_src_configure
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ echo "Running configure in ${GTK3_BUILDDIR}"
+ G2CONF="${GTK3_G2CONF}" gnome2_src_configure
+ fi
+}
+
+src_compile() {
+ cd ${GTK2_BUILDDIR}
+ echo "Running make in ${GTK2_BUILDDIR}"
+ default
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ echo "Running make in ${GTK3_BUILDDIR}"
+ default
+ fi
+}
+
+src_test() {
+ cd ${GTK2_BUILDDIR}
+ echo "Running make check in ${GTK2_BUILDDIR}"
+ default
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ echo "Running make check in ${GTK3_BUILDDIR}"
+ default
+ fi
+}
+
+src_install() {
+ cd ${GTK2_BUILDDIR}
+ echo "Running make install in ${GTK2_BUILDDIR}"
+ default
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ echo "Running make install in ${GTK3_BUILDDIR}"
+ default
+ fi
+}