summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-01-24 20:16:57 +0000
committerThilo Bangert <bangert@gentoo.org>2010-01-24 20:16:57 +0000
commit6cb3ebaef9acd181cd8641c4adca8c63a5d7dd46 (patch)
tree1e872e75a8ec078005f3c14fd6c3813f5567b537 /app-emulation/virt-viewer
parentUSE=bidi support thanks to Martin von Gagern (bug #261155). (diff)
downloadgentoo-2-6cb3ebaef9acd181cd8641c4adca8c63a5d7dd46.tar.gz
gentoo-2-6cb3ebaef9acd181cd8641c4adca8c63a5d7dd46.tar.bz2
gentoo-2-6cb3ebaef9acd181cd8641c4adca8c63a5d7dd46.zip
fix building against xulrunner-1.9.1 (#280167)
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'app-emulation/virt-viewer')
-rw-r--r--app-emulation/virt-viewer/ChangeLog11
-rw-r--r--app-emulation/virt-viewer/files/virt-viewer-0.2.0-xulrunner-1.9.1.patch24
-rw-r--r--app-emulation/virt-viewer/virt-viewer-0.2.0-r2.ebuild35
3 files changed, 68 insertions, 2 deletions
diff --git a/app-emulation/virt-viewer/ChangeLog b/app-emulation/virt-viewer/ChangeLog
index f84197e9c0e9..3b50724c50ed 100644
--- a/app-emulation/virt-viewer/ChangeLog
+++ b/app-emulation/virt-viewer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/virt-viewer
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/ChangeLog,v 1.7 2009/12/23 17:27:45 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/ChangeLog,v 1.8 2010/01/24 20:16:57 bangert Exp $
+
+*virt-viewer-0.2.0-r2 (24 Jan 2010)
+
+ 24 Jan 2010; Thilo Bangert <bangert@gentoo.org>
+ +virt-viewer-0.2.0-r2.ebuild,
+ +files/virt-viewer-0.2.0-xulrunner-1.9.1.patch:
+ fix building against xulrunner-1.9.1 (#280167)
23 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
-virt-viewer-0.0.3.ebuild:
diff --git a/app-emulation/virt-viewer/files/virt-viewer-0.2.0-xulrunner-1.9.1.patch b/app-emulation/virt-viewer/files/virt-viewer-0.2.0-xulrunner-1.9.1.patch
new file mode 100644
index 000000000000..7e015d07e0b1
--- /dev/null
+++ b/app-emulation/virt-viewer/files/virt-viewer-0.2.0-xulrunner-1.9.1.patch
@@ -0,0 +1,24 @@
+diff -Naur virt-viewer-0.2.0.orig/plugin/npshell.c virt-viewer-0.2.0/plugin/npshell.c
+--- virt-viewer-0.2.0.orig/plugin/npshell.c 2009-08-03 16:31:59.413536402 +0200
++++ virt-viewer-0.2.0/plugin/npshell.c 2009-08-03 16:28:27.682285745 +0200
+@@ -84,7 +84,7 @@
+ #include <strings.h>
+
+ #include <npapi.h>
+-#include <npupp.h>
++#include <npfunctions.h>
+
+ #include "virt-viewer-plugin.h"
+
+diff -Naur virt-viewer-0.2.0.orig/plugin/npunix.c virt-viewer-0.2.0/plugin/npunix.c
+--- virt-viewer-0.2.0.orig/plugin/npunix.c 2009-08-03 16:32:05.906537077 +0200
++++ virt-viewer-0.2.0/plugin/npunix.c 2009-08-03 16:27:53.100384815 +0200
+@@ -57,7 +57,7 @@
+
+ #include <stdio.h>
+ #include <npapi.h>
+-#include <npupp.h>
++#include <npfunctions.h>
+
+ #include <glib.h> /* just for G_GNUC_UNUSED */
+
diff --git a/app-emulation/virt-viewer/virt-viewer-0.2.0-r2.ebuild b/app-emulation/virt-viewer/virt-viewer-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..c05221810669
--- /dev/null
+++ b/app-emulation/virt-viewer/virt-viewer-0.2.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/virt-viewer-0.2.0-r2.ebuild,v 1.1 2010/01/24 20:16:57 bangert Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Graphical console client for connecting to virtual machines"
+HOMEPAGE="http://virt-manager.org/"
+SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nsplugin"
+RDEPEND=">=x11-libs/gtk+-2.10.0
+ >=gnome-base/libglade-2.6.0
+ >=app-emulation/libvirt-0.6.0
+ >=net-libs/gtk-vnc-0.3.8
+ >=dev-libs/libxml2-2.6.0
+ nsplugin? ( >=dev-libs/nspr-4.0.0
+ >=net-libs/xulrunner-1.9.1 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-xulrunner-1.9.1.patch
+}
+
+src_configure() {
+ econf $(use_enable nsplugin plugin)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}