summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-26 00:05:08 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-26 00:05:08 +0000
commita16401e8bb186dcd90d96bd0fa55cfeb8fc85d2b (patch)
treebfea5bc15f154d41967ce03a2eac4c1ce38bd2ba /app-emulation/vmware-workstation
parent2.5/2.6 kernel support (diff)
downloadgentoo-2-a16401e8bb186dcd90d96bd0fa55cfeb8fc85d2b.tar.gz
gentoo-2-a16401e8bb186dcd90d96bd0fa55cfeb8fc85d2b.tar.bz2
gentoo-2-a16401e8bb186dcd90d96bd0fa55cfeb8fc85d2b.zip
old 3.2.0 is gone
Diffstat (limited to 'app-emulation/vmware-workstation')
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230-r1/90vmware3
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230-r1/VMwareWorkstation.desktop12
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware73
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware-config.pl-gcc-generalized.patch60
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware.pngbin470 -> 0 bytes
-rw-r--r--app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230-r11
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-3.2.0.2230-r1.ebuild163
7 files changed, 0 insertions, 312 deletions
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/90vmware b/app-emulation/vmware-workstation/files/3.2.0.2230-r1/90vmware
deleted file mode 100644
index 8e00d2bb0587..000000000000
--- a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/90vmware
+++ /dev/null
@@ -1,3 +0,0 @@
-PATH=/opt/vmware/bin
-ROOTPATH=/opt/vmware/bin
-MANPATH=/opt/vmware/man
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/VMwareWorkstation.desktop b/app-emulation/vmware-workstation/files/3.2.0.2230-r1/VMwareWorkstation.desktop
deleted file mode 100644
index 9e42f9c1b4c6..000000000000
--- a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/VMwareWorkstation.desktop
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Name=VMware Workstation
-Comment=VMware Workstation
-GenericName=Virtual PC Emulator
-Exec=vmware
-Icon=/opt/vmware/lib/icon/vmware.png
-Path=
-Terminal=0
-TerminalOptions=
-Type=Application
-X-KDE-SubstituteUID=false
-X-KDE-Username=
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware b/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware
deleted file mode 100644
index f86be6a09b33..000000000000
--- a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware,v 1.3 2003/02/14 22:35:37 vapier Exp $
-
-depend() {
- need localmount
- use logger net
-}
-
-vmware-prettify() {
- # Yea, the code is ugly but the output is pretty
- state=$1
- waserror=0
- msgtype=0
- while read line
- do
- [ "$line" == "" ] && continue
- if [ "$msgtype" -le "0" ]
- then
- if [ "$msgtype" == "-1" ]
- then
- ewarn $line
- continue
- fi
- if [ "${line/*:*/}" == "" ]
- then
- einfon $line
- echo
- eend 0
- msgtype=1
- else
- ewarn $line
- msgtype=-1
- waserror=1
- fi
- continue
- fi
-
- # Strip out anything after the <esc> code
- message=`echo $line | sed -e "s/^\(.*\).*$/\1/"`
- einfon " $message"
- echo
-
- echo $line | grep done > /dev/null
- status=$?
- eend $status
-
- if [ "$status" != "0" ]
- then
- logger -p local0.err -t vmware-${state} "$line"
- waserror=$status
- fi
- done
- if [ "$msgtype" == "-1" ]
- then
- eend 1 "VMware is not properly configured! See above."
- fi
- return $waserror
-}
-
-start() {
- test -x /etc/vmware/init.d/vmware || \
- eend 1 "vmware init script not found. Aborting" || return 1
-
- /etc/vmware/init.d/vmware start | vmware-prettify start
- return $?
-}
-
-stop() {
- /etc/vmware/init.d/vmware stop | vmware-prettify stop
- return $?
-}
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware-config.pl-gcc-generalized.patch b/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware-config.pl-gcc-generalized.patch
deleted file mode 100644
index f2a0239f4c7b..000000000000
--- a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware-config.pl-gcc-generalized.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- bin/vmware-config.pl.orig 2002-12-16 12:15:35.000000000 -0500
-+++ bin/vmware-config.pl 2002-12-16 13:30:29.000000000 -0500
-@@ -1487,21 +1487,21 @@
- }
-
- $gcc_version = direct_command(shell_string($gHelper{'gcc'})
-- . ' --version');
-+ . ' -dumpversion');
- chomp($gcc_version);
- @gcc_version_num = split(/\./, $gcc_version);
-- if ($gcc_version_num[0] >= 3) {
-- if (get_answer('As of April 2002, gcc version 3 and later is not yet a '
-- . 'supported compiler by the Linux kernel development '
-- . 'team. Have a look at Documentation/Changes in your '
-- . 'kernel source directory to get the correct compiler '
-- . 'installed. Do you want to go with compiler "'
-- . $gHelper{'gcc'} . '" version ' . $gcc_version . '?',
-- 'yesno', 'no') eq 'no') {
-- print wrap('Unable to continue.' . "\n\n", 0);
-- module_error();
-- }
-- }
-+# if ($gcc_version_num[0] >= 3) {
-+# if (get_answer('As of April 2002, gcc version 3 and later is not yet a '
-+# . 'supported compiler by the Linux kernel development '
-+# . 'team. Have a look at Documentation/Changes in your '
-+# . 'kernel source directory to get the correct compiler '
-+# . 'installed. Do you want to go with compiler "'
-+# . $gHelper{'gcc'} . '" version ' . $gcc_version . '?',
-+# 'yesno', 'no') eq 'no') {
-+# print wrap('Unable to continue.' . "\n\n", 0);
-+# module_error();
-+# }
-+# }
-
- # When installing the modules, kernels 2.4+ setup a symlink to the kernel
- # source directory
-@@ -1526,6 +1526,22 @@
- module_error();
- }
-
-+ my $makefile="$build_dir/$name-only/Makefile";
-+ my $gcc_replace="";
-+ $gcc_version = direct_command(shell_string($gHelper{'gcc'})
-+ . ' -dumpversion');
-+ chomp($gcc_version);
-+ @gcc_version_num = split(/\./, $gcc_version);
-+ if ($gcc_version_num[0] >= 3) {
-+ $gcc_replace="-e 's:-malign-:-falign-:g'";
-+ }
-+ system("/usr/bin/cp $makefile $makefile.old");
-+ system("/usr/bin/sed" .
-+ " -e 's:CC) --version:CC) -dumpversion:'" .
-+ " -e 's:-m486:-march=i486:'" .
-+ " -e 's:-Wall -Wstrict-prototypes::'" .
-+ " $gcc_replace" .
-+ " $makefile.old > $makefile");
- print wrap('Building the ' . $name . ' module.' . "\n\n", 0);
- if (system(shell_string($gHelper{'make'}) . ' -C ' . shell_string($build_dir . '/' . $name . '-only') . ' auto-build ' . (($gSystem{'smp'} eq 'yes') ? 'SUPPORT_SMP=1 ' : '') . shell_string('HEADER_DIR=' . db_get_answer('HEADER_DIR')) . ' ' . shell_string('CC=' . $gHelper{'gcc'}) . ' ' . shell_string('GREP=' . $gHelper{'grep'}))) {
- print wrap('Unable to build the ' . $name . ' module.' . "\n\n", 0);
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware.png b/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware.png
deleted file mode 100644
index 06672aa3f0bf..000000000000
--- a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware.png
+++ /dev/null
Binary files differ
diff --git a/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230-r1 b/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230-r1
deleted file mode 100644
index 3fcf4a53a48b..000000000000
--- a/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 be6a12e7c835d027adfe533e1744759e VMware-workstation-3.2.0-2230.tar.gz 12575521
diff --git a/app-emulation/vmware-workstation/vmware-workstation-3.2.0.2230-r1.ebuild b/app-emulation/vmware-workstation/vmware-workstation-3.2.0.2230-r1.ebuild
deleted file mode 100644
index 44cf1a58033f..000000000000
--- a/app-emulation/vmware-workstation/vmware-workstation-3.2.0.2230-r1.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-3.2.0.2230-r1.ebuild,v 1.5 2003/03/11 21:11:44 seemant Exp $
-
-# Unlike many other binary packages the user doesn't need to agree to a licence
-# to download VM Ware. The agreeing to a licence is part of the configure step
-# which the user must run manually.
-
-S=${WORKDIR}/vmware-distrib
-NP="VMware-workstation-3.2.0-2230"
-DESCRIPTION="Emulate a complete PC on your PC without the usual performance overhead of most emulators"
-SRC_URI="http://vmware-svca.www.conxion.com/software/${NP}.tar.gz
- http://www.vmware.com/download1/software/${NP}.tar.gz
- ftp://download1.vmware.com/pub/software/${NP}.tar.gz
- http://vmware-chil.www.conxion.com/software/${NP}.tar.gz
- http://vmware-heva.www.conxion.com/software/${NP}.tar.gz
- http://vmware.wespe.de/software/${NP}.tar.gz
- ftp://vmware.wespe.de/pub/software/${NP}.tar.gz"
-HOMEPAGE="http://www.vmware.com/products/desktop/ws_features.html"
-
-SLOT="0"
-LICENSE="vmware"
-KEYWORDS="x86 -ppc -sparc"
-IUSE="kde"
-
-DEPEND="virtual/glibc
- virtual/x11
- sys-kernel/linux-headers
- >=dev-lang/perl-5
- >=dev-lang/tcl-8.3.3"
-
-RESTRICT="nostrip"
-
-src_install() {
- # lets make gcc happy regardless of what version we're using
- patch -p0 < ${FILESDIR}/${PVR}/vmware-config.pl-gcc-generalized.patch
-
- dodir /opt/vmware/bin
- cp -a bin/* ${D}/opt/vmware/bin/
- # vmware and vmware-ping needs to be suid root.
- chmod u+s ${D}/opt/vmware/bin/vmware
- chmod u+s ${D}/opt/vmware/bin/vmware-ping
-
- dodir /opt/vmware/lib
- cp -a lib/* ${D}/opt/vmware/lib/
- # Since with Gentoo we compile everthing it doesn't make sense to keep
- # the precompiled modules arround. Saves about 4 megs of disk space too.
- rm -rf ${D}/opt/vmware/lib/modules/binary
-
- dodir /opt/vmware/doc
- cp -a doc/* ${D}/opt/vmware/doc/
-
- dodir /opt/vmware/man/
- cp -a man/* ${D}/opt/vmware/man/
-
- # vmware service loader
- exeinto /etc/init.d
- newexe ${FILESDIR}/${PVR}/vmware vmware
-
- # vmware enviroment
- insinto /etc/env.d
- doins ${FILESDIR}/${PVR}/90vmware
-
- dodir /etc/vmware/
- cp -a etc/* ${D}/etc/vmware/
-
- dodir /etc/vmware/init.d
- dodir /etc/vmware/init.d/rc0.d
- dodir /etc/vmware/init.d/rc1.d
- dodir /etc/vmware/init.d/rc2.d
- dodir /etc/vmware/init.d/rc3.d
- dodir /etc/vmware/init.d/rc4.d
- dodir /etc/vmware/init.d/rc5.d
- dodir /etc/vmware/init.d/rc6.d
- cp -a installer/services.sh ${D}/etc/vmware/init.d/vmware
-
- # This is to fix a problem where if someone merges vmware and then
- # before configuring vmware they upgrade or re-merge the vmware
- # package which would rmdir the /etc/vmware/init.d/rc?.d directories.
- keepdir /etc/vmware/init.d/rc{0,1,2,3,4,5,6}.d
-
- # A simple icon I made
- dodir /opt/vmware/lib/icon
- insinto /opt/vmware/lib/icon
- doins ${FILESDIR}/${PVR}/vmware.png
-
- if [ "`use kde`" ] ; then
- dodir /usr/share/applnk/Applications
- insinto /usr/share/applnk/Applications
- doins "${FILESDIR}/${PVR}/VMwareWorkstation.desktop"
- fi
-
- # Questions:
- einfo "Adding answers to /etc/vmware/locations"
- locations="${D}/etc/vmware/locations"
- echo "answer BINDIR /opt/vmware/bin" >> ${locations}
- echo "answer LIBDIR /opt/vmware/lib" >> ${locations}
- echo "answer MANDIR /opt/vmware/man" >> ${locations}
- echo "answer DOCDIR /opt/vmware/doc" >> ${locations}
- echo "answer RUN_CONFIGURATOR no" >> ${locations}
- echo "answer INITDIR /etc/vmware/init.d" >> ${locations}
- echo "answer INITSCRIPTSDIR /etc/vmware/init.d" >> ${locations}
-}
-
-pkg_preinst() {
- # This must be done after the install to get the mtimes on each file
- # right. This perl snippet gets the /etc/vmware/locations file code:
- # perl -e "@a = stat('bin/vmware'); print \$a[9]"
- # The above perl line and the find line below output the same thing.
- # I would think the find line is faster to execute.
- # find /opt/vmware/bin/vmware -printf %T@
-
- #Note: it's a bit weird to use ${D} in a preinst script but it should work
- #(drobbins, 1 Feb 2002)
-
- einfo "Generating /etc/vmware/locations file."
- d=`echo ${D} | wc -c`
- for x in `find ${D}/opt/vmware ${D}/etc/vmware` ; do
- x="`echo ${x} | cut -c ${d}-`"
- if [ -d ${D}/${x} ] ; then
- echo "directory ${x}" >> ${D}/etc/vmware/locations
- else
- echo -n "file ${x}" >> ${D}/etc/vmware/locations
- if [ "${x}" == "/etc/vmware/locations" ] ; then
- echo "" >> ${D}/etc/vmware/locations
- elif [ "${x}" == "/etc/vmware/not_configured" ] ; then
- echo "" >> ${D}/etc/vmware/locations
- else
- echo -n " " >> ${D}/etc/vmware/locations
- #perl -e "@a = stat('${D}${x}'); print \$a[9]" >> ${D}/etc/vmware/locations
- find ${D}${x} -printf %T@ >> ${D}/etc/vmware/locations
- echo "" >> ${D}/etc/vmware/locations
- fi
- fi
- done
-}
-
-pkg_postinst () {
- # This is to fix the problem where the not_configured file doesn't get
- # removed when the configuration is run. This doesn't remove the file
- # It just tells the vmware-config.pl script it can delete it.
- einfo "Updating /etc/vmware/locations"
- for x in /etc/vmware/._cfg????_locations ; do
- if [ -f $x ] ; then
- cat $x >> /etc/vmware/locations
- rm $x
- fi
- done
-
- einfo
- einfo "You need to run /opt/vmware/bin/vmware-config.pl to complete the install."
- einfo
- einfo "For VMware Add-Ons just visit"
- einfo "http://www.vmware.com/download/downloadaddons.html"
-}
-
-pkg_postrm() {
- einfo
- einfo "To remove all traces of vmware you will need to remove the files"
- einfo "in /etc/vmware/, /etc/init.d/vmware, /lib/modules/*/misc/vm*.o,"
- einfo "and .vmware/ in each users home directory."
- einfo
-}