summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-04 20:45:34 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-04 20:45:34 +0000
commit80f7bce0ee53dd3e5e22e70099269f1b29f6b879 (patch)
treeafca3f2811f8dfc9259152767230bfe0e356a44c /app-emulation/wine/wine-0.9.9.ebuild
parentCleanup. (diff)
downloadgentoo-2-80f7bce0ee53dd3e5e22e70099269f1b29f6b879.tar.gz
gentoo-2-80f7bce0ee53dd3e5e22e70099269f1b29f6b879.tar.bz2
gentoo-2-80f7bce0ee53dd3e5e22e70099269f1b29f6b879.zip
Cleanup modular X handling in all ebuilds and cleanup lcms handling #167240.
(Portage version: 2.1.2-r14)
Diffstat (limited to 'app-emulation/wine/wine-0.9.9.ebuild')
-rw-r--r--app-emulation/wine/wine-0.9.9.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-emulation/wine/wine-0.9.9.ebuild b/app-emulation/wine/wine-0.9.9.ebuild
index 1a827394af74..056f439ee861 100644
--- a/app-emulation/wine/wine-0.9.9.ebuild
+++ b/app-emulation/wine/wine-0.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.9.ebuild,v 1.12 2007/03/04 06:56:15 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.9.ebuild,v 1.13 2007/03/04 20:45:33 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -18,9 +18,12 @@ RDEPEND=">=media-libs/freetype-2.0.0
media-fonts/corefonts
ncurses? ( >=sys-libs/ncurses-5.2 )
jack? ( media-sound/jack-audio-connection-kit )
- X? ( || ( ( x11-libs/libXrandr x11-libs/libXi x11-libs/libXmu
- x11-libs/libXxf86dga x11-libs/libXxf86vm x11-apps/xmessage )
- virtual/x11 )
+ X? (
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-apps/xmessage
)
arts? ( kde-base/arts )
alsa? ( media-libs/alsa-lib )
@@ -43,13 +46,11 @@ RDEPEND=">=media-libs/freetype-2.0.0
>=sys-kernel/linux-headers-2.6
)"
DEPEND="${RDEPEND}
- X? ( || ( ( x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xf86dgaproto
- x11-proto/xf86vidmodeproto
- )
- virtual/x11
- )
+ X? (
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
)
sys-devel/bison
sys-devel/flex"
@@ -95,7 +96,7 @@ src_compile() {
config_cache glut glut:glutMainLoop
config_cache jpeg jpeglib.h
config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
- config_cache lcms lcms.h
+ config_cache lcms lcms.h lcms/lcms.h
use x86 && config_cache truetype freetype:FT_Init_FreeType
strip-flags