summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-02 23:32:06 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-02 23:32:06 +0000
commita83ebde79a603e2a0ec94a2de8fa2397a449c3c4 (patch)
tree0e8e975dd9dd10f2837c8eb67670539f1b5a807f /app-emulation/wine/wine-1.3.1.ebuild
parentVersion bump and update Gecko #390995 by Andreas Sturmlechner. (diff)
downloadgentoo-2-a83ebde79a603e2a0ec94a2de8fa2397a449c3c4.tar.gz
gentoo-2-a83ebde79a603e2a0ec94a2de8fa2397a449c3c4.tar.bz2
gentoo-2-a83ebde79a603e2a0ec94a2de8fa2397a449c3c4.zip
Delete custom pulseaudio/mousewarp patches that are obsolete in newer versions.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/wine/wine-1.3.1.ebuild')
-rw-r--r--app-emulation/wine/wine-1.3.1.ebuild21
1 files changed, 5 insertions, 16 deletions
diff --git a/app-emulation/wine/wine-1.3.1.ebuild b/app-emulation/wine/wine-1.3.1.ebuild
index 29c9dd86069d..ae8f87d64dc3 100644
--- a/app-emulation/wine/wine-1.3.1.ebuild
+++ b/app-emulation/wine/wine-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.1.ebuild,v 1.15 2011/09/18 09:08:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.1.ebuild,v 1.16 2011/12/02 23:32:04 vapier Exp $
EAPI="2"
@@ -8,36 +8,32 @@ inherit eutils flag-o-matic multilib
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
- inherit git-2 autotools
+ inherit git-2
SRC_URI=""
#KEYWORDS=""
else
- AUTOTOOLS_AUTO_DEPEND="no"
- inherit autotools
MY_P="${PN}-${PV/_/-}"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
S=${WORKDIR}/${MY_P}
fi
-pulse_patches() { echo "$1"/winepulse-{0.36,0.35-configure.ac,0.38-winecfg}.patch ; }
GV="1.0.0-x86"
DESCRIPTION="free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
- gecko? ( mirror://sourceforge/wine/wine_gecko-${GV}.cab )
- pulseaudio? ( `pulse_patches http://art.ified.ca/downloads/winepulse` )"
+ gecko? ( mirror://sourceforge/wine/wine_gecko-${GV}.cab )"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm hardened jack jpeg lcms ldap mp3 nas ncurses openal +opengl +oss +perl png pulseaudio samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm hardened jack jpeg lcms ldap mp3 nas ncurses openal +opengl +oss +perl png samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
RESTRICT="test" #72375
MLIB_DEPS="amd64? (
truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
X? (
>=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1[pulseaudio?]
+ >=app-emulation/emul-linux-x86-soundlibs-2.1
)
mp3? ( app-emulation/emul-linux-x86-soundlibs )
openal? ( app-emulation/emul-linux-x86-sdl )
@@ -71,7 +67,6 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
nas? ( media-libs/nas )
cups? ( net-print/cups )
opengl? ( virtual/opengl )
- pulseaudio? ( media-sound/pulseaudio )
gsm? ( media-sound/gsm )
jpeg? ( virtual/jpeg )
ldap? ( net-nds/openldap )
@@ -87,7 +82,6 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
win32? ( ${MLIB_DEPS} )
xcomposite? ( x11-libs/libXcomposite )"
DEPEND="${RDEPEND}
- pulseaudio? ( ${AUTOTOOLS_DEPEND} )
X? (
x11-proto/inputproto
x11-proto/xextproto
@@ -112,10 +106,6 @@ src_unpack() {
}
src_prepare() {
- if use pulseaudio ; then
- EPATCH_OPTS=-p1 epatch `pulse_patches "${DISTDIR}"`
- eautoreconf
- fi
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch_user #282735
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
@@ -152,7 +142,6 @@ do_configure() {
$(use_with oss) \
$(use_with png) \
$(use_with threads pthread) \
- $(use pulseaudio && use_with pulseaudio pulse) \
$(use_with scanner sane) \
$(use_enable test tests) \
$(use_with truetype freetype) \