summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-31 07:38:44 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-31 07:38:44 +0000
commitbae84a5ba3d7244a2154e4ebbb1be8e9f1241ecc (patch)
tree46639b24e724f1c1c48a099f53d57a9af57cac43 /app-emulation/wine/wine-9999.ebuild
parentMask tracker[thunderbird] since thunderbird is not keyworded. (diff)
downloadgentoo-2-bae84a5ba3d7244a2154e4ebbb1be8e9f1241ecc.tar.gz
gentoo-2-bae84a5ba3d7244a2154e4ebbb1be8e9f1241ecc.tar.bz2
gentoo-2-bae84a5ba3d7244a2154e4ebbb1be8e9f1241ecc.zip
Completely disable pulseaudio patches for the live 9999 ebuild since it breaks too often (e.g. bug #448970). Remove the vanilla USE flag since it is now superfluous.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 0bdfd05e7816..afd49026effd 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.126 2012/12/26 22:19:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.127 2012/12/31 07:38:44 tetromino Exp $
EAPI="5"
@@ -35,18 +35,18 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags elibc_glibc fontconfig +gecko gnutls gphoto2 gsm gstreamer jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa +oss +perl png +prelink pulseaudio samba scanner selinux ssl test +threads +truetype udisks vanilla v4l +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags elibc_glibc fontconfig +gecko gnutls gphoto2 gsm gstreamer jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa +oss +perl png +prelink samba scanner selinux ssl test +threads +truetype udisks v4l +win32 +win64 +X xcomposite xinerama xml"
+[[ ${PV} == "9999" ]] || IUSE="${IUSE} pulseaudio"
REQUIRED_USE="elibc_glibc? ( threads )
mono? ( || ( win32 !win64 ) )
- osmesa? ( opengl )
- vanilla? ( !pulseaudio )" #286560
+ osmesa? ( opengl )" #286560
RESTRICT="test" #72375
MLIB_DEPS="amd64? (
truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
X? (
>=app-emulation/emul-linux-x86-xlibs-2.1
- >=app-emulation/emul-linux-x86-soundlibs-2.1[pulseaudio(+)?]
+ >=app-emulation/emul-linux-x86-soundlibs-2.1
)
mp3? ( app-emulation/emul-linux-x86-soundlibs )
odbc? ( app-emulation/emul-linux-x86-db )
@@ -95,10 +95,6 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
nls? ( sys-devel/gettext )
odbc? ( dev-db/unixODBC:= )
osmesa? ( media-libs/mesa[osmesa] )
- pulseaudio? (
- media-sound/pulseaudio
- sys-auth/rtkit
- )
samba? ( >=net-fs/samba-3.0.25 )
selinux? ( sec-policy/selinux-wine )
xml? ( dev-libs/libxml2 dev-libs/libxslt )
@@ -109,6 +105,11 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
!win64? ( ${MLIB_DEPS} )
win32? ( ${MLIB_DEPS} )
xcomposite? ( x11-libs/libXcomposite )"
+[[ ${PV} == "9999" ]] || RDEPEND="${RDEPEND}
+ pulseaudio? (
+ media-sound/pulseaudio
+ sys-auth/rtkit
+ )"
DEPEND="${RDEPEND}
X? (
x11-proto/inputproto
@@ -144,11 +145,10 @@ src_unpack() {
src_prepare() {
local md5="$(md5sum server/protocol.def)"
- # keep these even if USE=vanilla: they are needed to build
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch "${FILESDIR}"/${PN}-1.5.17-osmesa-check.patch #429386
- use vanilla || epatch "../${PULSE_PATCHES}"/*.patch #421365
+ [[ ${PV} == "9999" ]] || epatch "../${PULSE_PATCHES}"/*.patch #421365
epatch_user #282735
if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
einfo "server/protocol.def was patched; running tools/make_requests"
@@ -156,7 +156,7 @@ src_prepare() {
fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
- use vanilla || sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+ sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}
do_configure() {
@@ -164,6 +164,9 @@ do_configure() {
mkdir -p "${builddir}"
pushd "${builddir}" >/dev/null
+ local usepulse
+ [[ ${PV} == "9999" ]] || usepulse=$(use_with pulseaudio pulse)
+
ECONF_SOURCE=${S} \
econf \
--sysconfdir=/etc/wine \
@@ -191,7 +194,7 @@ do_configure() {
$(use_with oss) \
$(use_with png) \
$(use_with threads pthread) \
- $(usex vanilla "" $(use_with pulseaudio pulse)) \
+ ${usepulse} \
$(use_with scanner sane) \
$(use_enable test tests) \
$(use_with truetype freetype) \