summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-23 01:13:01 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-23 01:13:01 +0000
commit5e2992e0e22e2e22c73b75f5ea54ca8703d05212 (patch)
treeed0cfac7f831a48fffcf5c121327fb44ab0a6064 /app-emulation/wine
parent~amd64 (diff)
downloadgentoo-2-5e2992e0e22e2e22c73b75f5ea54ca8703d05212.tar.gz
gentoo-2-5e2992e0e22e2e22c73b75f5ea54ca8703d05212.tar.bz2
gentoo-2-5e2992e0e22e2e22c73b75f5ea54ca8703d05212.zip
Add patch from upstream to address insecure tempfile usage #101773.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog9
-rw-r--r--app-emulation/wine/files/wine-cvs-winelauncher-temp.patch28
-rw-r--r--app-emulation/wine/wine-20041019-r3.ebuild8
-rw-r--r--app-emulation/wine/wine-20050111-r1.ebuild6
-rw-r--r--app-emulation/wine/wine-20050211.ebuild4
-rw-r--r--app-emulation/wine/wine-20050310-r1.ebuild3
-rw-r--r--app-emulation/wine/wine-20050419.ebuild3
-rw-r--r--app-emulation/wine/wine-20050524.ebuild3
-rw-r--r--app-emulation/wine/wine-20050628.ebuild3
-rw-r--r--app-emulation/wine/wine-20050725.ebuild3
10 files changed, 55 insertions, 15 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 73c9af94fa83..06006ead04f3 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.101 2005/08/03 04:55:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.102 2005/08/23 01:13:01 vapier Exp $
+
+ 23 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/wine-cvs-winelauncher-temp.patch, wine-20041019-r3.ebuild,
+ wine-20050111-r1.ebuild, wine-20050211.ebuild, wine-20050310-r1.ebuild,
+ wine-20050419.ebuild, wine-20050524.ebuild, wine-20050628.ebuild,
+ wine-20050725.ebuild:
+ Add patch from upstream to address insecure tempfile usage #101773.
03 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+files/wine-20050725-gcc-32bit.patch, wine-20050524.ebuild,
diff --git a/app-emulation/wine/files/wine-cvs-winelauncher-temp.patch b/app-emulation/wine/files/wine-cvs-winelauncher-temp.patch
new file mode 100644
index 000000000000..74e9b7fa6683
--- /dev/null
+++ b/app-emulation/wine/files/wine-cvs-winelauncher-temp.patch
@@ -0,0 +1,28 @@
+http://bugs.gentoo.org/101773
+
+===================================================================
+RCS file: /home/wine/wine/programs/winelauncher.in,v
+retrieving revision 1.4
+retrieving revision 1.5
+diff -u -p -r1.4 -r1.5
+--- wine/programs/winelauncher.in 2004/06/21 23:56:15 1.4
++++ wine/programs/winelauncher.in 2005/08/10 10:51:50 1.5
+@@ -59,8 +59,8 @@ type xmessage >/dev/null 2>/dev/null
+ if [ $? -ne 0 ] ; then
+ # xmessage not found; make sure the user notices this error
+ # (GUI users wouldn't even notice if we printed the text on console !)
+- MSGFILE=/tmp/WINE_CANNOT_FIND_XMESSAGE
+- cat > $MSGFILE << EOF
++ MSGFILE=`mktemp "/tmp/wine.xmessage.XXXXXX"`
++ cat > $MSGFILE <<EOF
+ Warning:
+ The Wine launcher is unable to find the xmessage program,
+ which it needs to properly notify you of Wine execution status
+@@ -87,6 +87,7 @@ EOF
+
+ # ok, we really give up now, this system is hosed ;-)
+ cat $MSGFILE
++ rm $MSGFILE
+ else
+ XMESSAGE="xmessage $COLOR"
+ fi
diff --git a/app-emulation/wine/wine-20041019-r3.ebuild b/app-emulation/wine/wine-20041019-r3.ebuild
index 887510bd6c4b..b4a563c40420 100644
--- a/app-emulation/wine/wine-20041019-r3.ebuild
+++ b/app-emulation/wine/wine-20041019-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.15 2005/07/19 04:40:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r3.ebuild,v 1.16 2005/08/23 01:13:01 vapier Exp $
inherit eutils flag-o-matic
@@ -38,10 +38,10 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
- epatch ${FILESDIR}/winearts-kdecvs-fix.patch
+ epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
-
- test_flag -fstack-protector && epatch ${FILESDIR}/${PV}-no-stack.patch #66002
+ epatch "${FILESDIR}"/${PV}-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
config_cache() {
diff --git a/app-emulation/wine/wine-20050111-r1.ebuild b/app-emulation/wine/wine-20050111-r1.ebuild
index da910710b017..1cd8093a1939 100644
--- a/app-emulation/wine/wine-20050111-r1.ebuild
+++ b/app-emulation/wine/wine-20050111-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111-r1.ebuild,v 1.8 2005/08/06 20:00:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111-r1.ebuild,v 1.9 2005/08/23 01:13:01 vapier Exp $
inherit eutils flag-o-matic
@@ -41,8 +41,8 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-upstream-registry-fix.patch.bz2 #85387
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
-
- test_flag -fstack-protector && epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
config_cache() {
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index bb732e9561b5..9d20acb3e2ca 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.14 2005/08/06 03:22:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.15 2005/08/23 01:13:01 vapier Exp $
inherit eutils flag-o-matic
@@ -62,10 +62,10 @@ src_unpack() {
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
- epatch "${FILESDIR}"/wine-hangfix-bug2660.patch #98156
epatch "${FILESDIR}"/20050211-docs.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
config_cache() {
diff --git a/app-emulation/wine/wine-20050310-r1.ebuild b/app-emulation/wine/wine-20050310-r1.ebuild
index 66d76554092c..3817b8b88a0e 100644
--- a/app-emulation/wine/wine-20050310-r1.ebuild
+++ b/app-emulation/wine/wine-20050310-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.7 2005/08/06 03:22:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.8 2005/08/23 01:13:01 vapier Exp $
inherit eutils flag-o-matic
@@ -66,6 +66,7 @@ src_unpack() {
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/wine-20050310-upstream-colortable.patch #88715
epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
config_cache() {
diff --git a/app-emulation/wine/wine-20050419.ebuild b/app-emulation/wine/wine-20050419.ebuild
index c03244e786cd..ab40efb905cd 100644
--- a/app-emulation/wine/wine-20050419.ebuild
+++ b/app-emulation/wine/wine-20050419.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.9 2005/08/06 03:22:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.10 2005/08/23 01:13:01 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -65,6 +65,7 @@ src_unpack() {
epatch "${FILESDIR}"/wine-hangfix-bug2660.patch #98156
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+ epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
config_cache() {
diff --git a/app-emulation/wine/wine-20050524.ebuild b/app-emulation/wine/wine-20050524.ebuild
index 2396cd1c42dc..29d99a504914 100644
--- a/app-emulation/wine/wine-20050524.ebuild
+++ b/app-emulation/wine/wine-20050524.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.8 2005/08/03 04:55:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.9 2005/08/23 01:13:01 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -66,6 +66,7 @@ src_unpack() {
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/20041019-no-stack.patch #66002
epatch "${FILESDIR}"/wine-20050725-gcc-32bit.patch
+ epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
config_cache() {
diff --git a/app-emulation/wine/wine-20050628.ebuild b/app-emulation/wine/wine-20050628.ebuild
index 16fa44d176e1..988e74631c61 100644
--- a/app-emulation/wine/wine-20050628.ebuild
+++ b/app-emulation/wine/wine-20050628.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050628.ebuild,v 1.3 2005/08/03 04:55:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050628.ebuild,v 1.4 2005/08/23 01:13:01 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -65,6 +65,7 @@ src_unpack() {
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/20041019-no-stack.patch #66002
epatch "${FILESDIR}"/wine-20050725-gcc-32bit.patch
+ epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
config_cache() {
diff --git a/app-emulation/wine/wine-20050725.ebuild b/app-emulation/wine/wine-20050725.ebuild
index af57cc59207d..6d4e97ec03dc 100644
--- a/app-emulation/wine/wine-20050725.ebuild
+++ b/app-emulation/wine/wine-20050725.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050725.ebuild,v 1.2 2005/08/03 04:55:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050725.ebuild,v 1.3 2005/08/23 01:13:01 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -65,6 +65,7 @@ src_unpack() {
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/20041019-no-stack.patch #66002
epatch "${FILESDIR}"/wine-20050725-gcc-32bit.patch
+ epatch "${FILESDIR}"/wine-cvs-winelauncher-temp.patch #101773
}
config_cache() {