summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-06-30 02:29:59 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-06-30 02:29:59 +0000
commit1c11277d29b0cddfb02becbeaacdf514601a4751 (patch)
tree9d556b5263f19d2dfbdc6af9cec48db7f4f44a48 /app-emulation/winetricks
parentUpdates from Jeroen Roovers <jer@gentoo.org> and Michael Weber <xmw@gentoo.or... (diff)
downloadgentoo-2-1c11277d29b0cddfb02becbeaacdf514601a4751.tar.gz
gentoo-2-1c11277d29b0cddfb02becbeaacdf514601a4751.tar.bz2
gentoo-2-1c11277d29b0cddfb02becbeaacdf514601a4751.zip
Version bump with updates for Adobe Flash, .NET, psdk2003, etc. Switch to upstream packaged tarballs instead of svn checkouts. Drop old.
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-emulation/winetricks')
-rw-r--r--app-emulation/winetricks/ChangeLog10
-rw-r--r--app-emulation/winetricks/winetricks-20130629.ebuild (renamed from app-emulation/winetricks/winetricks-954.ebuild)23
-rw-r--r--app-emulation/winetricks/winetricks-99999999.ebuild21
3 files changed, 26 insertions, 28 deletions
diff --git a/app-emulation/winetricks/ChangeLog b/app-emulation/winetricks/ChangeLog
index 7afb15fe92d4..95c92138d663 100644
--- a/app-emulation/winetricks/ChangeLog
+++ b/app-emulation/winetricks/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/winetricks
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/ChangeLog,v 1.22 2013/06/15 03:58:20 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/ChangeLog,v 1.23 2013/06/30 02:29:59 tetromino Exp $
+
+*winetricks-20130629 (30 Jun 2013)
+
+ 30 Jun 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -winetricks-954.ebuild, +winetricks-20130629.ebuild,
+ winetricks-99999999.ebuild:
+ Version bump with updates for Adobe Flash, .NET, psdk2003, etc. Switch to
+ upstream packaged tarballs instead of svn checkouts. Drop old.
*winetricks-960 (15 Jun 2013)
diff --git a/app-emulation/winetricks/winetricks-954.ebuild b/app-emulation/winetricks/winetricks-20130629.ebuild
index ca1d21c11ccd..d2b94f068577 100644
--- a/app-emulation/winetricks/winetricks-954.ebuild
+++ b/app-emulation/winetricks/winetricks-20130629.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/winetricks-954.ebuild,v 1.1 2013/05/26 04:29:30 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/winetricks-20130629.ebuild,v 1.1 2013/06/30 02:29:59 tetromino Exp $
-EAPI=4
+EAPI=5
inherit gnome2-utils eutils
@@ -10,8 +10,7 @@ if [[ ${PV} == "99999999" ]] ; then
ESVN_REPO_URI="http://winetricks.googlecode.com/svn/trunk"
inherit subversion
else
- SRC_URI="http://winetricks.googlecode.com/svn-history/r${PV}/trunk/src/winetricks -> ${P}
- http://winetricks.googlecode.com/svn-history/r${PV}/trunk/src/winetricks.1 -> ${P}.1"
+ SRC_URI="http://winetricks.org/download/releases/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
wtg=winetricks-gentoo-2012.11.24
@@ -41,22 +40,18 @@ S="${WORKDIR}"
src_unpack() {
if [[ ${PV} == "99999999" ]] ; then
subversion_src_unpack
+ if use gtk || use kde; then
+ unpack ${wtg}.tar.bz2
+ fi
else
- mkdir src
- cp "${DISTDIR}"/${P} src/${PN} || die
- cp "${DISTDIR}"/${P}.1 src/${PN}.1 || die
- fi
- if use gtk || use kde; then
- unpack ${wtg}.tar.bz2
+ default
fi
}
src_install() {
- cd src
- dobin ${PN}
- doman ${PN}.1
+ default
if use gtk || use kde; then
- cd ../${wtg} || die
+ cd ${wtg} || die
domenu winetricks.desktop
insinto /usr/share/icons/hicolor/scalable/apps
doins wine-winetricks.svg
diff --git a/app-emulation/winetricks/winetricks-99999999.ebuild b/app-emulation/winetricks/winetricks-99999999.ebuild
index 7f6bc275e667..8a3aa2fac294 100644
--- a/app-emulation/winetricks/winetricks-99999999.ebuild
+++ b/app-emulation/winetricks/winetricks-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/winetricks-99999999.ebuild,v 1.8 2013/06/15 03:58:20 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/winetricks-99999999.ebuild,v 1.9 2013/06/30 02:29:59 tetromino Exp $
EAPI=5
@@ -10,8 +10,7 @@ if [[ ${PV} == "99999999" ]] ; then
ESVN_REPO_URI="http://winetricks.googlecode.com/svn/trunk"
inherit subversion
else
- SRC_URI="http://winetricks.googlecode.com/svn-history/r${PV}/trunk/src/winetricks -> ${P}
- http://winetricks.googlecode.com/svn-history/r${PV}/trunk/src/winetricks.1 -> ${P}.1"
+ SRC_URI="http://winetricks.org/download/releases/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
wtg=winetricks-gentoo-2012.11.24
@@ -41,22 +40,18 @@ S="${WORKDIR}"
src_unpack() {
if [[ ${PV} == "99999999" ]] ; then
subversion_src_unpack
+ if use gtk || use kde; then
+ unpack ${wtg}.tar.bz2
+ fi
else
- mkdir src
- cp "${DISTDIR}"/${P} src/${PN} || die
- cp "${DISTDIR}"/${P}.1 src/${PN}.1 || die
- fi
- if use gtk || use kde; then
- unpack ${wtg}.tar.bz2
+ default
fi
}
src_install() {
- cd src
- dobin ${PN}
- doman ${PN}.1
+ default
if use gtk || use kde; then
- cd ../${wtg} || die
+ cd ${wtg} || die
domenu winetricks.desktop
insinto /usr/share/icons/hicolor/scalable/apps
doins wine-winetricks.svg