summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-12 05:00:19 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-12 05:00:19 +0000
commit98a2b980b09f39108312f333a9aa7737c9cc002f (patch)
tree8c9c4e6615d0108616babb4b50a49dc60621364d /app-emulation/winex-transgaming
parentFixed initscript to insert module as required. Bug #48837 by Rico Schiekel <_... (diff)
downloadgentoo-2-98a2b980b09f39108312f333a9aa7737c9cc002f.tar.gz
gentoo-2-98a2b980b09f39108312f333a9aa7737c9cc002f.tar.bz2
gentoo-2-98a2b980b09f39108312f333a9aa7737c9cc002f.zip
Version bump.
Diffstat (limited to 'app-emulation/winex-transgaming')
-rw-r--r--app-emulation/winex-transgaming/ChangeLog10
-rw-r--r--app-emulation/winex-transgaming/files/digest-winex-transgaming-3.3.21
-rw-r--r--app-emulation/winex-transgaming/winex-transgaming-3.3.2.ebuild54
3 files changed, 63 insertions, 2 deletions
diff --git a/app-emulation/winex-transgaming/ChangeLog b/app-emulation/winex-transgaming/ChangeLog
index 0b3f6076f3af..7c3c41b7f4d6 100644
--- a/app-emulation/winex-transgaming/ChangeLog
+++ b/app-emulation/winex-transgaming/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/winex-transgaming
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/ChangeLog,v 1.11 2004/04/16 20:41:04 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/ChangeLog,v 1.12 2004/05/12 05:00:19 vapier Exp $
+
+*winex-transgaming-3.3.2 (12 May 2004)
+
+ 12 May 2004; Mike Frysinger <vapier@gentoo.org>
+ +winex-transgaming-3.3.2.ebuild:
+ Version bump.
*winex-transgaming-3.3.1 (16 Apr 2004)
diff --git a/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.3.2 b/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.3.2
new file mode 100644
index 000000000000..7dc9d613bf5c
--- /dev/null
+++ b/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.3.2
@@ -0,0 +1 @@
+MD5 925950091ac3ce9c9eb648a7d707a69d winex3_3.3.2-1.i386.tgz 7205956
diff --git a/app-emulation/winex-transgaming/winex-transgaming-3.3.2.ebuild b/app-emulation/winex-transgaming/winex-transgaming-3.3.2.ebuild
new file mode 100644
index 000000000000..329cde37e917
--- /dev/null
+++ b/app-emulation/winex-transgaming/winex-transgaming-3.3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/winex-transgaming-3.3.2.ebuild,v 1.1 2004/05/12 05:00:19 vapier Exp $
+
+MY_P="winex3_${PV}-1.i386"
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ !app-emulation/winex"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate WineX archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo ""
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install () {
+ mv ${WORKDIR}/usr ${D}
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/winex3 to start winex as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the winex wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/winex:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to /etc/modules.autoload."
+}