summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-08-27 09:16:28 +0000
committerSimon Stelling <blubb@gentoo.org>2006-08-27 09:16:28 +0000
commit2aa12f38af18c901d664b598e9310e9595e98a4e (patch)
treee6554f1110040c25e055f849dca55490ed14fc55 /app-emulation/x86-chroot
parentKeep cross-compiler files in /usr/CHOST/CTARGET/ #144700. (diff)
downloadgentoo-2-2aa12f38af18c901d664b598e9310e9595e98a4e.tar.gz
gentoo-2-2aa12f38af18c901d664b598e9310e9595e98a4e.tar.bz2
gentoo-2-2aa12f38af18c901d664b598e9310e9595e98a4e.zip
xhost needs to be run outside the chroot
(Portage version: 2.1-r2)
Diffstat (limited to 'app-emulation/x86-chroot')
-rw-r--r--app-emulation/x86-chroot/ChangeLog5
-rw-r--r--app-emulation/x86-chroot/files/initd1
-rw-r--r--app-emulation/x86-chroot/x86-chroot-2006.0.ebuild10
3 files changed, 9 insertions, 7 deletions
diff --git a/app-emulation/x86-chroot/ChangeLog b/app-emulation/x86-chroot/ChangeLog
index 8e432f45d50e..c2aa90101c3a 100644
--- a/app-emulation/x86-chroot/ChangeLog
+++ b/app-emulation/x86-chroot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/x86-chroot
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x86-chroot/ChangeLog,v 1.1 2006/08/25 13:37:46 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x86-chroot/ChangeLog,v 1.2 2006/08/27 09:16:28 blubb Exp $
+
+ 27 Aug 2006; <blubb@gentoo.org> files/initd, x86-chroot-2006.0.ebuild:
+ xhost needs to be run outside the chroot
*x86-chroot-2006.0 (25 Aug 2006)
diff --git a/app-emulation/x86-chroot/files/initd b/app-emulation/x86-chroot/files/initd
index fa024f5c67d7..084447a474fc 100644
--- a/app-emulation/x86-chroot/files/initd
+++ b/app-emulation/x86-chroot/files/initd
@@ -25,6 +25,7 @@ start() {
[[ -f /etc/${conffile} ]] && cp -pf /etc/${conffile} ${CHROOT_LOCATION}/etc >/dev/null &
done
cp -Ppf /etc/localtime ${CHROOT_LOCATION}/etc >/dev/null &
+ which xhost &>/dev/null && xhost local:localhost &>/dev/null
eend $? "An error occured while attempting to copy 32 bits chroot files."
}
diff --git a/app-emulation/x86-chroot/x86-chroot-2006.0.ebuild b/app-emulation/x86-chroot/x86-chroot-2006.0.ebuild
index ddc7e4d4b3b5..b8604378e459 100644
--- a/app-emulation/x86-chroot/x86-chroot-2006.0.ebuild
+++ b/app-emulation/x86-chroot/x86-chroot-2006.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x86-chroot/x86-chroot-2006.0.ebuild,v 1.1 2006/08/25 13:37:46 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x86-chroot/x86-chroot-2006.0.ebuild,v 1.2 2006/08/27 09:16:28 blubb Exp $
inherit linux-info
@@ -11,9 +11,10 @@ SRC_URI="http://distfiles.gentoo.org/releases/x86/${PV}/stages/stage3-i686-${PV}
LICENSE="GPL-2"
SLOT="${PV}"
KEYWORDS="-* ~amd64"
-IUSE=""
+IUSE="X"
-RDEPEND="sys-apps/setarch"
+RDEPEND="sys-apps/setarch
+ X? ( x11-apps/xhost )"
CONFIG_CHECK="IA32_EMULATION"
CHROOT_LOCATION=${CHROOT_LOCATION:-/opt/x86-chroot}
@@ -46,9 +47,6 @@ src_compile() {
EOF
echo "env-update" >> "${WORKDIR}/${CHROOT_LOCATION}/root/.bashrc"
echo "CHROOT_LOCATION=${CHROOT_LOCATION}" > "${WORKDIR}/${CHROOT_LOCATION}/etc/conf.d/${PN}"
-
- echo "which xhost &>/dev/null && xhost local:localhost" >> \
- "${WORKDIR}/${CHROOT_LOCATION}/root/.bashrc"
}
src_install() {