summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2006-05-22 16:00:27 +0000
committerChris Bainbridge <chrb@gentoo.org>2006-05-22 16:00:27 +0000
commit5d6a577440c85d8286aa6d6e603403c4111faf75 (patch)
tree5f494464c7c7b84530e6c95d0111a456ef416665 /app-emulation/xen
parentMake ortp depend really optional and do not always enable-libjingle thanks to... (diff)
downloadgentoo-2-5d6a577440c85d8286aa6d6e603403c4111faf75.tar.gz
gentoo-2-5d6a577440c85d8286aa6d6e603403c4111faf75.tar.bz2
gentoo-2-5d6a577440c85d8286aa6d6e603403c4111faf75.zip
Add hardened patch, thanks to Solar in bug #130167
(Portage version: 2.1_rc1-r4)
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/ChangeLog7
-rw-r--r--app-emulation/xen/files/xen-3.0.2-nopiessp.patch10
-rw-r--r--app-emulation/xen/xen-3.0.2.ebuild8
3 files changed, 22 insertions, 3 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index b787e1c22a4d..f9403c6fa150 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.36 2006/04/10 13:23:20 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.37 2006/05/22 16:00:27 chrb Exp $
+
+ 22 May 2006; <chrb@gentoo.org> +files/xen-3.0.2-nopiessp.patch,
+ -xen-3.0.1-r4.ebuild, -xen-3.0.1-r5.ebuild, -xen-3.0.1_p9029.ebuild,
+ xen-3.0.2.ebuild:
+ Add hardened patch, thanks to Solar in bug #130167
10 Apr 2006; <chrb@gentoo.org> xen-3.0.2.ebuild:
fix pae, again, #124355
diff --git a/app-emulation/xen/files/xen-3.0.2-nopiessp.patch b/app-emulation/xen/files/xen-3.0.2-nopiessp.patch
new file mode 100644
index 000000000000..27351247b925
--- /dev/null
+++ b/app-emulation/xen/files/xen-3.0.2-nopiessp.patch
@@ -0,0 +1,10 @@
+--- ./xen/Rules.mk 2006-04-09 22:05:55.000000000 +0000
++++ ./xen/Rules.mk 2006-04-16 16:39:26.000000000 +0000
+@@ -48,6 +48,7 @@
+ ALL_OBJS-y += $(BASEDIR)/arch/$(TARGET_ARCH)/built_in.o
+
+ CFLAGS-y += -g -D__XEN__
++CFLAGS-y += -fno-pie -fno-stack-protector-all -fno-stack-protector
+ CFLAGS-$(ACM_SECURITY) += -DACM_SECURITY
+ CFLAGS-$(verbose) += -DVERBOSE
+ CFLAGS-$(crash_debug) += -DCRASH_DEBUG
diff --git a/app-emulation/xen/xen-3.0.2.ebuild b/app-emulation/xen/xen-3.0.2.ebuild
index cec9a8477663..b65a1f50650a 100644
--- a/app-emulation/xen/xen-3.0.2.ebuild
+++ b/app-emulation/xen/xen-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.2.ebuild,v 1.3 2006/04/10 13:23:20 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.2.ebuild,v 1.4 2006/05/22 16:00:27 chrb Exp $
inherit mount-boot flag-o-matic
@@ -18,7 +18,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug custom-cflags pae"
+IUSE="debug custom-cflags pae hardened"
DEPEND="sys-devel/dev86"
RDEPEND=""
@@ -37,6 +37,10 @@ src_unpack() {
-e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
-i {} \;
fi
+ if use hardened; then
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-3.0.2-nopiessp.patch
+ fi
}
src_compile() {