summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-08-08 23:06:31 +0000
committerUlrich Müller <ulm@gentoo.org>2008-08-08 23:06:31 +0000
commit4c7928e9e5ea4f4a58945ab713f2b5b750868c35 (patch)
tree26a1abee79b0932f8ca39b72d969f66faa397e17 /app-emulation/xtrs/files
parentInitial import. (diff)
downloadgentoo-2-4c7928e9e5ea4f4a58945ab713f2b5b750868c35.tar.gz
gentoo-2-4c7928e9e5ea4f4a58945ab713f2b5b750868c35.tar.bz2
gentoo-2-4c7928e9e5ea4f4a58945ab713f2b5b750868c35.zip
Remove old.
(Portage version: 2.2_rc6/cvs/Linux 2.6.25-gentoo-r6 i686)
Diffstat (limited to 'app-emulation/xtrs/files')
-rw-r--r--app-emulation/xtrs/files/xtrs-4.9c-gentoo.patch92
-rw-r--r--app-emulation/xtrs/files/xtrs-4.9c-r2-gentoo.patch60
2 files changed, 33 insertions, 119 deletions
diff --git a/app-emulation/xtrs/files/xtrs-4.9c-gentoo.patch b/app-emulation/xtrs/files/xtrs-4.9c-gentoo.patch
index c9f5029b6afc..27f1ee1a0fcc 100644
--- a/app-emulation/xtrs/files/xtrs-4.9c-gentoo.patch
+++ b/app-emulation/xtrs/files/xtrs-4.9c-gentoo.patch
@@ -1,80 +1,54 @@
-diff -Nur xtrs-4.9c-orig/ChangeLog xtrs-4.9c/ChangeLog
---- xtrs-4.9c-orig/ChangeLog 2006-05-15 02:55:28.000000000 +0200
-+++ xtrs-4.9c/ChangeLog 2007-04-25 22:12:20.000000000 +0200
-@@ -1,3 +1,11 @@
-+4.9c-Gentoo -- Sat Apr 21 14:37:00 MDT 2007 Joe Peterson <joe@skyrush.com>
+diff -Nurp xtrs-4.9c-orig/ChangeLog xtrs-4.9c/ChangeLog
+--- xtrs-4.9c-orig/ChangeLog 2006-05-14 18:55:28.000000000 -0600
++++ xtrs-4.9c/ChangeLog 2008-06-26 16:57:23.000000000 -0600
+@@ -1,3 +1,13 @@
++4.9c-Gentoo -- Thu Jun 26 16:57:16 MDT 2008 -- Joe Peterson <joe@skyrush.com>
+
+* Patched for Gentoo ebuild
+ - Added assignment to volatile variable in the z80 delay loop
+ (allows near-actual speed emulation with optimization)
+ - Fixed keyboard wait issue that caused CPU spinning (i.e. max
+ CPU usage) after using F10 (reset), F7, F8, or F9.
++ - Disable SIGIO
++ - Added NEWDOS/80 system date/time auto-initialization
+
4.9c -- Sun May 14 17:54:25 PDT 2006 -- Tim Mann
* Fixed the new -e flag on import/cmd and export/cmd to actually
-diff -Nur xtrs-4.9c-orig/main.c xtrs-4.9c/main.c
---- xtrs-4.9c-orig/main.c 2002-04-14 09:03:43.000000000 +0200
-+++ xtrs-4.9c/main.c 2007-04-25 22:12:20.000000000 +0200
-@@ -26,7 +26,7 @@
- #include "trs_disk.h"
- #include "load_cmd.h"
+diff -Nurp xtrs-4.9c-orig/Makefile xtrs-4.9c/Makefile
+--- xtrs-4.9c-orig/Makefile 2006-05-13 15:10:25.000000000 -0600
++++ xtrs-4.9c/Makefile 2008-06-26 16:48:15.000000000 -0600
+@@ -143,7 +143,7 @@ z80code: $(Z80CODE)
+ include Makefile.local
--int trs_model = 1;
-+int trs_model = 5;
- int trs_paused = 1;
- int trs_autodelay = 0;
- char *program_name;
-diff -Nur xtrs-4.9c-orig/trs.h xtrs-4.9c/trs.h
---- xtrs-4.9c-orig/trs.h 2006-05-13 23:05:59.000000000 +0200
-+++ xtrs-4.9c/trs.h 2007-04-25 22:12:20.000000000 +0200
-@@ -67,6 +67,7 @@
- extern void queue_key(int key);
- extern int dequeue_key(void);
- extern void clear_key_queue(void);
-+extern void trs_start_kbwait(void);
- extern void trs_end_kbwait(void);
- extern int stretch_amount;
+ CFLAGS = $(DEBUG) $(ENDIAN) $(DEFAULT_ROM) $(READLINE) $(DISKDIR) $(IFLAGS) \
+- $(APPDEFAULTS) -DKBWAIT -DHAVE_SIGIO
++ $(APPDEFAULTS) -DKBWAIT
+ LIBS = $(XLIB) $(READLINELIBS) $(EXTRALIBS)
-diff -Nur xtrs-4.9c-orig/trs_keyboard.c xtrs-4.9c/trs_keyboard.c
---- xtrs-4.9c-orig/trs_keyboard.c 2006-05-13 22:50:17.000000000 +0200
-+++ xtrs-4.9c/trs_keyboard.c 2007-04-25 22:12:20.000000000 +0200
-@@ -983,6 +983,12 @@
- }
-
- void
-+trs_start_kbwait()
-+{
-+ key_immediate = 0;
-+}
-+
-+void
- trs_end_kbwait()
- {
- key_immediate = 1;
-@@ -1003,7 +1009,6 @@
+ ZMACFLAGS = -h
+diff -Nurp xtrs-4.9c-orig/trs_keyboard.c xtrs-4.9c/trs_keyboard.c
+--- xtrs-4.9c-orig/trs_keyboard.c 2006-05-13 14:50:17.000000000 -0600
++++ xtrs-4.9c/trs_keyboard.c 2008-06-26 16:46:03.000000000 -0600
+@@ -998,12 +998,12 @@ int trs_next_key(int wait)
+ if ((z80_state.nmi && !z80_state.nmi_seen) ||
+ (z80_state.irq && z80_state.iff1) ||
+ trs_event_scheduled() || key_immediate) {
++ key_immediate = 0;
+ rval = -1;
+ break;
}
trs_paused = 1;
- pause(); /* Wait for SIGALRM or SIGIO */
+- pause(); /* Wait for SIGALRM or SIGIO */
- key_immediate = 0;
++ pause(); /* Wait for SIGALRM */
trs_get_event(0);
}
return rval;
-diff -Nur xtrs-4.9c-orig/trs_xinterface.c xtrs-4.9c/trs_xinterface.c
---- xtrs-4.9c-orig/trs_xinterface.c 2006-05-13 23:33:51.000000000 +0200
-+++ xtrs-4.9c/trs_xinterface.c 2007-04-25 22:12:20.000000000 +0200
-@@ -920,6 +920,7 @@
- (void)trs_uart_check_avail();
- }
-
-+ trs_start_kbwait();
- do {
- if (wait) {
- XNextEvent(display, &event);
-diff -Nur xtrs-4.9c-orig/z80.c xtrs-4.9c/z80.c
---- xtrs-4.9c-orig/z80.c 2005-05-22 08:57:01.000000000 +0200
-+++ xtrs-4.9c/z80.c 2007-04-25 22:12:20.000000000 +0200
-@@ -3027,7 +3027,8 @@
+diff -Nurp xtrs-4.9c-orig/z80.c xtrs-4.9c/z80.c
+--- xtrs-4.9c-orig/z80.c 2005-05-22 00:57:01.000000000 -0600
++++ xtrs-4.9c/z80.c 2008-06-26 16:44:32.000000000 -0600
+@@ -3027,7 +3027,8 @@ int z80_run(int continuous)
#endif
/* Speed control */
if ((i = z80_state.delay)) {
diff --git a/app-emulation/xtrs/files/xtrs-4.9c-r2-gentoo.patch b/app-emulation/xtrs/files/xtrs-4.9c-r2-gentoo.patch
deleted file mode 100644
index 27f1ee1a0fcc..000000000000
--- a/app-emulation/xtrs/files/xtrs-4.9c-r2-gentoo.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -Nurp xtrs-4.9c-orig/ChangeLog xtrs-4.9c/ChangeLog
---- xtrs-4.9c-orig/ChangeLog 2006-05-14 18:55:28.000000000 -0600
-+++ xtrs-4.9c/ChangeLog 2008-06-26 16:57:23.000000000 -0600
-@@ -1,3 +1,13 @@
-+4.9c-Gentoo -- Thu Jun 26 16:57:16 MDT 2008 -- Joe Peterson <joe@skyrush.com>
-+
-+* Patched for Gentoo ebuild
-+ - Added assignment to volatile variable in the z80 delay loop
-+ (allows near-actual speed emulation with optimization)
-+ - Fixed keyboard wait issue that caused CPU spinning (i.e. max
-+ CPU usage) after using F10 (reset), F7, F8, or F9.
-+ - Disable SIGIO
-+ - Added NEWDOS/80 system date/time auto-initialization
-+
- 4.9c -- Sun May 14 17:54:25 PDT 2006 -- Tim Mann
-
- * Fixed the new -e flag on import/cmd and export/cmd to actually
-diff -Nurp xtrs-4.9c-orig/Makefile xtrs-4.9c/Makefile
---- xtrs-4.9c-orig/Makefile 2006-05-13 15:10:25.000000000 -0600
-+++ xtrs-4.9c/Makefile 2008-06-26 16:48:15.000000000 -0600
-@@ -143,7 +143,7 @@ z80code: $(Z80CODE)
- include Makefile.local
-
- CFLAGS = $(DEBUG) $(ENDIAN) $(DEFAULT_ROM) $(READLINE) $(DISKDIR) $(IFLAGS) \
-- $(APPDEFAULTS) -DKBWAIT -DHAVE_SIGIO
-+ $(APPDEFAULTS) -DKBWAIT
- LIBS = $(XLIB) $(READLINELIBS) $(EXTRALIBS)
-
- ZMACFLAGS = -h
-diff -Nurp xtrs-4.9c-orig/trs_keyboard.c xtrs-4.9c/trs_keyboard.c
---- xtrs-4.9c-orig/trs_keyboard.c 2006-05-13 14:50:17.000000000 -0600
-+++ xtrs-4.9c/trs_keyboard.c 2008-06-26 16:46:03.000000000 -0600
-@@ -998,12 +998,12 @@ int trs_next_key(int wait)
- if ((z80_state.nmi && !z80_state.nmi_seen) ||
- (z80_state.irq && z80_state.iff1) ||
- trs_event_scheduled() || key_immediate) {
-+ key_immediate = 0;
- rval = -1;
- break;
- }
- trs_paused = 1;
-- pause(); /* Wait for SIGALRM or SIGIO */
-- key_immediate = 0;
-+ pause(); /* Wait for SIGALRM */
- trs_get_event(0);
- }
- return rval;
-diff -Nurp xtrs-4.9c-orig/z80.c xtrs-4.9c/z80.c
---- xtrs-4.9c-orig/z80.c 2005-05-22 00:57:01.000000000 -0600
-+++ xtrs-4.9c/z80.c 2008-06-26 16:44:32.000000000 -0600
-@@ -3027,7 +3027,8 @@ int z80_run(int continuous)
- #endif
- /* Speed control */
- if ((i = z80_state.delay)) {
-- while (--i) /*nothing*/;
-+ volatile int dummy;
-+ while (--i) dummy = i;
- }
-
- instruction = mem_read(REG_PC++);