summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-05 17:39:59 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-05 17:39:59 +0000
commit57df7e0106b119a9bc6714f3fe2b8c33c5e750ae (patch)
tree1a74df42b7a9b6b9c53ec649a1abaf9d1e444c77 /app-emulation/zsnes
parentfixes (diff)
downloadgentoo-2-57df7e0106b119a9bc6714f3fe2b8c33c5e750ae.tar.gz
gentoo-2-57df7e0106b119a9bc6714f3fe2b8c33c5e750ae.tar.bz2
gentoo-2-57df7e0106b119a9bc6714f3fe2b8c33c5e750ae.zip
zsnes is a great snes emulator.
Diffstat (limited to 'app-emulation/zsnes')
-rw-r--r--app-emulation/zsnes/files/digest-zsnes-1.3371
-rw-r--r--app-emulation/zsnes/zsnes-1.337.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/zsnes/files/digest-zsnes-1.337 b/app-emulation/zsnes/files/digest-zsnes-1.337
new file mode 100644
index 000000000000..b6fcfd8dd5a7
--- /dev/null
+++ b/app-emulation/zsnes/files/digest-zsnes-1.337
@@ -0,0 +1 @@
+MD5 092740f7ee0e3fbf92016a45f0a0df8b zsnes1337src.tar.gz
diff --git a/app-emulation/zsnes/zsnes-1.337.ebuild b/app-emulation/zsnes/zsnes-1.337.ebuild
new file mode 100644
index 000000000000..5f43249ad029
--- /dev/null
+++ b/app-emulation/zsnes/zsnes-1.337.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/zsnes-1.337.ebuild,v 1.1 2001/10/05 17:39:59 danarmak Exp $
+# Don't attempt to introduce $CFLAGS usage, docs say result will be slower.
+
+DESCRIPTION="zsnes is an excellent snes (super nintendo) emulator"
+
+SRC_URI="http://prdownloads.suorceforge.net/zsnes/zsnes1337src.tar.gz"
+
+HOMEPAGE="http://www.zsnes.com/"
+
+S=${WORKDIR}/${P}
+
+DEP="opengl? ( virtual/opengl )
+ virtual/x11
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib
+ media-libs/libpng"
+
+DEPEND="sys-devel/gcc
+ virtual/glibc
+ sys-devel/make
+ >=dev-lang/nasm-0.98
+ $DEP"
+
+RDEPEND="$DEP"
+
+src_compile() {
+ cd ${S}/src
+ use opengl || myconf="--without-opengl"
+ ./configure --prefix=/usr --host=${CHOST} $myconf || die
+ make
+}
+src_install () {
+ cd ${S}/src
+ into /usr
+ dobin zsnes
+ doman linux/zsnes.man
+ cd ${S}
+ dodoc *.txt linux/*
+}
+