summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2011-03-12 19:11:19 +0000
committerLance Albertson <ramereth@gentoo.org>2011-03-12 19:11:19 +0000
commit1dc16a720634076399768fc3bb923ab4df270fc7 (patch)
tree942f80ffa11715f1b31fbc13400e38a340a66ae2 /app-emulation
parentalpha/arm/ia64/sparc stable wrt #353436 (diff)
downloadgentoo-2-1dc16a720634076399768fc3bb923ab4df270fc7.tar.gz
gentoo-2-1dc16a720634076399768fc3bb923ab4df270fc7.tar.bz2
gentoo-2-1dc16a720634076399768fc3bb923ab4df270fc7.zip
version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti-htools/ChangeLog8
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/app-emulation/ganeti-htools/ChangeLog b/app-emulation/ganeti-htools/ChangeLog
index dda52286c26c..0961fe300af3 100644
--- a/app-emulation/ganeti-htools/ChangeLog
+++ b/app-emulation/ganeti-htools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/ganeti-htools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.8 2011/03/07 19:00:05 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.9 2011/03/12 19:11:19 ramereth Exp $
+
+*ganeti-htools-0.3.1 (12 Mar 2011)
+
+ 12 Mar 2011; Lance Albertson <ramereth@gentoo.org>
+ +ganeti-htools-0.3.1.ebuild:
+ Version bump
07 Mar 2011; Lance Albertson <ramereth@gentoo.org>
ganeti-htools-0.2.8.ebuild:
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
new file mode 100644
index 000000000000..819c0a998e9e
--- /dev/null
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild,v 1.1 2011/03/12 19:11:19 ramereth Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
+clusters."
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/ghc
+ dev-haskell/json
+ dev-haskell/curl
+ dev-haskell/network
+ dev-haskell/parallel"
+RDEPEND="${DEPEND}
+ !<app-emulation/ganeti-2.4"
+
+src_prepare() {
+ # htools does not currently compile cleanly with ghc-6.12+, so remove this
+ # for now
+ sed -i -e "s:-Werror ::" Makefile
+ # Workaround to skip pandoc
+ sed -i -e "s:) man:):" Makefile
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dosbin hspace hscan hbal
+ exeinto /usr/$(get_libdir)/ganeti/iallocators
+ doexe hail
+ doman man/*.1
+ dodoc README NEWS AUTHORS
+ use doc && dohtml -r apidoc/*
+}