summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2007-02-07 20:38:55 +0000
committerLuca Barbato <lu_zero@gentoo.org>2007-02-07 20:38:55 +0000
commit1f334fc216d57a719b7e3ed79ed50962f4e9c52d (patch)
tree5c4bddbefa3ef3fc31d9a48303f3079d550e5fcd /app-emulation
parentstable on amd64; bug 163611 (diff)
downloadgentoo-2-1f334fc216d57a719b7e3ed79ed50962f4e9c52d.tar.gz
gentoo-2-1f334fc216d57a719b7e3ed79ed50962f4e9c52d.tar.bz2
gentoo-2-1f334fc216d57a719b7e3ed79ed50962f4e9c52d.zip
New version
(Portage version: 2.1.2-r8)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog7
-rw-r--r--app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.03
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.9.0.ebuild110
3 files changed, 119 insertions, 1 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index d304fa2503d8..90f8a9491cd7 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-softmmu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.32 2007/02/06 14:48:34 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.33 2007/02/07 20:38:55 lu_zero Exp $
+
+*qemu-softmmu-0.9.0 (07 Feb 2007)
+
+ 07 Feb 2007; Luca Barbato <lu_zero@gentoo.org> +qemu-softmmu-0.9.0.ebuild:
+ New version
06 Feb 2007; Simon Stelling <blubb@gentoo.org>
qemu-softmmu-0.8.2-r1.ebuild:
diff --git a/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.0 b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.0
new file mode 100644
index 000000000000..2079a38f6c73
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.9.0
@@ -0,0 +1,3 @@
+MD5 ab11a03ba30cf4a70641f0f170473d69 qemu-0.9.0.tar.gz 1901741
+RMD160 4296542b6da18a6ac93d20787330d3c1c2ac0a19 qemu-0.9.0.tar.gz 1901741
+SHA256 491facf9335654967ee53d8fb3540a274bfcbdcc225506bd38c4ee8e9ab405c1 qemu-0.9.0.tar.gz 1901741
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.9.0.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.9.0.ebuild
new file mode 100644
index 000000000000..7faf2ad4a31f
--- /dev/null
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.9.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.9.0.ebuild,v 1.1 2007/02/07 20:38:55 lu_zero Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="${HOMEPAGE}${P/-softmmu/}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~ppc -sparc ~x86"
+IUSE="sdl kqemu alsa" #qvm86 debug nptl qemu-fast nptlonly"
+RESTRICT="nostrip test"
+
+DEPEND="virtual/libc
+ sdl? ( media-libs/libsdl )
+ !<=app-emulation/qemu-0.7.0
+ kqemu? ( >=app-emulation/kqemu-1.3.0_pre10 )
+ app-text/texi2html"
+RDEPEND="sdl? ( media-libs/libsdl )
+ alsa? ( media-libs/alsa-lib )"
+
+S="${WORKDIR}/${P/-softmmu/}"
+
+QA_TEXTRELS="usr/bin/qemu
+ usr/bin/qemu-system-sparc
+ usr/bin/qemu-system-arm
+ usr/bin/qemu-system-ppc
+ usr/bin/qemu-system-mips
+ usr/bin/qemu-system-x86_64"
+QA_EXECSTACK="usr/share/qemu/openbios-sparc32"
+QA_WX_LOAD="usr/share/qemu/openbios-sparc32"
+
+set_target_list() {
+ TARGET_LIST="i386-softmmu ppc-softmmu sparc-softmmu x86_64-softmmu arm-softmmu mips-softmmu"
+ export TARGET_LIST
+}
+
+pkg_setup() {
+ if [ "$(gcc-major-version)" == "4" ]; then
+ eerror "qemu requires gcc-3 in order to build and work correctly"
+ eerror "please compile it switching to gcc-3."
+ eerror "We are aware that qemu can guess a gcc-3 but this feature"
+ eerror "could be harmful."
+ die "gcc 4 cannot build qemu"
+ fi
+}
+
+#RUNTIME_PATH="/emul/gnemul/"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Alter target makefiles to accept CFLAGS set via flag-o.
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
+ # Ensure mprotect restrictions are relaxed for emulator binaries
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # Prevent install of kernel module by qemu's makefile
+ sed -i 's/\(.\/install.sh\)/#\1/' Makefile
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ set_target_list
+
+ myconf="--disable-gcc-check"
+ if ! use sdl ; then
+ myconf="$myconf --disable-gfx-check"
+ fi
+ ./configure \
+ --prefix=/usr \
+ --target-list="${TARGET_LIST}" \
+ --enable-slirp --enable-adlib \
+ --cc=$(tc-getCC) \
+ --host-cc=$(tc-getCC) \
+ --kernel-path=${KV_DIR} \
+ $(use_enable sdl)\
+ $(use_enable kqemu) \
+ $(use_enable alsa) \
+ ${myconf} \
+ || die "could not configure"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ datadir=${D}/usr/share/qemu \
+ docdir=${D}/usr/share/doc/${P} \
+ mandir=${D}/usr/share/man || die
+
+ chmod -x ${D}/usr/share/man/*/*
+}
+
+pkg_postinst() {
+ einfo "You will need the Universal TUN/TAP driver compiled into"
+ einfo "kernel or as a module to use the virtual network device."
+}