summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-03-27 04:26:13 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-03-27 04:26:13 +0000
commit2339ef4b39f38fc1168bc28847b43603c5374c70 (patch)
tree87c8576dc472545d8e628b6dafedb5d47d9abc4e /app-emulation
parentnew package (bug 14170) (diff)
downloadgentoo-2-2339ef4b39f38fc1168bc28847b43603c5374c70.tar.gz
gentoo-2-2339ef4b39f38fc1168bc28847b43603c5374c70.tar.bz2
gentoo-2-2339ef4b39f38fc1168bc28847b43603c5374c70.zip
new rc2 of vmware-workstation 4.0 (build 4388)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-workstation/files/4.0.4388/90vmware3
-rw-r--r--app-emulation/vmware-workstation/files/4.0.4388/VMwareWorkstation.desktop12
-rw-r--r--app-emulation/vmware-workstation/files/4.0.4388/vmware73
-rw-r--r--app-emulation/vmware-workstation/files/4.0.4388/vmware.pngbin0 -> 470 bytes
-rw-r--r--app-emulation/vmware-workstation/files/digest-vmware-workstation-4.0.43881
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-4.0.4388.ebuild184
6 files changed, 273 insertions, 0 deletions
diff --git a/app-emulation/vmware-workstation/files/4.0.4388/90vmware b/app-emulation/vmware-workstation/files/4.0.4388/90vmware
new file mode 100644
index 000000000000..8e00d2bb0587
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/4.0.4388/90vmware
@@ -0,0 +1,3 @@
+PATH=/opt/vmware/bin
+ROOTPATH=/opt/vmware/bin
+MANPATH=/opt/vmware/man
diff --git a/app-emulation/vmware-workstation/files/4.0.4388/VMwareWorkstation.desktop b/app-emulation/vmware-workstation/files/4.0.4388/VMwareWorkstation.desktop
new file mode 100644
index 000000000000..9e42f9c1b4c6
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/4.0.4388/VMwareWorkstation.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=VMware Workstation
+Comment=VMware Workstation
+GenericName=Virtual PC Emulator
+Exec=vmware
+Icon=/opt/vmware/lib/icon/vmware.png
+Path=
+Terminal=0
+TerminalOptions=
+Type=Application
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/app-emulation/vmware-workstation/files/4.0.4388/vmware b/app-emulation/vmware-workstation/files/4.0.4388/vmware
new file mode 100644
index 000000000000..1c7af05709dc
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/4.0.4388/vmware
@@ -0,0 +1,73 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/files/4.0.4388/vmware,v 1.1 2003/03/27 04:26:13 drobbins Exp $
+
+depend() {
+ need localmount
+ use logger net
+}
+
+vmware-prettify() {
+ # Yea, the code is ugly but the output is pretty
+ state=$1
+ waserror=0
+ msgtype=0
+ while read line
+ do
+ [ "$line" == "" ] && continue
+ if [ "$msgtype" -le "0" ]
+ then
+ if [ "$msgtype" == "-1" ]
+ then
+ ewarn $line
+ continue
+ fi
+ if [ "${line/*:*/}" == "" ]
+ then
+ einfon $line
+ echo
+ eend 0
+ msgtype=1
+ else
+ ewarn $line
+ msgtype=-1
+ waserror=1
+ fi
+ continue
+ fi
+
+ # Strip out anything after the <esc> code
+ message=`echo $line | sed -e "s/^\(.*\).*$/\1/"`
+ einfon " $message"
+ echo
+
+ echo $line | grep done > /dev/null
+ status=$?
+ eend $status
+
+ if [ "$status" != "0" ]
+ then
+ logger -p local0.err -t vmware-${state} "$line"
+ waserror=$status
+ fi
+ done
+ if [ "$msgtype" == "-1" ]
+ then
+ eend 1 "VMware is not properly configured! See above."
+ fi
+ return $waserror
+}
+
+start() {
+ test -x /etc/vmware/init.d/vmware || \
+ eend 1 "vmware init script not found. Aborting" || return 1
+
+ /etc/vmware/init.d/vmware start | vmware-prettify start
+ return $?
+}
+
+stop() {
+ /etc/vmware/init.d/vmware stop | vmware-prettify stop
+ return $?
+}
diff --git a/app-emulation/vmware-workstation/files/4.0.4388/vmware.png b/app-emulation/vmware-workstation/files/4.0.4388/vmware.png
new file mode 100644
index 000000000000..06672aa3f0bf
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/4.0.4388/vmware.png
Binary files differ
diff --git a/app-emulation/vmware-workstation/files/digest-vmware-workstation-4.0.4388 b/app-emulation/vmware-workstation/files/digest-vmware-workstation-4.0.4388
new file mode 100644
index 000000000000..a56eeeec9036
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/digest-vmware-workstation-4.0.4388
@@ -0,0 +1 @@
+MD5 7783de769394f8020de270af1694c664 VMware-workstation-e.x.p-4388.tar.gz 23150976
diff --git a/app-emulation/vmware-workstation/vmware-workstation-4.0.4388.ebuild b/app-emulation/vmware-workstation/vmware-workstation-4.0.4388.ebuild
new file mode 100644
index 000000000000..284c4a1caefc
--- /dev/null
+++ b/app-emulation/vmware-workstation/vmware-workstation-4.0.4388.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-4.0.4388.ebuild,v 1.1 2003/03/27 04:26:13 drobbins Exp $
+
+# Unlike many other binary packages the user doesn't need to agree to a licence
+# to download VM Ware. The agreeing to a licence is part of the configure step
+# which the user must run manually.
+
+S=${WORKDIR}/vmware-distrib
+NP="VMware-workstation-e.x.p-4388"
+DESCRIPTION="Emulate a complete PC on your PC without the usual performance overhead of most emulators"
+SRC_URI="http://vmware-svca.www.conxion.com/software/${NP}.tar.gz
+ http://download.vmware.com/htdocs/software/${NP}.tar.gz
+ http://www.vmware.com/download1/software/${NP}.tar.gz
+ ftp://download1.vmware.com/pub/software/${NP}.tar.gz
+ http://vmware-chil.www.conxion.com/software/${NP}.tar.gz
+ http://vmware-heva.www.conxion.com/software/${NP}.tar.gz
+ http://vmware.wespe.de/software/${NP}.tar.gz
+ ftp://vmware.wespe.de/pub/software/${NP}.tar.gz"
+HOMEPAGE="http://www.vmware.com/products/desktop/ws_features.html"
+
+SLOT="0"
+LICENSE="vmware"
+KEYWORDS="-* ~x86"
+IUSE="kde"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ sys-kernel/linux-headers
+ >=dev-lang/perl-5
+ >=dev-lang/tcl-8.3.3
+ sys-apps/pciutils"
+
+RDEPEND=${DEPEND}
+
+RESTRICT="nostrip"
+
+src_install() {
+ # lets make gcc happy regardless of what version we're using
+# patch -p0 < ${FILESDIR}/${PVR}/vmware-config.pl-gcc-generalized.patch
+
+ dodir /opt/vmware/bin
+ cp -a bin/* ${D}/opt/vmware/bin/
+ # vmware and vmware-ping needs to be suid root.
+ chmod u+s ${D}/opt/vmware/bin/vmware || die
+ chmod u+s ${D}/opt/vmware/bin/vmware-ping || die
+
+ dodir /opt/vmware/lib
+ cp -a lib/* ${D}/opt/vmware/lib/
+
+ chmod u+s ${D}/opt/vmware/lib/bin/vmware-vmx || die
+
+ # Since with Gentoo we compile everthing it doesn't make sense to keep
+ # the precompiled modules arround. Saves about 4 megs of disk space too.
+ rm -rf ${D}/opt/vmware/lib/modules/binary
+
+ dodir /opt/vmware/doc
+ cp -a doc/* ${D}/opt/vmware/doc/
+
+ dodir /opt/vmware/man/
+ cp -a man/* ${D}/opt/vmware/man/
+
+ # vmware service loader
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PVR}/vmware vmware || die
+
+ # vmware enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/90vmware || die
+
+ dodir /etc/vmware/
+ cp -a etc/* ${D}/etc/vmware/
+
+ dodir /etc/vmware/init.d
+ dodir /etc/vmware/init.d/rc0.d
+ dodir /etc/vmware/init.d/rc1.d
+ dodir /etc/vmware/init.d/rc2.d
+ dodir /etc/vmware/init.d/rc3.d
+ dodir /etc/vmware/init.d/rc4.d
+ dodir /etc/vmware/init.d/rc5.d
+ dodir /etc/vmware/init.d/rc6.d
+ cp -a installer/services.sh ${D}/etc/vmware/init.d/vmware || die
+
+ # This is to fix a problem where if someone merges vmware and then
+ # before configuring vmware they upgrade or re-merge the vmware
+ # package which would rmdir the /etc/vmware/init.d/rc?.d directories.
+ keepdir /etc/vmware/init.d/rc{0,1,2,3,4,5,6}.d
+
+ # A simple icon I made
+ dodir /opt/vmware/lib/icon
+ insinto /opt/vmware/lib/icon
+ doins ${FILESDIR}/${PVR}/vmware.png || die
+
+ if [ "`use kde`" ] ; then
+ dodir /usr/share/applnk/Applications
+ insinto /usr/share/applnk/Applications
+ doins "${FILESDIR}/${PVR}/VMwareWorkstation.desktop"
+ fi
+
+
+ dodir /usr/bin
+ dosym /opt/vmware/bin/vmware /usr/bin/vmware
+
+ # Questions:
+ einfo "Adding answers to /etc/vmware/locations"
+ locations="${D}/etc/vmware/locations"
+ echo "answer BINDIR /opt/vmware/bin" >> ${locations}
+ echo "answer LIBDIR /opt/vmware/lib" >> ${locations}
+ echo "answer MANDIR /opt/vmware/man" >> ${locations}
+ echo "answer DOCDIR /opt/vmware/doc" >> ${locations}
+ echo "answer RUN_CONFIGURATOR no" >> ${locations}
+ echo "answer INITDIR /etc/vmware/init.d" >> ${locations}
+ echo "answer INITSCRIPTSDIR /etc/vmware/init.d" >> ${locations}
+}
+
+pkg_preinst() {
+ # This must be done after the install to get the mtimes on each file
+ # right. This perl snippet gets the /etc/vmware/locations file code:
+ # perl -e "@a = stat('bin/vmware'); print \$a[9]"
+ # The above perl line and the find line below output the same thing.
+ # I would think the find line is faster to execute.
+ # find /opt/vmware/bin/vmware -printf %T@
+
+ #Note: it's a bit weird to use ${D} in a preinst script but it should work
+ #(drobbins, 1 Feb 2002)
+
+ einfo "Generating /etc/vmware/locations file."
+ d=`echo ${D} | wc -c`
+ for x in `find ${D}/opt/vmware ${D}/etc/vmware` ; do
+ x="`echo ${x} | cut -c ${d}-`"
+ if [ -d ${D}/${x} ] ; then
+ echo "directory ${x}" >> ${D}/etc/vmware/locations
+ else
+ echo -n "file ${x}" >> ${D}/etc/vmware/locations
+ if [ "${x}" == "/etc/vmware/locations" ] ; then
+ echo "" >> ${D}/etc/vmware/locations
+ elif [ "${x}" == "/etc/vmware/not_configured" ] ; then
+ echo "" >> ${D}/etc/vmware/locations
+ else
+ echo -n " " >> ${D}/etc/vmware/locations
+ #perl -e "@a = stat('${D}${x}'); print \$a[9]" >> ${D}/etc/vmware/locations
+ find ${D}${x} -printf %T@ >> ${D}/etc/vmware/locations
+ echo "" >> ${D}/etc/vmware/locations
+ fi
+ fi
+ done
+}
+
+pkg_config() {
+ # In case pkg_config() ends up being the defacto standard for
+ # configuring packages (malverian <malverian@gentoo.org>)
+
+ einfo "Running /opt/vmware/bin/vmware-config.pl"
+ /opt/vmware/bin/vmware-config.pl
+}
+
+pkg_postinst() {
+ # This is to fix the problem where the not_configured file doesn't get
+ # removed when the configuration is run. This doesn't remove the file
+ # It just tells the vmware-config.pl script it can delete it.
+ einfo "Updating /etc/vmware/locations"
+ for x in /etc/vmware/._cfg????_locations ; do
+ if [ -f $x ] ; then
+ cat $x >> /etc/vmware/locations
+ rm $x
+ fi
+ done
+
+ einfo
+ einfo "You need to run /opt/vmware/bin/vmware-config.pl to complete the install."
+ einfo
+ einfo "For VMware Add-Ons just visit"
+ einfo "http://www.vmware.com/download/downloadaddons.html"
+ einfo
+ einfo "After configuring, type 'vmware' to launch"
+}
+
+pkg_postrm() {
+ einfo
+ einfo "To remove all traces of vmware you will need to remove the files"
+ einfo "in /etc/vmware/, /etc/init.d/vmware, /lib/modules/*/misc/vm*.o,"
+ einfo "and .vmware/ in each users home directory."
+ einfo
+}