summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-09-23 22:43:09 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-09-23 22:43:09 +0000
commit2b47920136f251a1ffb902877036962203a7d574 (patch)
tree47d082e8bb2627b3c0ef897662b22d233adcf819 /app-emulation
parentstable on s390 (Manifest recommit) (diff)
downloadgentoo-2-2b47920136f251a1ffb902877036962203a7d574.tar.gz
gentoo-2-2b47920136f251a1ffb902877036962203a7d574.tar.bz2
gentoo-2-2b47920136f251a1ffb902877036962203a7d574.zip
wxwidgets eclass in use
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/bochs/ChangeLog5
-rw-r--r--app-emulation/bochs/bochs-2.1.1.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 3bcaabbd4cfd..0a5e4f3d3087 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.27 2004/07/10 18:25:48 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.28 2004/09/23 22:43:09 lu_zero Exp $
+
+ 24 Sep 2004; Luca Barbato <lu_zero@gentoo.org> :
+ Start using wxwidgets eclass
10 Jul 2004; Luca Barbato <lu_zero@gentoo.org> bochs-2.1.1.ebuild:
Change gtk useflag to wxwindows useflag
diff --git a/app-emulation/bochs/bochs-2.1.1.ebuild b/app-emulation/bochs/bochs-2.1.1.ebuild
index f9050906772c..7c7711811689 100644
--- a/app-emulation/bochs/bochs-2.1.1.ebuild
+++ b/app-emulation/bochs/bochs-2.1.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.8 2004/07/10 18:25:48 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.9 2004/09/23 22:43:09 lu_zero Exp $
-inherit eutils
+inherit eutils wxwidgets
DESCRIPTION="a LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 ~ppc alpha ~sparc ~amd64"
-IUSE="sdl wxwindows readline"
+IUSE="sdl wxwindows readline gtk2"
DEPEND="virtual/libc
virtual/x11
@@ -35,6 +35,11 @@ src_unpack() {
}
src_compile() {
+ if ! use gtk2 ; then
+ need-wxwidgets gtk
+ else
+ need-wxwidgets gtk2
+ fi
[ "$ARCH" == "x86" ] \
&& myconf="--enable-idle-hack --enable-fast-function-calls"
myconf="${myconf} `use_with sdl`"