summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-09-05 22:10:55 +0000
committerSimon Stelling <blubb@gentoo.org>2006-09-05 22:10:55 +0000
commit308439cd11117591964949f1a420bb9164041596 (patch)
tree8174a3c51adc516621fcf9e97d48c70c5bada753 /app-emulation
parentDeprecate the 2005.1 SPARC profiles. (diff)
downloadgentoo-2-308439cd11117591964949f1a420bb9164041596.tar.gz
gentoo-2-308439cd11117591964949f1a420bb9164041596.tar.bz2
gentoo-2-308439cd11117591964949f1a420bb9164041596.zip
version bump
(Portage version: 2.1.1_rc1-r4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/x86-chroot/ChangeLog7
-rw-r--r--app-emulation/x86-chroot/files/digest-x86-chroot-2006.13
-rw-r--r--app-emulation/x86-chroot/x86-chroot-2006.1.ebuild71
3 files changed, 80 insertions, 1 deletions
diff --git a/app-emulation/x86-chroot/ChangeLog b/app-emulation/x86-chroot/ChangeLog
index c2aa90101c3a..d23891c6dbf0 100644
--- a/app-emulation/x86-chroot/ChangeLog
+++ b/app-emulation/x86-chroot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/x86-chroot
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x86-chroot/ChangeLog,v 1.2 2006/08/27 09:16:28 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x86-chroot/ChangeLog,v 1.3 2006/09/05 22:10:55 blubb Exp $
+
+*x86-chroot-2006.1 (05 Sep 2006)
+
+ 05 Sep 2006; <blubb@gentoo.org> +x86-chroot-2006.1.ebuild:
+ release bump
27 Aug 2006; <blubb@gentoo.org> files/initd, x86-chroot-2006.0.ebuild:
xhost needs to be run outside the chroot
diff --git a/app-emulation/x86-chroot/files/digest-x86-chroot-2006.1 b/app-emulation/x86-chroot/files/digest-x86-chroot-2006.1
new file mode 100644
index 000000000000..a09dab48c9bb
--- /dev/null
+++ b/app-emulation/x86-chroot/files/digest-x86-chroot-2006.1
@@ -0,0 +1,3 @@
+MD5 aa2333b6fc7c1ba4bf251523273887df stage3-i686-2006.1.tar.bz2 112603344
+RMD160 07b84e3115f849221fbf5a73c7d5969a46fe9814 stage3-i686-2006.1.tar.bz2 112603344
+SHA256 5837a8f6788df03f75c1b01c29981d9faab598ed18691de0ba0983105b59d7de stage3-i686-2006.1.tar.bz2 112603344
diff --git a/app-emulation/x86-chroot/x86-chroot-2006.1.ebuild b/app-emulation/x86-chroot/x86-chroot-2006.1.ebuild
new file mode 100644
index 000000000000..9d30a207c356
--- /dev/null
+++ b/app-emulation/x86-chroot/x86-chroot-2006.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x86-chroot/x86-chroot-2006.1.ebuild,v 1.1 2006/09/05 22:10:55 blubb Exp $
+
+inherit linux-info
+
+DESCRIPTION="Provides a 32bit chroot for amd64 users"
+HOMEPAGE="http://amd64.gentoo.org/"
+SRC_URI="http://distfiles.gentoo.org/releases/x86/${PV}/stages/stage3-i686-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="-* ~amd64"
+IUSE="X"
+
+RDEPEND="sys-apps/setarch
+ X? ( x11-apps/xhost )"
+
+CONFIG_CHECK="IA32_EMULATION"
+CHROOT_LOCATION=${CHROOT_LOCATION:-/opt/x86-chroot}
+
+pkg_setup() {
+ if [[ -e ${CHROOT_LOCATION} && -z ${IKNOWMYSHIT} ]] ; then
+ eerror "ATTENTION! The location you are going to install the chroot to"
+ eerror "already exists and probably contains a chroot. Re-merging ${PN}"
+ eerror "will overwrite files in the chroot and likely result in a broken"
+ eerror "chroot. If you still want to merge it, execute:"
+ eerror ""
+ eerror "export IKNOWMYSHIT=breakmychroot"
+ die "Previous chroot instance found!"
+ fi
+ linux-info_pkg_setup
+}
+
+src_unpack() {
+ cd ${WORKDIR}
+ mkdir -p ".${CHROOT_LOCATION}"
+ cd ".${CHROOT_LOCATION}"
+ unpack ${A}
+}
+
+src_compile() {
+ cat <<- EOF > "${WORKDIR}/${CHROOT_LOCATION}/etc/make.conf"
+ CFLAGS="-O2 -march=athlon-xp -msse2 -pipe -fomit-frame-pointer"
+ CHOST="i686-pc-linux-gnu"
+ CXXFLAGS="\${CFLAGS}"
+ EOF
+ echo "env-update" >> "${WORKDIR}/${CHROOT_LOCATION}/root/.bashrc"
+ echo "CHROOT_LOCATION=${CHROOT_LOCATION}" > "${WORKDIR}/${CHROOT_LOCATION}/etc/conf.d/${PN}"
+}
+
+src_install() {
+ mv ${WORKDIR}/* ${D}/ || die "moving chroot failed!"
+ newinitd ${FILESDIR}/initd ${PN} || die "could not install init.d file!"
+ mkdir -p "${D}/etc/conf.d"
+ echo "CHROOT_LOCATION=${CHROOT_LOCATION}" > "${D}/etc/conf.d/${PN}" || die "could not install conf.d file!"
+ dobin ${FILESDIR}/${PN} || die "couldn't install x86-chroot"
+}
+
+pkg_postinst() {
+ einfo "Your chroot system is now installed. To do all the necessary setup"
+ einfo "work, run '/etc/init.d/x86-chroot start'. To start a chroot session,"
+ einfo "run 'x86-chroot'."
+}
+
+pkg_prerm() {
+ [[ -f /etc/conf.d/${PN} ]] && source /etc/conf.d/${PN}
+ ewarn "There are still files around in ${CHROOT_LOCATION}; make sure you
+ manually"
+ ewarn "remove that directory *after* checking the mounts for it"
+}