summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2007-07-27 18:46:26 +0000
committerLuca Barbato <lu_zero@gentoo.org>2007-07-27 18:46:26 +0000
commit3e6c9992c4774b91e8a7a3ab73002a59087a4e00 (patch)
tree87290140b815bfa25238eb950ed6ccfc4f02d8a0 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-3e6c9992c4774b91e8a7a3ab73002a59087a4e00.tar.gz
gentoo-2-3e6c9992c4774b91e8a7a3ab73002a59087a4e00.tar.bz2
gentoo-2-3e6c9992c4774b91e8a7a3ab73002a59087a4e00.zip
fix bug #185170
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kqemu/ChangeLog7
-rw-r--r--app-emulation/kqemu/files/kqemu-1.3.0_pre11-sched_h.patch10
-rw-r--r--app-emulation/kqemu/kqemu-1.3.0_pre11.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/app-emulation/kqemu/ChangeLog b/app-emulation/kqemu/ChangeLog
index 9879b3752ff2..e113eb880bf8 100644
--- a/app-emulation/kqemu/ChangeLog
+++ b/app-emulation/kqemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/kqemu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.20 2007/07/02 13:59:28 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.21 2007/07/27 18:46:26 lu_zero Exp $
+
+ 27 Jul 2007; Luca Barbato <lu_zero@gentoo.org>
+ +files/kqemu-1.3.0_pre11-sched_h.patch, kqemu-1.3.0_pre11.ebuild:
+ fix bug #185170, using the same patch as reported in DebianBug#434031,
+ thanks to Dominik Paulus <dominik.paulus@web.de> for pointing it
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> kqemu-0.7.2.ebuild,
kqemu-1.3.0_pre5.ebuild, kqemu-1.3.0_pre7.ebuild, kqemu-1.3.0_pre9.ebuild,
diff --git a/app-emulation/kqemu/files/kqemu-1.3.0_pre11-sched_h.patch b/app-emulation/kqemu/files/kqemu-1.3.0_pre11-sched_h.patch
new file mode 100644
index 000000000000..575c9b50bb37
--- /dev/null
+++ b/app-emulation/kqemu/files/kqemu-1.3.0_pre11-sched_h.patch
@@ -0,0 +1,10 @@
+--- kqemu-linux.c 2007-07-25 13:41:52.000000000 +0200
++++ kqemu-linux.c.new 2007-07-25 14:02:00.000000000 +0200
+@@ -26,6 +26,7 @@
+ #include <linux/ioctl.h>
+ #include <linux/smp_lock.h>
+ #include <linux/miscdevice.h>
++#include <linux/sched.h>
+ #include <asm/atomic.h>
+ #include <asm/processor.h>
+ #include <asm/uaccess.h>
diff --git a/app-emulation/kqemu/kqemu-1.3.0_pre11.ebuild b/app-emulation/kqemu/kqemu-1.3.0_pre11.ebuild
index 64dedfba9d0d..536d06c50c84 100644
--- a/app-emulation/kqemu/kqemu-1.3.0_pre11.ebuild
+++ b/app-emulation/kqemu/kqemu-1.3.0_pre11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-1.3.0_pre11.ebuild,v 1.4 2007/07/02 13:59:28 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-1.3.0_pre11.ebuild,v 1.5 2007/07/27 18:46:26 lu_zero Exp $
inherit eutils flag-o-matic linux-mod toolchain-funcs
@@ -29,6 +29,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${P}-sched_h.patch
sed -i 's:MODULE_PARM(\([^,]*\),"i");:module_param(\1, int, 0);:' kqemu-linux.c
}