summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-11-26 03:25:14 +0000
committerYixun Lan <dlan@gentoo.org>2014-11-26 03:25:14 +0000
commit55b29418f48bcfc6601e3c9ac146166df5adc68d (patch)
tree643c5da61c4adcc610c39412693ad4a165724642 /app-emulation
parentBump (diff)
downloadgentoo-2-55b29418f48bcfc6601e3c9ac146166df5adc68d.tar.gz
gentoo-2-55b29418f48bcfc6601e3c9ac146166df5adc68d.tar.bz2
gentoo-2-55b29418f48bcfc6601e3c9ac146166df5adc68d.zip
security version bump, bug 530182
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/ChangeLog10
-rw-r--r--app-emulation/xen-tools/xen-tools-4.3.3-r2.ebuild (renamed from app-emulation/xen-tools/xen-tools-4.4.1-r1.ebuild)149
-rw-r--r--app-emulation/xen-tools/xen-tools-4.4.1-r4.ebuild (renamed from app-emulation/xen-tools/xen-tools-4.4.1-r2.ebuild)36
3 files changed, 105 insertions, 90 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index f9bd2045fc22..58fe3ce10734 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.266 2014/11/06 23:00:32 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.267 2014/11/26 03:25:14 dlan Exp $
+
+*xen-tools-4.4.1-r4 (26 Nov 2014)
+*xen-tools-4.3.3-r2 (26 Nov 2014)
+
+ 26 Nov 2014; Yixun Lan <dlan@gentoo.org> +xen-tools-4.3.3-r2.ebuild,
+ -xen-tools-4.4.1-r1.ebuild, -xen-tools-4.4.1-r2.ebuild,
+ +xen-tools-4.4.1-r4.ebuild:
+ security version bump, bug 530182
*xen-tools-4.4.1-r3 (06 Nov 2014)
diff --git a/app-emulation/xen-tools/xen-tools-4.4.1-r1.ebuild b/app-emulation/xen-tools/xen-tools-4.3.3-r2.ebuild
index 0ddc601486e7..6297575e2e1e 100644
--- a/app-emulation/xen-tools/xen-tools-4.4.1-r1.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.3.3-r2.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.4.1-r1.ebuild,v 1.1 2014/10/10 03:05:45 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.3.3-r2.ebuild,v 1.1 2014/11/26 03:25:14 dlan Exp $
EAPI=5
-MY_PV=${PV/_/-}
-
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_6,2_7} )
PYTHON_REQ_USE='xml,threads'
if [[ $PV == *9999 ]]; then
@@ -16,25 +14,25 @@ if [[ $PV == *9999 ]]; then
S="${WORKDIR}/${REPO}"
live_eclass="mercurial"
else
- KEYWORDS="~amd64 ~arm -x86"
+ KEYWORDS="~amd64 -x86"
UPSTREAM_VER=1
# xen-tools's gentoo patches tarball
GENTOO_VER=0
# xen-tools's gentoo patches version which apply to this specific ebuild
GENTOO_GPV=0
- SEABIOS_VER=1.7.3.1
+ SEABIOS_VER=1.7.1-stable-xen
[[ -n ${UPSTREAM_VER} ]] && \
- UPSTRAM_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${P/-tools/}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+ UPSTREAM_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${P/-tools/}-upstream-patches-${UPSTREAM_VER}.tar.xz"
[[ -n ${GENTOO_VER} ]] && \
- GENTOO_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${PN/-tools}-gentoo-patches-${GENTOO_VER}.tar.xz"
+ GENTOO_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${PN/-tools/}-gentoo-patches-${GENTOO_VER}.tar.xz"
- SRC_URI="http://bits.xensource.com/oss-xen/release/${MY_PV}/xen-${MY_PV}.tar.gz
+ SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz
http://code.coreboot.org/p/seabios/downloads/get/seabios-${SEABIOS_VER}.tar.gz
http://dev.gentoo.org/~dlan/distfiles/seabios-${SEABIOS_VER}.tar.gz
- ${UPSTRAM_PATCHSET_URI}
+ ${UPSTREAM_PATCHSET_URI}
${GENTOO_PATCHSET_URI}"
- S="${WORKDIR}/xen-${MY_PV}"
+ S="${WORKDIR}/xen-${PV}"
fi
inherit bash-completion-r1 eutils flag-o-matic multilib python-single-r1 toolchain-funcs udev ${live_eclass}
@@ -45,39 +43,32 @@ DOCS=( README docs/README.xen-bugtool )
LICENSE="GPL-2"
SLOT="0"
-# Inclusion of IUSE ocaml on stabalizing requires maintainer of ocaml to (get off his hands and) make
+# Inclusion of IUSE ocaml on stabalizing requires maintainer of ocaml to (get off his hands and) make
# >=dev-lang/ocaml-4 stable
# Masked in profiles/eapi-5-files instead
-IUSE="api custom-cflags debug doc flask hvm qemu ocaml +pam python pygrub screen static-libs system-qemu system-seabios"
+IUSE="api custom-cflags debug doc flask hvm qemu ocaml +pam python pygrub screen static-libs system-seabios"
-REQUIRED_USE="hvm? ( || ( qemu system-qemu ) )
+REQUIRED_USE="hvm? ( qemu )
${PYTHON_REQUIRED_USE}
- pygrub? ( python )
- qemu? ( !system-qemu )"
+ pygrub? ( python )"
-COMMON_DEPEND="
- dev-libs/lzo:2
+DEPEND="dev-libs/lzo:2
dev-libs/glib:2
dev-libs/yajl
- dev-libs/libaio
dev-libs/libgcrypt:0
- sys-libs/zlib
-"
-
-DEPEND="${COMMON_DEPEND}
dev-python/lxml[${PYTHON_USEDEP}]
pam? ( dev-python/pypam[${PYTHON_USEDEP}] )
+ sys-libs/zlib
+ sys-power/iasl
+ system-seabios? ( sys-firmware/seabios )
+ sys-firmware/ipxe
hvm? ( media-libs/libsdl )
${PYTHON_DEPS}
api? ( dev-libs/libxml2
net-misc/curl )
pygrub? ( ${PYTHON_DEPS//${PYTHON_REQ_USE}/ncurses} )
- arm? ( >=sys-apps/dtc-1.4.0 )
- !arm? ( sys-devel/bin86
- system-seabios? ( sys-firmware/seabios )
- sys-firmware/ipxe
- sys-devel/dev86
- sys-power/iasl )
+ sys-devel/bin86
+ sys-devel/dev86
dev-lang/perl
app-misc/pax-utils
dev-python/markdown[${PYTHON_USEDEP}]
@@ -97,12 +88,9 @@ DEPEND="${COMMON_DEPEND}
hvm? ( x11-proto/xproto
!net-libs/libiscsi )
qemu? ( x11-libs/pixman )
- system-qemu? ( app-emulation/qemu[xen] )
ocaml? ( dev-ml/findlib
>=dev-lang/ocaml-4 )"
-
-RDEPEND="${COMMON_DEPEND}
- sys-apps/iproute2
+RDEPEND="sys-apps/iproute2
net-misc/bridge-utils
screen? (
app-misc/screen
@@ -112,8 +100,7 @@ RDEPEND="${COMMON_DEPEND}
# hvmloader is used to bootstrap a fully virtualized kernel
# Approved by QA team in bug #144032
-QA_WX_LOAD="usr/lib/xen/boot/hvmloader
- usr/share/qemu-xen/qemu/s390-ccw.img"
+QA_WX_LOAD="usr/lib/xen/boot/hvmloader"
RESTRICT="test"
@@ -128,6 +115,12 @@ pkg_setup() {
export "CONFIG_GCRYPT=y"
fi
+ if use qemu; then
+ export "CONFIG_IOEMU=y"
+ else
+ export "CONFIG_IOEMU=n"
+ fi
+
if [[ -z ${XEN_TARGET_ARCH} ]] ; then
if use x86 && use amd64; then
die "Confusion! Both x86 and amd64 are set in your use flags!"
@@ -135,14 +128,10 @@ pkg_setup() {
export XEN_TARGET_ARCH="x86_32"
elif use amd64 ; then
export XEN_TARGET_ARCH="x86_64"
- elif use arm; then
- export XEN_TARGET_ARCH="arm32"
else
die "Unsupported architecture!"
fi
fi
- #bug 472438
- export BASH_COMPLETION_DIR=/usr/share/bash-completion
}
src_prepare() {
@@ -165,6 +154,10 @@ src_prepare() {
done
fi
+ # Bug 496708
+ use system-seabios && epatch "${WORKDIR}"/patches-gentoo/${PN}-4-unbundle-seabios.patch
+
+ # Bug 478064
mv tools/qemu-xen/qemu-bridge-helper.c tools/qemu-xen/xen-bridge-helper.c || die
mv ../seabios-${SEABIOS_VER} tools/firmware/seabios-dir-remote || die
@@ -172,16 +165,6 @@ src_prepare() {
ln -s seabios-dir-remote seabios-dir || die
popd > /dev/null
- # Fix texi2html build error with new texi2html, qemu.doc.html
- sed -i -e "/texi2html -monolithic/s/-number//" tools/qemu-xen-traditional/Makefile || die
-
- use api || sed -e "/SUBDIRS-\$(LIBXENAPI_BINDINGS) += libxen/d" -i tools/Makefile || die
- sed -e 's:$(MAKE) PYTHON=$(PYTHON) subdirs-$@:LC_ALL=C "$(MAKE)" PYTHON=$(PYTHON) subdirs-$@:' \
- -i tools/firmware/Makefile || die
-
- # Drop .config, fixes to gcc-4.6
- sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
-
# if the user *really* wants to use their own custom-cflags, let them
if use custom-cflags; then
einfo "User wants their own CFLAGS - removing defaults"
@@ -205,7 +188,9 @@ src_prepare() {
sed -e '/^SUBDIRS-y += python$/d' -i tools/Makefile || die
fi
+ # Disable hvm support on systems that don't support x86_32 binaries.
if ! use hvm; then
+ sed -e '/^CONFIG_IOEMU := y$/d' -i config/*.mk || die
sed -e '/SUBDIRS-$(CONFIG_X86) += firmware/d' -i tools/Makefile || die
# Bug 351648
elif ! use x86 && ! has x86 $(get_all_abis); then
@@ -216,30 +201,27 @@ src_prepare() {
# Don't bother with qemu, only needed for fully virtualised guests
if ! use qemu; then
- sed -e "s:install-tools\: tools/qemu-xen-traditional-dir:install-tools\: :g" -i Makefile || die
+ sed -e "/^CONFIG_IOEMU := y$/d" -i config/*.mk || die
+ sed -e "s:install-tools\: tools/ioemu-dir:install-tools\: :g" -i Makefile || die
fi
- # Bug 472438
- sed -e 's:^BASH_COMPLETION_DIR ?= $(CONFIG_DIR)/bash_completion.d:BASH_COMPLETION_DIR ?= $(SHARE_DIR)/bash-completion:' \
+ # Reset bash completion dir; Bug 472438
+ sed -e "s:^BASH_COMPLETION_DIR ?= \$(CONFIG_DIR)/bash_completion.d:BASH_COMPLETION_DIR ?= $(get_bashcompdir):" \
-i Config.mk || die
+ sed -i -e "/bash-completion/s/xl\.sh/xl/g" tools/libxl/Makefile || die
+
+ use flask || sed -e "/SUBDIRS-y += flask/d" -i tools/Makefile || die
+ use api || sed -e "/SUBDIRS-\$(LIBXENAPI_BINDINGS) += libxen/d" -i tools/Makefile || die
+ sed -e 's:$(MAKE) PYTHON=$(PYTHON) subdirs-$@:LC_ALL=C "$(MAKE)" PYTHON=$(PYTHON) subdirs-$@:' \
+ -i tools/firmware/Makefile || die
# xencommons, Bug #492332, sed lighter weight than patching
sed -e 's:\$QEMU_XEN -xen-domid:test -e "\$QEMU_XEN" \&\& &:' \
-i tools/hotplug/Linux/init.d/xencommons || die
- # respect multilib, usr/lib/libcacard.so.0.0.0
- sed -e "/^libdir=/s/\/lib/\/$(get_libdir)/" \
- -i tools/qemu-xen/configure || die
-
- #bug 518136, don't build 32bit exactuable for nomultilib profile
- if [[ "${ARCH}" == 'amd64' ]] && ! has_multilib_profile; then
- sed -i -e "/x86_emulator/d" tools/tests/Makefile || die
- fi
-
- # Bug 477884, 518136
- if [[ "${ARCH}" == 'amd64' ]]; then
- sed -i -e "/LIBEXEC =/s|/lib/xen/bin|/$(get_libdir)/xen/bin|" config/StdGNU.mk || die
- fi
+ # Bug 493232 fix from http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1844
+ sed -e 's:bl->argsspace = 7 + :bl->argsspace = 9 + :' \
+ -i tools/libxl/libxl_bootloader.c || die
# fix QA warning, create /var/run/, /var/lock dynamically
sed -i -e "/\$(INSTALL_DIR) \$(DESTDIR)\$(XEN_RUN_DIR)/d" \
@@ -256,20 +238,20 @@ src_prepare() {
}
src_configure() {
- local myconf="--prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- --disable-werror \
- --disable-xen \
- --enable-tools \
- --enable-docs \
- --enable-qemu-traditional \
- $(use_with system-qemu) \
- $(use_enable pam) \
- $(use_enable api xenapi) \
- $(use_enable ocaml ocamltools) \
- "
- use system-seabios && myconf+=" --with-system-seabios=/usr/share/seabios/bios.bin"
- use qemu || myconf+=" --with-system-qemu"
+ local myconf="--prefix=/usr --disable-werror"
+
+ if use ocaml
+ then
+ myconf="${myconf} $(use_enable ocaml ocamltools)"
+ else
+ myconf="${myconf} --disable-ocamltools"
+ fi
+
+ if ! use pam
+ then
+ myconf="${myconf} --disable-pam"
+ fi
+
econf ${myconf}
}
@@ -315,9 +297,6 @@ src_install() {
-e 's:^#vifscript="vif-bridge":vifscript="vif-bridge":' \
-i tools/examples/xl.conf || die
- # Reset bash completion dir; Bug 472438
- mv "${D}"bash-completion "${D}"usr/share/ || die
-
if use doc; then
emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" install-docs
@@ -347,6 +326,12 @@ src_install() {
keepdir /var/log/xen-consoles
fi
+ # Move files built with use qemu, Bug #477884
+ if [[ "${ARCH}" == 'amd64' ]] && use qemu; then
+ mkdir -p "${D}"usr/$(get_libdir)/xen/bin || die
+ mv "${D}"usr/lib/xen/bin/* "${D}"usr/$(get_libdir)/xen/bin/ || die
+ fi
+
# For -static-libs wrt Bug 384355
if ! use static-libs; then
rm -f "${D}"usr/$(get_libdir)/*.a "${D}"usr/$(get_libdir)/ocaml/*/*.a
diff --git a/app-emulation/xen-tools/xen-tools-4.4.1-r2.ebuild b/app-emulation/xen-tools/xen-tools-4.4.1-r4.ebuild
index 37249937bd67..9e5a7bd33fbb 100644
--- a/app-emulation/xen-tools/xen-tools-4.4.1-r2.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.4.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.4.1-r2.ebuild,v 1.1 2014/11/01 14:54:13 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.4.1-r4.ebuild,v 1.1 2014/11/26 03:25:14 dlan Exp $
EAPI=5
@@ -17,23 +17,31 @@ if [[ $PV == *9999 ]]; then
live_eclass="mercurial"
else
KEYWORDS="~amd64 ~arm -x86"
- UPSTREAM_VER=1
+ UPSTREAM_VER=2
# xen-tools's gentoo patches tarball
- GENTOO_VER=1
+ GENTOO_VER=3
# xen-tools's gentoo patches version which apply to this specific ebuild
- GENTOO_GPV=1
+ GENTOO_GPV=2
+ # xen-tools ovmf's patches
+ OVMF_VER=0
+
SEABIOS_VER=1.7.3.1
+ OVMF_PV=20131208
[[ -n ${UPSTREAM_VER} ]] && \
UPSTRAM_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${P/-tools/}-upstream-patches-${UPSTREAM_VER}.tar.xz"
[[ -n ${GENTOO_VER} ]] && \
GENTOO_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${PN/-tools}-gentoo-patches-${GENTOO_VER}.tar.xz"
+ [[ -n ${OVMF_VER} ]] && \
+ OVMF_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${PN/-tools}-ovmf-patches-${OVMF_VER}.tar.xz"
SRC_URI="http://bits.xensource.com/oss-xen/release/${MY_PV}/xen-${MY_PV}.tar.gz
http://code.coreboot.org/p/seabios/downloads/get/seabios-${SEABIOS_VER}.tar.gz
http://dev.gentoo.org/~dlan/distfiles/seabios-${SEABIOS_VER}.tar.gz
+ http://dev.gentoo.org/~dlan/distfiles/ovmf-${OVMF_PV}.tar.bz2
${UPSTRAM_PATCHSET_URI}
- ${GENTOO_PATCHSET_URI}"
+ ${GENTOO_PATCHSET_URI}
+ ${OVMF_PATCHSET_URI}"
S="${WORKDIR}/xen-${MY_PV}"
fi
@@ -48,11 +56,12 @@ SLOT="0"
# Inclusion of IUSE ocaml on stabalizing requires maintainer of ocaml to (get off his hands and) make
# >=dev-lang/ocaml-4 stable
# Masked in profiles/eapi-5-files instead
-IUSE="api custom-cflags debug doc flask hvm qemu ocaml +pam python pygrub screen static-libs system-qemu system-seabios"
+IUSE="api custom-cflags debug doc flask hvm qemu ocaml ovmf +pam python pygrub screen static-libs system-qemu system-seabios"
REQUIRED_USE="hvm? ( || ( qemu system-qemu ) )
${PYTHON_REQUIRED_USE}
pygrub? ( python )
+ ovmf? ( hvm )
qemu? ( !system-qemu )"
COMMON_DEPEND="
@@ -163,9 +172,20 @@ src_prepare() {
done
fi
+ # Ovmf's patchset
+ if [[ -n ${OVMF_VER} ]]; then
+ pushd "${WORKDIR}"/ovmf-*/ > /dev/null
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ EPATCH_OPTS="-p1" \
+ epatch "${WORKDIR}"/patches-ovmf
+ popd > /dev/null
+ fi
+
mv tools/qemu-xen/qemu-bridge-helper.c tools/qemu-xen/xen-bridge-helper.c || die
mv ../seabios-${SEABIOS_VER} tools/firmware/seabios-dir-remote || die
+ mv ../ovmf-${OVMF_PV} tools/firmware/ovmf-dir-remote || die
pushd tools/firmware/ > /dev/null
ln -s seabios-dir-remote seabios-dir || die
popd > /dev/null
@@ -261,12 +281,14 @@ src_configure() {
--disable-xen \
--enable-tools \
--enable-docs \
- --enable-qemu-traditional \
$(use_with system-qemu) \
$(use_enable pam) \
$(use_enable api xenapi) \
+ $(use_enable ovmf) \
$(use_enable ocaml ocamltools) \
"
+ # disable qemu-traditional for arm, fail to build
+ use arm || myconf+=" --enable-qemu-traditional"
use system-seabios && myconf+=" --with-system-seabios=/usr/share/seabios/bios.bin"
use qemu || myconf+=" --with-system-qemu"
econf ${myconf}