summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-12 18:59:01 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-12 18:59:01 +0000
commit5e52e024385f9a315244493543fff9712c9d659e (patch)
treec9728e68a2771d8840c2e7c9e235e70257de052f /app-emulation
parentx86 stable per bug 366685 (diff)
downloadgentoo-2-5e52e024385f9a315244493543fff9712c9d659e.tar.gz
gentoo-2-5e52e024385f9a315244493543fff9712c9d659e.tar.bz2
gentoo-2-5e52e024385f9a315244493543fff9712c9d659e.zip
[app-emulation/xen-tools] Prevent downloading during compile, fixes bug #366125; Thanks to Ian Delaney aka idella4
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/ChangeLog9
-rw-r--r--app-emulation/xen-tools/xen-tools-4.1.1-r4.ebuild (renamed from app-emulation/xen-tools/xen-tools-4.1.1-r3.ebuild)13
-rw-r--r--app-emulation/xen-tools/xen-tools-9999.ebuild13
3 files changed, 30 insertions, 5 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 114aee1dbed4..18f7c637e39f 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.84 2011/09/11 21:27:42 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.85 2011/09/12 18:59:01 alexxy Exp $
+
+*xen-tools-4.1.1-r4 (12 Sep 2011)
+
+ 12 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> -xen-tools-4.1.1-r3.ebuild,
+ +xen-tools-4.1.1-r4.ebuild:
+ Prevent downloading during compile, fixes bug #366125; Thanks to Ian Delaney
+ aka idella4
11 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> xen-tools-4.1.1-r3.ebuild,
xen-tools-9999.ebuild:
diff --git a/app-emulation/xen-tools/xen-tools-4.1.1-r3.ebuild b/app-emulation/xen-tools/xen-tools-4.1.1-r4.ebuild
index 2826cdb8c27a..c3b655dcc988 100644
--- a/app-emulation/xen-tools/xen-tools-4.1.1-r3.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.1.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.1.1-r3.ebuild,v 1.2 2011/09/11 21:27:42 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.1.1-r4.ebuild,v 1.1 2011/09/12 18:59:01 alexxy Exp $
EAPI="3"
@@ -12,7 +12,9 @@ if [[ $PV == *9999 ]]; then
live_eclass="mercurial"
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
+ XEN_EXTFILES_URL="http://xenbits.xensource.com/xen-extfiles"
+ SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz \
+ $XEN_EXTFILES_URL/ipxe-git-v1.0.0.tar.gz"
S="${WORKDIR}/xen-${PV}"
fi
@@ -124,6 +126,7 @@ pkg_setup() {
}
src_prepare() {
+ cp "$DISTDIR/ipxe-git-v1.0.0.tar.gz" tools/firmware/etherboot/ipxe.tar.gz
sed -e 's/-Wall//' -i Config.mk || die "Couldn't sanitize CFLAGS"
# Drop .config
sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
@@ -171,6 +174,12 @@ src_prepare() {
# Do not strip binaries
epatch "${FILESDIR}/${PN}-3.3.0-nostrip.patch"
+
+ # Prevent the downloading of ipxe
+ sed -e 's:^\tif ! wget -O _$T:#\tif ! wget -O _$T:' \
+ -e 's:^\tfi:#\tfi:' -i \
+ -e 's:^\tmv _$T $T:#\tmv _$T $T:' \
+ -i tools/firmware/etherboot/Makefile || die
}
src_compile() {
diff --git a/app-emulation/xen-tools/xen-tools-9999.ebuild b/app-emulation/xen-tools/xen-tools-9999.ebuild
index f6612de60924..401fa77e3bab 100644
--- a/app-emulation/xen-tools/xen-tools-9999.ebuild
+++ b/app-emulation/xen-tools/xen-tools-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-9999.ebuild,v 1.5 2011/09/11 21:27:42 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-9999.ebuild,v 1.6 2011/09/12 18:59:01 alexxy Exp $
EAPI="3"
@@ -12,7 +12,9 @@ if [[ $PV == *9999 ]]; then
live_eclass="mercurial"
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
+ XEN_EXTFILES_URL="http://xenbits.xensource.com/xen-extfiles"
+ SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz \
+ $XEN_EXTFILES_URL/ipxe-git-v1.0.0.tar.gz"
S="${WORKDIR}/xen-${PV}"
fi
@@ -124,6 +126,7 @@ pkg_setup() {
}
src_prepare() {
+ cp "$DISTDIR/ipxe-git-v1.0.0.tar.gz" tools/firmware/etherboot/ipxe.tar.gz
sed -e 's/-Wall//' -i Config.mk || die "Couldn't sanitize CFLAGS"
# Drop .config
sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
@@ -171,6 +174,12 @@ src_prepare() {
# Do not strip binaries
epatch "${FILESDIR}/${PN}-3.3.0-nostrip.patch"
+
+ # Prevent the downloading of ipxe
+ sed -e 's:^\tif ! wget -O _$T:#\tif ! wget -O _$T:' \
+ -e 's:^\tfi:#\tfi:' -i \
+ -e 's:^\tmv _$T $T:#\tmv _$T $T:' \
+ -i tools/firmware/etherboot/Makefile || die
}
src_compile() {