summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-26 12:52:25 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-26 12:52:25 +0000
commit706c305eeed3f74d6ba393c2911ea5a2f00e5fe8 (patch)
treec05624795d4bd14ab1705f1f0e50e3cdecdae4db /app-emulation
parentAvoid entering emergency mode by using fprintf instead sgLogFatalError (#2592... (diff)
downloadgentoo-2-706c305eeed3f74d6ba393c2911ea5a2f00e5fe8.tar.gz
gentoo-2-706c305eeed3f74d6ba393c2911ea5a2f00e5fe8.tar.bz2
gentoo-2-706c305eeed3f74d6ba393c2911ea5a2f00e5fe8.zip
Fix gcc 4.3 compile failure, part of #259670
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/ChangeLog6
-rw-r--r--app-emulation/xen-tools/files/xen-tools-3.3.0-warning-fix.patch33
-rw-r--r--app-emulation/xen-tools/xen-tools-3.3.0.ebuild7
3 files changed, 43 insertions, 3 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 658a4189cd4d..f8201d942ad1 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.42 2009/02/28 10:20:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.43 2009/04/26 12:52:25 patrick Exp $
+
+ 26 Apr 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/xen-tools-3.3.0-warning-fix.patch, xen-tools-3.3.0:
+ Fix gcc 4.3 compile failure, part of #259670
28 Feb 2009; Markus Meier <maekke@gentoo.org> metadata.xml:
custom-cflags is a global USE-flag
diff --git a/app-emulation/xen-tools/files/xen-tools-3.3.0-warning-fix.patch b/app-emulation/xen-tools/files/xen-tools-3.3.0-warning-fix.patch
new file mode 100644
index 000000000000..f2f5e60141f7
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-3.3.0-warning-fix.patch
@@ -0,0 +1,33 @@
+diff -Nru a/tools/libxc/xc_dom_x86.c b/tools/libxc/xc_dom_x86.c
+--- a/tools/libxc/xc_dom_x86.c 2008-08-22 17:49:08.000000000 +0800
++++ b/tools/libxc/xc_dom_x86.c 2009-02-19 19:08:23.000000000 +0800
+@@ -418,7 +418,7 @@
+ xc_dom_printf("%s: called\n", __FUNCTION__);
+
+ memset(start_info, 0, sizeof(*start_info));
+- snprintf(start_info->magic, sizeof(start_info->magic), dom->guest_type);
++ snprintf(start_info->magic, sizeof(start_info->magic), "%s", dom->guest_type);
+ start_info->nr_pages = dom->total_pages;
+ start_info->shared_info = shinfo << PAGE_SHIFT_X86;
+ start_info->pt_base = dom->pgtables_seg.vstart;
+@@ -457,7 +457,7 @@
+ xc_dom_printf("%s: called\n", __FUNCTION__);
+
+ memset(start_info, 0, sizeof(*start_info));
+- snprintf(start_info->magic, sizeof(start_info->magic), dom->guest_type);
++ snprintf(start_info->magic, sizeof(start_info->magic), "%s", dom->guest_type);
+ start_info->nr_pages = dom->total_pages;
+ start_info->shared_info = shinfo << PAGE_SHIFT_X86;
+ start_info->pt_base = dom->pgtables_seg.vstart;
+diff -Nru a/tools/xenstat/xentop/xentop.c b/tools/xenstat/xentop/xentop.c
+--- a/tools/xenstat/xentop/xentop.c 2008-08-22 17:49:08.000000000 +0800
++++ b/tools/xenstat/xentop/xentop.c 2009-02-19 19:11:46.000000000 +0800
+@@ -254,7 +254,7 @@
+ {
+ if(cwin != NULL && !isendwin())
+ endwin();
+- fprintf(stderr, str);
++ fprintf(stderr, "%s", str);
+ exit(1);
+ }
+
diff --git a/app-emulation/xen-tools/xen-tools-3.3.0.ebuild b/app-emulation/xen-tools/xen-tools-3.3.0.ebuild
index 325bf5da6552..7e3a6921cb16 100644
--- a/app-emulation/xen-tools/xen-tools-3.3.0.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.3.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.3.0.ebuild,v 1.1 2008/09/01 00:41:07 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.3.0.ebuild,v 1.2 2009/04/26 12:52:25 patrick Exp $
inherit flag-o-matic eutils multilib python
@@ -144,6 +144,9 @@ src_unpack() {
# Do not strip binaries
epatch "${FILESDIR}/"${P}-nostrip.patch
+
+ # Fix compiler warnings
+ epatch "${FILESDIR}/"${P}-warning-fix.patch
}
src_compile() {