summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-04-30 16:23:19 +0000
committerMike Frysinger <vapier@gentoo.org>2007-04-30 16:23:19 +0000
commit7e9db2ed7a6c04c72bedf5d3f830b6fff8540ea8 (patch)
tree5c79b9557e2ee3dab5662446b7672e2c6c4dfe40 /app-emulation
parentVersion bump (diff)
downloadgentoo-2-7e9db2ed7a6c04c72bedf5d3f830b6fff8540ea8.tar.gz
gentoo-2-7e9db2ed7a6c04c72bedf5d3f830b6fff8540ea8.tar.bz2
gentoo-2-7e9db2ed7a6c04c72bedf5d3f830b6fff8540ea8.zip
Version bump.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/files/digest-wine-0.9.363
-rw-r--r--app-emulation/wine/wine-0.9.36.ebuild116
3 files changed, 125 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 8fd545f1f7c3..d3cf3c7621ba 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.177 2007/04/19 00:14:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.178 2007/04/30 16:23:19 vapier Exp $
+
+*wine-0.9.36 (30 Apr 2007)
+
+ 30 Apr 2007; Mike Frysinger <vapier@gentoo.org> +wine-0.9.36.ebuild:
+ Version bump.
19 Apr 2007; Mike Frysinger <vapier@gentoo.org> wine-0.9.35.ebuild:
Drop USE=arts #174864 by Christopher Eby.
diff --git a/app-emulation/wine/files/digest-wine-0.9.36 b/app-emulation/wine/files/digest-wine-0.9.36
new file mode 100644
index 000000000000..98285ceee0e8
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-0.9.36
@@ -0,0 +1,3 @@
+MD5 8cc54b83b5beafcc3d998a04ed723a39 wine-0.9.36.tar.bz2 11843261
+RMD160 41e77069e07d6bb3db7d18b55e95a5b463ac4227 wine-0.9.36.tar.bz2 11843261
+SHA256 97266030c40266dce8bc3a0f7085dd1b101c4660562137ac606a96a4cb9133f3 wine-0.9.36.tar.bz2 11843261
diff --git a/app-emulation/wine/wine-0.9.36.ebuild b/app-emulation/wine/wine-0.9.36.ebuild
new file mode 100644
index 000000000000..396b123baf64
--- /dev/null
+++ b/app-emulation/wine/wine-0.9.36.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.36.ebuild,v 1.1 2007/04/30 16:23:19 vapier Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa cups dbus esd hal jack jpeg lcms ldap nas ncurses opengl oss scanner xml X"
+RESTRICT="test" #72375
+
+RDEPEND=">=media-libs/freetype-2.0.0
+ media-fonts/corefonts
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ dbus? ( sys-apps/dbus )
+ hal? ( sys-apps/hal )
+ X? (
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-apps/xmessage
+ )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ jpeg? ( media-libs/jpeg )
+ ldap? ( net-nds/openldap )
+ lcms? ( media-libs/lcms )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )
+ >=media-gfx/fontforge-20060703
+ scanner? ( media-gfx/sane-backends )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1
+ >=sys-kernel/linux-headers-2.6
+ )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ )
+ sys-devel/bison
+ sys-devel/flex"
+
+src_unpack() {
+ unpack wine-${PV}.tar.bz2
+ cd "${S}"
+
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+ epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
+ sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+}
+
+config_cache() {
+ local h ans="no"
+ use $1 && ans="yes"
+ shift
+ for h in "$@" ; do
+ [[ ${h} == *.h ]] \
+ && h=header_${h} \
+ || h=lib_${h}
+ export ac_cv_${h//[:\/.]/_}=${ans}
+ done
+}
+
+src_compile() {
+ export LDCONFIG=/bin/true
+ use esd || export ac_cv_path_ESDCONFIG=""
+ use scanner || export ac_cv_path_sane_devel="no"
+ config_cache jack jack/jack.h
+ config_cache cups cups/cups.h
+ config_cache alsa alsa/asoundlib.h sys/asoundlib.h asound:snd_pcm_open
+ config_cache nas audio/audiolib.h audio/soundlib.h
+ config_cache xml libxml/parser.h libxslt/pattern.h libxslt/transform.h
+ config_cache ldap ldap.h lber.h
+ config_cache dbus dbus/dbus.h
+ config_cache hal hal/libhal.h
+ config_cache jpeg jpeglib.h
+ config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
+ config_cache lcms lcms.h
+
+ strip-flags
+
+ use amd64 && multilib_toolchain_setup x86
+
+ # $(use_enable amd64 win64)
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with ncurses curses) \
+ $(use_with opengl) \
+ $(use_with X x) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+ emake all || die "all"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ANNOUNCE AUTHORS ChangeLog DEVELOPERS-HINTS README
+}
+
+pkg_postinst() {
+ elog "~/.wine/config is now deprecated. For configuration either use"
+ elog "winecfg or regedit HKCU\\Software\\Wine"
+}