summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-01-05 15:03:40 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-01-05 15:03:40 +0000
commit902be9414c8f748156e352c7835b469626b79e2d (patch)
tree42b2a8276a70bb4c10a2fa621f383cc9625d6c75 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-902be9414c8f748156e352c7835b469626b79e2d.tar.gz
gentoo-2-902be9414c8f748156e352c7835b469626b79e2d.tar.bz2
gentoo-2-902be9414c8f748156e352c7835b469626b79e2d.zip
Added files for schema/protocol instead of cat'ting them in the ebuild.
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/ChangeLog8
-rw-r--r--app-emulation/spice/files/spice.protocol12
-rw-r--r--app-emulation/spice/files/spice.schemas41
-rw-r--r--app-emulation/spice/spice-0.7.1.ebuild51
4 files changed, 81 insertions, 31 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index d54b36f98bfc..839b04ba07de 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/spice
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.5 2010/12/29 09:30:52 dev-zero Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.6 2011/01/05 15:03:39 dev-zero Exp $
+
+ 05 Jan 2011; Tiziano Müller <dev-zero@gentoo.org> spice-0.7.1.ebuild,
+ +files/spice.protocol, +files/spice.schemas:
+ Added files for schema/protocol instead of cat'ting them in the ebuild.
*spice-0.7.1 (29 Dec 2010)
diff --git a/app-emulation/spice/files/spice.protocol b/app-emulation/spice/files/spice.protocol
new file mode 100644
index 000000000000..13a2817fd554
--- /dev/null
+++ b/app-emulation/spice/files/spice.protocol
@@ -0,0 +1,12 @@
+[Protocol]
+exec=/usr/bin/spicec --uri "%u"
+protocol=spice
+input=none
+output=none
+helper=true
+listing=
+reading=false
+writing=false
+makedir=false
+deleting=false
+
diff --git a/app-emulation/spice/files/spice.schemas b/app-emulation/spice/files/spice.schemas
new file mode 100644
index 000000000000..f3ba2f5e5f87
--- /dev/null
+++ b/app-emulation/spice/files/spice.schemas
@@ -0,0 +1,41 @@
+<?xml version="1.0"?>
+<gconfschemafile>
+<schemalist>
+<schema>
+ <key>/schemas/desktop/gnome/url-handlers/spice/enabled</key>
+ <applyto>/desktop/gnome/url-handlers/spice/enabled</applyto>
+ <owner>spice</owner>
+ <type>bool</type>
+ <default>true</default>
+ <locale name="C">
+ <short>How to handle spice URLs</short>
+ <long>Set to true to have a program specified in command handle spice URLs</long>
+ </locale>
+</schema>
+
+ <schema>
+ <key>/schemas/desktop/gnome/url-handlers/spice/command</key>
+ <applyto>/desktop/gnome/url-handlers/spice/command</applyto>
+ <owner>spice</owner>
+ <type>string</type>
+ <default>/usr/bin/spicec --uri "%s"</default>
+ <locale name="C">
+ <short>URL handler for spice URIs</short>
+ <long>URL handler for spice URIs</long>
+ </locale>
+ </schema>
+
+ <schema>
+ <key>/schemas/desktop/gnome/url-handlers/spice/need-terminal</key>
+ <applyto>/desktop/gnome/url-handlers/spice/need-terminal</applyto>
+ <owner>spice</owner>
+ <type>bool</type>
+ <default>false</default>
+ <locale name="C">
+ <short>Run program in terminal</short>
+ <long>True if the program to handle this URL should be run in a terminal</long>
+ </locale>
+ </schema>
+</schemalist>
+</gconfschemafile>
+
diff --git a/app-emulation/spice/spice-0.7.1.ebuild b/app-emulation/spice/spice-0.7.1.ebuild
index 0eddf89f708e..1d2dad05b387 100644
--- a/app-emulation/spice/spice-0.7.1.ebuild
+++ b/app-emulation/spice/spice-0.7.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.7.1.ebuild,v 1.2 2011/01/05 13:14:18 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.7.1.ebuild,v 1.3 2011/01/05 15:03:39 dev-zero Exp $
EAPI=3
-inherit autotools eutils
+inherit autotools eutils gnome2-utils
DESCRIPTION="SPICE server and client."
HOMEPAGE="http://spice-space.org/"
@@ -13,7 +13,7 @@ SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+gui kde static-libs uri"
+IUSE="gnome +gui kde static-libs uri"
RDEPEND=">=app-emulation/spice-protocol-0.7.0
>=x11-libs/pixman-0.17.7
@@ -28,7 +28,8 @@ RDEPEND=">=app-emulation/spice-protocol-0.7.0
virtual/jpeg
sys-libs/zlib
gui? ( =dev-games/cegui-0.6* )
- uri? ( dev-libs/uriparser )"
+ uri? ( dev-libs/uriparser
+ gnome? ( gnome-base/gconf ) )"
DEPEND="dev-util/pkgconfig
${RDEPEND}"
@@ -54,33 +55,25 @@ src_install() {
dodoc NEWS TODO
use static-libs || rm "${D}"/usr/lib*/*.la
- if use uri && use kde ; then
- dodir /usr/share/kde4/services
- cat > "${D}/usr/share/kde4/services/spice.protocol" << EOF
-[Protocol]
-exec=/usr/bin/spicec --uri "%u"
-protocol=spice
-input=none
-output=none
-helper=true
-listing=
-reading=false
-writing=false
-makedir=false
-deleting=false
-EOF
- fi
-}
-
-pkg_postinst() {
if use uri ; then
- elog "You enabled uri-handler support in spice. Therefore you"
- elog "might want your browser / deskop environment to handle"
- elog "spice uri's using spicec. To enable this, run:"
- elog " gconftool-2 -s /desktop/gnome/url-handlers/spice/command '/usr/bin/spicec --uri "%s"' --type String"
- elog " gconftool-2 -s /desktop/gnome/url-handlers/spice/enabled --type Boolean true"
+ if use gnome ; then
+ insinto /etc/gconf/schemas
+ doins ${FILESDIR}/spice.schemas
+ fi
if use kde ; then
- elog "For KDE the protocol could be registered automatically."
+ insinto /usr/share/kde4/services
+ doins "${FILESDIR}/spice.protocol"
fi
fi
}
+
+pkg_preinst() {
+ use uri && use gnome && gnome2_gconf_savelist
+}
+pkg_postinst() {
+ use uri && use gnome && gnome2_gconf_install
+}
+
+pkg_prerm() {
+ use uri && use gnome && gnome2_gconf_uninstall
+}