summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2006-09-13 21:48:38 +0000
committerMike Auty <ikelos@gentoo.org>2006-09-13 21:48:38 +0000
commit9340f22ae89d6b32f9ecf31b55db76e41a9e596f (patch)
tree75ac3940b57a15177b75bad1027e1f0e702b9611 /app-emulation
parentMark 2.14.2.1 stable on ia64. #139612 (diff)
downloadgentoo-2-9340f22ae89d6b32f9ecf31b55db76e41a9e596f.tar.gz
gentoo-2-9340f22ae89d6b32f9ecf31b55db76e41a9e596f.tar.bz2
gentoo-2-9340f22ae89d6b32f9ecf31b55db76e41a9e596f.zip
Add a patch to fix compilation against kernels <= 2.6.16 with gcc-4.1. Closes bug #146004.
(Portage version: 2.1.1)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-modules/ChangeLog8
-rw-r--r--app-emulation/vmware-modules/files/1.0.0.15-gcc4-ignore-pedantic-errors.patch12
-rw-r--r--app-emulation/vmware-modules/vmware-modules-1.0.0.15.ebuild17
3 files changed, 34 insertions, 3 deletions
diff --git a/app-emulation/vmware-modules/ChangeLog b/app-emulation/vmware-modules/ChangeLog
index 2ac79ec88a52..893d26dc845d 100644
--- a/app-emulation/vmware-modules/ChangeLog
+++ b/app-emulation/vmware-modules/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vmware-modules
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.8 2006/08/28 12:58:14 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.9 2006/09/13 21:48:38 ikelos Exp $
+
+ 13 Sep 2006; Mike Auty <ikelos@gentoo.org>
+ +files/1.0.0.15-gcc4-ignore-pedantic-errors.patch,
+ vmware-modules-1.0.0.15.ebuild:
+ Add a patch to fix compilation against kernels <= 2.6.16 with gcc-4.1.
+ Closes bug #146004.
28 Aug 2006; Chris Gianelloni <wolf31o2@gentoo.org>
vmware-modules-1.0.0.8.ebuild:
diff --git a/app-emulation/vmware-modules/files/1.0.0.15-gcc4-ignore-pedantic-errors.patch b/app-emulation/vmware-modules/files/1.0.0.15-gcc4-ignore-pedantic-errors.patch
new file mode 100644
index 000000000000..7b3595f27604
--- /dev/null
+++ b/app-emulation/vmware-modules/files/1.0.0.15-gcc4-ignore-pedantic-errors.patch
@@ -0,0 +1,12 @@
+diff -uNr Makefile.kernel Makefile.kernel
+--- Makefile.kernel 2006-09-03 19:55:36.000000000 +0100
++++ Makefile.kernel 2006-09-03 19:55:52.000000000 +0100
+@@ -8,7 +8,7 @@
+
+ vm_check_build = $(shell if $(CC) $(CPPFLAGS) $(CFLAGS) $(CFLAGS_KERNEL) \
+ $(EXTRA_CFLAGS) -Iinclude2/asm/mach-default -DKBUILD_BASENAME=\"$(DRIVER)\" \
+- -Werror -S -o /dev/null -xc $(1) \
++ -Wno-declaration-after-statement -Werror -S -o /dev/null -xc $(1) \
+ > /dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi)
+
+ CC_WARNINGS := -Wall -Wstrict-prototypes
diff --git a/app-emulation/vmware-modules/vmware-modules-1.0.0.15.ebuild b/app-emulation/vmware-modules/vmware-modules-1.0.0.15.ebuild
index 35326cd9f901..51b319396a32 100644
--- a/app-emulation/vmware-modules/vmware-modules-1.0.0.15.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-1.0.0.15.ebuild
@@ -1,11 +1,24 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-1.0.0.15.ebuild,v 1.3 2006/08/19 16:35:19 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-1.0.0.15.ebuild,v 1.4 2006/09/13 21:48:38 ikelos Exp $
-inherit vmware-mod
+inherit toolchain-funcs vmware-mod
SRC_URI="http://download3.vmware.com/software/vmserver/VMware-server-1.0.1-29996.tar.gz"
KEYWORDS="-* ~amd64 ~x86"
VMWARE_VER="VME_S1B1"
VMWARE_MOD_DIR="vmware-server-distrib/lib/modules/source"
+
+src_unpack() {
+ vmware-mod_src_unpack
+
+ if [[ "$(gcc-major-version)" -eq "4" ]] ; then
+ if [[ $(gcc-minor-version) -ge 1 ]] ; then
+ for mod in ${VMWARE_MODULE_LIST}; do
+ cd "${S}"/${mod}-only
+ epatch ${FILESDIR}/${PV}-gcc4-ignore-pedantic-errors.patch
+ done
+ fi
+ fi
+}