summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-09-02 19:12:36 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-09-02 19:12:36 +0000
commit954d5b476c4a7631e60a2723fd6df2b51fe02894 (patch)
tree63b16e3a4c2f3690e156f82ba92b4018fc5c3ae8 /app-emulation
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-954d5b476c4a7631e60a2723fd6df2b51fe02894.tar.gz
gentoo-2-954d5b476c4a7631e60a2723fd6df2b51fe02894.tar.bz2
gentoo-2-954d5b476c4a7631e60a2723fd6df2b51fe02894.zip
upstream version bump plus backporting translation updates from upstream
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virtinst/ChangeLog7
-rw-r--r--app-emulation/virtinst/virtinst-0.500.4.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-emulation/virtinst/ChangeLog b/app-emulation/virtinst/ChangeLog
index 7c7c4b09bd4e..115e7b7904ce 100644
--- a/app-emulation/virtinst/ChangeLog
+++ b/app-emulation/virtinst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virtinst
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.18 2010/04/28 21:33:45 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.19 2010/09/02 19:12:36 cardoe Exp $
+
+*virtinst-0.500.4 (02 Sep 2010)
+
+ 02 Sep 2010; Doug Goldstein <cardoe@gentoo.org> +virtinst-0.500.4.ebuild:
+ upstream version bump plus backporting translation updates from upstream
*virtinst-0.500.3 (28 Apr 2010)
diff --git a/app-emulation/virtinst/virtinst-0.500.4.ebuild b/app-emulation/virtinst/virtinst-0.500.4.ebuild
new file mode 100644
index 000000000000..709d44d47da7
--- /dev/null
+++ b/app-emulation/virtinst/virtinst-0.500.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.500.4.ebuild,v 1.1 2010/09/02 19:12:36 cardoe Exp $
+
+BACKPORTS=1
+
+EAPI=2
+
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="Python modules for starting virtualized guest installations"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=">=app-emulation/libvirt-0.7.0[python]
+ dev-python/urlgrabber"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="virtconv virtinst"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ distutils_src_prepare
+}
+