summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-04-05 18:56:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-04-05 18:56:37 +0000
commit96ecf37bda1c72f73f8d2c6ea0e4132bf6af92fd (patch)
treefc01736adbe4364d0eeaadc3b01a4acd811433dd /app-emulation
parentStable for sparc, wrt bug #463884 (diff)
downloadgentoo-2-96ecf37bda1c72f73f8d2c6ea0e4132bf6af92fd.tar.gz
gentoo-2-96ecf37bda1c72f73f8d2c6ea0e4132bf6af92fd.tar.bz2
gentoo-2-96ecf37bda1c72f73f8d2c6ea0e4132bf6af92fd.zip
fix buffer overflow (bug #464708)
(Portage version: 2.1.11.55/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vice/ChangeLog8
-rw-r--r--app-emulation/vice/files/vice-2.4-arm.patch12
-rw-r--r--app-emulation/vice/files/vice-2.4-buffer.patch14
-rw-r--r--app-emulation/vice/files/vice-2.4-ffmpeg-1.patch6
-rw-r--r--app-emulation/vice/vice-2.4.ebuild5
5 files changed, 28 insertions, 17 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index 58fdf7e986b2..82b4c820ca55 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vice
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.87 2013/01/24 14:40:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.88 2013/04/05 18:56:37 mr_bones_ Exp $
+
+ 05 Apr 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/vice-2.4-buffer.patch, files/vice-2.3-libav.patch,
+ files/vice-2.3-notexi.patch, files/vice-2.4-arm.patch,
+ files/vice-2.4-ffmpeg-1.patch, vice-2.4.ebuild:
+ fix buffer overflow (bug #464708)
24 Jan 2013; Alexis Ballier <aballier@gentoo.org> vice-2.4.ebuild,
+files/vice-2.4-ffmpeg-1.patch:
diff --git a/app-emulation/vice/files/vice-2.4-arm.patch b/app-emulation/vice/files/vice-2.4-arm.patch
index d96a75d2296d..55e2d5a35b0c 100644
--- a/app-emulation/vice/files/vice-2.4-arm.patch
+++ b/app-emulation/vice/files/vice-2.4-arm.patch
@@ -1,7 +1,5 @@
-Index: vice/configure.in
-===================================================================
---- vice/configure.in (Revision 26764)
-+++ vice/configure.in (Revision 26765)
+--- vice/configure.in
++++ vice/configure.in
@@ -2299,6 +2299,7 @@
if test x"$PARSID_SUPPORT" = "xno"; then
@@ -10,10 +8,8 @@ Index: vice/configure.in
fi
if test x"$PARSID_SUPPORT" = "xyes"; then
-Index: vice/src/arch/unix/parsid.c
-===================================================================
---- vice/src/arch/unix/parsid.c (Revision 26764)
-+++ vice/src/arch/unix/parsid.c (Revision 26765)
+--- vice/src/arch/unix/parsid.c
++++ vice/src/arch/unix/parsid.c
@@ -217,8 +217,12 @@
#endif
#endif
diff --git a/app-emulation/vice/files/vice-2.4-buffer.patch b/app-emulation/vice/files/vice-2.4-buffer.patch
new file mode 100644
index 000000000000..dc5fab9b5725
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.4-buffer.patch
@@ -0,0 +1,14 @@
+avoid writing past the end of the gcr_track buffer
+https://bugs.gentoo.org/show_bug.cgi?id=464708
+
+--- ./src/diskimage/fsimage-create.c.orig
++++ ./src/diskimage/fsimage-create.c
+@@ -262,7 +262,7 @@
+ gcrptr = gcr_track;
+ util_word_to_le_buf(gcrptr, disk_image_raw_track_size(image->type, track));
+ gcrptr += 2;
+- memset(gcrptr, 0x55, NUM_MAX_BYTES_TRACK);
++ memset(gcrptr, 0x55, NUM_MAX_BYTES_TRACK - 2);
+
+ header.track = track;
+ for (sector = 0;
diff --git a/app-emulation/vice/files/vice-2.4-ffmpeg-1.patch b/app-emulation/vice/files/vice-2.4-ffmpeg-1.patch
index e601e7041697..4aefda24584f 100644
--- a/app-emulation/vice/files/vice-2.4-ffmpeg-1.patch
+++ b/app-emulation/vice/files/vice-2.4-ffmpeg-1.patch
@@ -3,8 +3,6 @@ Fixes build with recent FFmpeg versions.
https://bugs.gentoo.org/show_bug.cgi?id=443218
https://sourceforge.net/tracker/?func=detail&aid=3601992&group_id=223021&atid=1057619
-Index: vice-2.4/src/gfxoutputdrv/ffmpegdrv.c
-===================================================================
--- vice-2.4.orig/src/gfxoutputdrv/ffmpegdrv.c
+++ vice-2.4/src/gfxoutputdrv/ffmpegdrv.c
@@ -343,7 +343,7 @@ static int ffmpegmovie_init_audio(int sp
@@ -59,8 +57,6 @@ Index: vice-2.4/src/gfxoutputdrv/ffmpegdrv.c
}
}
-Index: vice-2.4/src/gfxoutputdrv/ffmpeglib.c
-===================================================================
--- vice-2.4.orig/src/gfxoutputdrv/ffmpeglib.c
+++ vice-2.4/src/gfxoutputdrv/ffmpeglib.c
@@ -208,13 +208,12 @@ static int load_avformat(ffmpeglib_t *li
@@ -99,8 +95,6 @@ Index: vice-2.4/src/gfxoutputdrv/ffmpeglib.c
lib->p_av_guess_format = NULL;
#ifndef HAVE_FFMPEG_SWSCALE
lib->p_img_convert = NULL;
-Index: vice-2.4/src/gfxoutputdrv/ffmpeglib.h
-===================================================================
--- vice-2.4.orig/src/gfxoutputdrv/ffmpeglib.h
+++ vice-2.4/src/gfxoutputdrv/ffmpeglib.h
@@ -80,13 +80,12 @@ typedef int (*avpicture_get_size_t) (int
diff --git a/app-emulation/vice/vice-2.4.ebuild b/app-emulation/vice/vice-2.4.ebuild
index 6f9f64bad2df..9be5dd03218d 100644
--- a/app-emulation/vice/vice-2.4.ebuild
+++ b/app-emulation/vice/vice-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.4.ebuild,v 1.4 2013/01/24 14:40:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.4.ebuild,v 1.5 2013/04/05 18:56:37 mr_bones_ Exp $
EAPI=5
inherit autotools eutils toolchain-funcs games
@@ -60,7 +60,8 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-arm.patch \
- "${FILESDIR}"/${P}-ffmpeg-1.patch
+ "${FILESDIR}"/${P}-ffmpeg-1.patch \
+ "${FILESDIR}"/${P}-buffer.patch
sed -i \
-e "s:/usr/local/lib/VICE:${GAMES_DATADIR}/${PN}:" \
man/vice.1 \