summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-04-29 22:27:37 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-04-29 22:27:37 +0000
commit9afda8d3c64aea714fbef995b6bb2d152d1b9698 (patch)
treecb3a40bb7bb9420dd0cdbdc29fb7cdc09385e325 /app-emulation
parentFixed broken Manifest. (diff)
downloadgentoo-2-9afda8d3c64aea714fbef995b6bb2d152d1b9698.tar.gz
gentoo-2-9afda8d3c64aea714fbef995b6bb2d152d1b9698.tar.bz2
gentoo-2-9afda8d3c64aea714fbef995b6bb2d152d1b9698.zip
Retouches retouches retouches
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog5
-rw-r--r--app-emulation/qemu/Manifest2
-rw-r--r--app-emulation/qemu/qemu-0.7.0.ebuild26
3 files changed, 18 insertions, 15 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 7b9189ccf6e3..f840127a1465 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/qemu
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.30 2005/04/29 13:59:00 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.31 2005/04/29 22:27:37 lu_zero Exp $
+
+ 29 Apr 2005; Luca Barbato <lu_zero@gentoo.org> qemu-0.7.0.ebuild:
+ Retouches and corrections, thanks to genstef as usual
29 Apr 2005; Luca Barbato <lu_zero@gentoo.org> qemu-0.7.0.ebuild:
Added udev support and qemu group creation
diff --git a/app-emulation/qemu/Manifest b/app-emulation/qemu/Manifest
index 2d5c893c9a38..a0ac54be7cac 100644
--- a/app-emulation/qemu/Manifest
+++ b/app-emulation/qemu/Manifest
@@ -1,6 +1,6 @@
MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
MD5 518988ab13f6b610696b8706d31d2fb9 qemu-0.6.0.ebuild 1895
-MD5 30a58ecb767f56b896f85f045a2c46d6 qemu-0.7.0.ebuild 3899
+MD5 7ef0e99931db2d2a91d61cae0ada47bd qemu-0.7.0.ebuild 3894
MD5 b035e8de3718e77cc27918198bf49fb6 qemu-0.6.1-r1.ebuild 2143
MD5 e65dab4abb0028ab15d60ecd60ca4ba9 qemu-0.6.1.ebuild 2071
MD5 c0f431d159954d598817d53838ddef33 ChangeLog 3867
diff --git a/app-emulation/qemu/qemu-0.7.0.ebuild b/app-emulation/qemu/qemu-0.7.0.ebuild
index ac9fb8f29298..6faac7dd4a50 100644
--- a/app-emulation/qemu/qemu-0.7.0.ebuild
+++ b/app-emulation/qemu/qemu-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.7.0.ebuild,v 1.3 2005/04/29 13:59:00 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.7.0.ebuild,v 1.4 2005/04/29 22:27:37 lu_zero Exp $
inherit eutils flag-o-matic linux-mod
@@ -35,16 +35,14 @@ set_target_list() {
pkg_setup() {
# ( use kqemu || use qvm86 ) && linux-mod_pkg_setup
- ( use kqemu ) && linux-mod_pkg_setup
+ use kqemu && linux-mod_pkg_setup
}
#RUNTIME_PATH="/emul/gnemul/"
src_unpack() {
unpack ${A}
- use kqemu &&
-
- (
+ if use kqemu ; then
einfo "QEMU Accelerator enabled"
einfo "kqemu actually is a closed source software"
einfo "Please read carefully the KQEMU license"
@@ -53,7 +51,8 @@ src_unpack() {
mv ${S}/../kqemu ${S}
cd ${S}/kqemu
epatch ${FILESDIR}/kqemu-sysfs.patch
- )
+ fi
+
# if use qvm86; then
# mv ${WORKDIR}/qvm86 ${S}
# cd ${S}
@@ -81,12 +80,13 @@ src_compile() {
--prefix=/usr \
--target-list="${TARGET_LIST}" \
--enable-slirp \
+ --kernel-path=${KV_DIR} \
$(use_enable kqemu) \
${myconf} \
`use_enable sdl`\
|| die "could not configure"
- make || die "make failed"
-# $(use_enable qvm86) \
+
+ emake || die "make failed"
}
src_install() {
@@ -100,7 +100,7 @@ src_install() {
chmod -x ${D}/usr/share/man/*/*
if use kqemu ; then
-#if use kqemu || use qvm86; then
+
linux-mod_src_install
# udev rule
@@ -118,14 +118,14 @@ src_install() {
pkg_postinst() {
einfo "You will need the Universal TUN/TAP driver compiled into"
einfo "kernel or as a module to use the virtual network device."
- use softmmu || \
- (
+ if use ! softmmu ; then
ewarn ""
ewarn "You have the softmmu useflag disabled."
ewarn "In order to have the full system emulator (qemu) you have"
ewarn "to emerge qemu again with the softmmu useflag enabled."
- )
- if use kqemu; then
+ ewarn ""
+ fi
+ if use kqemu ; then
einfo "kqemu actually is a closed source software"
einfo "Please read carefully the KQEMU license"
einfo "and http://fabrice.bellard.free.fr/qemu/qemu-accel.html"