summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-02-20 23:10:16 +0000
committerPacho Ramos <pacho@gentoo.org>2010-02-20 23:10:16 +0000
commitcc2ae1c3fd5706c987f5ada99d97b6ebea760fb6 (patch)
treea806ab6e728ad36bbf9155870944c9c47690ccc9 /app-emulation
parentVersion bump (diff)
downloadgentoo-2-cc2ae1c3fd5706c987f5ada99d97b6ebea760fb6.tar.gz
gentoo-2-cc2ae1c3fd5706c987f5ada99d97b6ebea760fb6.tar.bz2
gentoo-2-cc2ae1c3fd5706c987f5ada99d97b6ebea760fb6.zip
Version bump
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/emul-linux-x86-soundlibs/ChangeLog8
-rw-r--r--app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20100220.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/app-emulation/emul-linux-x86-soundlibs/ChangeLog b/app-emulation/emul-linux-x86-soundlibs/ChangeLog
index 0f71ad35a4c9..44771cbb45e2 100644
--- a/app-emulation/emul-linux-x86-soundlibs/ChangeLog
+++ b/app-emulation/emul-linux-x86-soundlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/emul-linux-x86-soundlibs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/ChangeLog,v 1.55 2010/02/10 09:48:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/ChangeLog,v 1.56 2010/02/20 23:10:16 pacho Exp $
+
+*emul-linux-x86-soundlibs-20100220 (20 Feb 2010)
+
+ 20 Feb 2010; Pacho Ramos <pacho@gentoo.org>
+ +emul-linux-x86-soundlibs-20100220.ebuild:
+ Version bump with updated packages
10 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
-emul-linux-x86-soundlibs-20081109.ebuild:
diff --git a/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20100220.ebuild b/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20100220.ebuild
new file mode 100644
index 000000000000..2e932cd3e971
--- /dev/null
+++ b/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20100220.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20100220.ebuild,v 1.1 2010/02/20 23:10:16 pacho Exp $
+
+inherit emul-linux-x86
+
+LICENSE="as-is BSD GPL-2 LGPL-2 LGPL-2.1 gsm"
+KEYWORDS="-* ~amd64"
+IUSE="alsa pulseaudio"
+
+RDEPEND="pulseaudio? ( media-sound/pulseaudio )
+ ~app-emulation/emul-linux-x86-baselibs-${PV}
+ ~app-emulation/emul-linux-x86-medialibs-${PV}"
+
+QA_DT_HASH="usr/lib32/.*"
+
+src_unpack() {
+ _ALLOWED="${S}/etc/env.d"
+ use alsa && _ALLOWED="${_ALLOWED}|${S}/usr/bin/aoss"
+ ALLOWED="(${_ALLOWED})"
+
+ emul-linux-x86_src_unpack
+
+ if use alsa; then
+ mv -f "${S}"/usr/bin/aoss{,32} || die
+ fi
+
+ # libs without the rest of pulseaudio cause problems, bug 302003
+ if ! use pulseaudio; then
+ rm -rf $(find "${S}" -name '*pulse*' -not -name '*impulse*') || die
+ fi
+}