summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-08-10 03:19:51 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-08-10 03:19:51 +0000
commitd027528f08a5284e1d6ce3b26121abc4c7f85eb6 (patch)
treeacdf36e1884f79f12f5905edb73275931b530ac3 /app-emulation
parentFix up a few missing options from kernel feature detection. (diff)
downloadgentoo-2-d027528f08a5284e1d6ce3b26121abc4c7f85eb6.tar.gz
gentoo-2-d027528f08a5284e1d6ce3b26121abc4c7f85eb6.tar.bz2
gentoo-2-d027528f08a5284e1d6ce3b26121abc4c7f85eb6.zip
Remove older version and older files
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog9
-rw-r--r--app-emulation/libvirt/files/libvirt-1.0.6-CVE-2013-2218.patch37
-rw-r--r--app-emulation/libvirt/files/libvirt-1.0.6-virinterface-udev-backend-ro.patch24
-rw-r--r--app-emulation/libvirt/files/libvirt-1.1.0-CVE-2013-2230.patch17
-rw-r--r--app-emulation/libvirt/files/libvirtd.init-r11129
-rw-r--r--app-emulation/libvirt/libvirt-1.1.0-r3.ebuild427
6 files changed, 8 insertions, 635 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index 4d0690074744..76cee6e8164b 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.306 2013/08/10 03:11:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.307 2013/08/10 03:19:51 cardoe Exp $
+
+ 10 Aug 2013; Doug Goldstein <cardoe@gentoo.org>
+ -files/libvirt-1.0.6-CVE-2013-2218.patch,
+ -files/libvirt-1.0.6-virinterface-udev-backend-ro.patch,
+ -files/libvirt-1.1.0-CVE-2013-2230.patch, -files/libvirtd.init-r11,
+ -libvirt-1.1.0-r3.ebuild:
+ Remove older version and older files
10 Aug 2013; Doug Goldstein <cardoe@gentoo.org> libvirt-1.1.1-r1.ebuild,
libvirt-9999.ebuild:
diff --git a/app-emulation/libvirt/files/libvirt-1.0.6-CVE-2013-2218.patch b/app-emulation/libvirt/files/libvirt-1.0.6-CVE-2013-2218.patch
deleted file mode 100644
index 38f849e610e9..000000000000
--- a/app-emulation/libvirt/files/libvirt-1.0.6-CVE-2013-2218.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From: "Daniel P. Berrange" <berrange@redhat.com>
-Date: Fri, 28 Jun 2013 10:48:37 +0100
-Subject: [PATCH] CVE-2013-2218: Fix crash listing network interfaces with
- filters
-
-The virConnectListAllInterfaces method has a double-free of the
-'struct netcf_if' object when any of the filtering flags cause
-an interface to be skipped over. For example when running the
-command 'virsh iface-list --inactive'
-
-This is a regression introduced in release 1.0.6 by
-
- commit 7ac2c4fe624f30f2c8270116513fa2ddab07631f
- Author: Guannan Ren <gren@redhat.com>
- Date: Tue May 21 21:29:38 2013 +0800
-
- interface: list all interfaces with flags == 0
-
-Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
----
- src/interface/interface_backend_netcf.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/interface/interface_backend_netcf.c b/src/interface/interface_backend_netcf.c
-index a995816..9aa673d 100644
---- a/src/interface/interface_backend_netcf.c
-+++ b/src/interface/interface_backend_netcf.c
-@@ -412,6 +412,7 @@ netcfConnectListAllInterfaces(virConnectPtr conn,
- (MATCH(VIR_CONNECT_LIST_INTERFACES_INACTIVE) &&
- (status & NETCF_IFACE_INACTIVE)))) {
- ncf_if_free(iface);
-+ iface = NULL;
- continue;
- }
-
---
-1.8.2.1
diff --git a/app-emulation/libvirt/files/libvirt-1.0.6-virinterface-udev-backend-ro.patch b/app-emulation/libvirt/files/libvirt-1.0.6-virinterface-udev-backend-ro.patch
deleted file mode 100644
index d95f7a917aff..000000000000
--- a/app-emulation/libvirt/files/libvirt-1.0.6-virinterface-udev-backend-ro.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-commit 027a7707bea5ba455212715278e3ae486f97eacb
-Author: Doug Goldstein <cardoe@cardoe.com>
-Date: Thu Jun 27 20:43:00 2013 -0500
-
- Allow RO connections to interface udev backend
-
- The udev based interface backend did not allow querying data over a
- read-only connection which is different than how the netcf backend
- operates. This brings the behavior inline with the default, netcf
- backend.
-
-diff --git a/src/interface/interface_backend_udev.c b/src/interface/interface_backend_udev.c
-index 68e1e2f..95034bf 100644
---- a/src/interface/interface_backend_udev.c
-+++ b/src/interface/interface_backend_udev.c
-@@ -139,7 +139,7 @@ udevInterfaceOpen(virConnectPtr conn,
- {
- struct udev_iface_driver *driverState = NULL;
-
-- virCheckFlags(0, VIR_DRV_OPEN_ERROR);
-+ virCheckFlags(VIR_CONNECT_RO, VIR_DRV_OPEN_ERROR);
-
- if (VIR_ALLOC(driverState) < 0) {
- virReportOOMError();
diff --git a/app-emulation/libvirt/files/libvirt-1.1.0-CVE-2013-2230.patch b/app-emulation/libvirt/files/libvirt-1.1.0-CVE-2013-2230.patch
deleted file mode 100644
index 127409442f86..000000000000
--- a/app-emulation/libvirt/files/libvirt-1.1.0-CVE-2013-2230.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-X-Git-Url: http://libvirt.org/git/?p=libvirt.git;a=blobdiff_plain;f=src%2Fqemu%2Fqemu_driver.c;h=b0180c9497da8579d3b2228a76e1579d26cdcaaa;hp=571d1f8c6b0866e2701b3b075cb6d2c53dffa75e;hb=f38c8185f97720ecae7ef2291fbaa5d6b0209e17;hpb=5744d96f211160d406ec0498c2f814a67d1a3fc8
-
-diff --git a/src/qemu/qemu_driver.c b/src/qemu/qemu_driver.c
-index 571d1f8..b0180c9 100644
---- a/src/qemu/qemu_driver.c
-+++ b/src/qemu/qemu_driver.c
-@@ -10043,9 +10043,7 @@ qemuConnectDomainEventRegisterAny(virConnectPtr conn,
- driver->domainEventState,
- dom, eventID,
- callback, opaque, freecb, &ret) < 0)
-- goto cleanup;
--
-- ret = 0;
-+ ret = -1;
-
- cleanup:
- return ret;
diff --git a/app-emulation/libvirt/files/libvirtd.init-r11 b/app-emulation/libvirt/files/libvirtd.init-r11
deleted file mode 100644
index dc7fee45c6c9..000000000000
--- a/app-emulation/libvirt/files/libvirtd.init-r11
+++ /dev/null
@@ -1,129 +0,0 @@
-#!/sbin/runscript
-
-description="Virtual Machine Management daemon (libvirt)"
-extra_started_commands="reload halt"
-description_halt="Stops the libvirt daemon without stopping your VMs"
-description_reload="Restarts the libvirt daemon without stopping your VMs"
-
-depend() {
- USE_FLAG_FIREWALLD
- use USE_FLAG_AVAHI USE_FLAG_ISCSI USE_FLAG_RBD dbus
- after ntp-client ntpd nfs nfsmount portmap rpc.statd iptables ip6tables ebtables corosync sanlock cgconfig
-}
-
-libvirtd_virsh() {
- local mode=$1
- shift
-
- # Silence errors because virsh always throws an error about
- # not finding the hypervisor version when connecting to libvirtd
- LC_ALL=C virsh -c ${mode}:///system "$@" 2>/dev/null
-}
-
-libvirtd_dom_list() {
- # Make sure that it wouldn't be confused if the domain name
- # contains the word running.
- libvirtd_virsh $1 list | awk '$3 == "running" { print $1 }'
-}
-
-libvirtd_dom_count() {
- # Make sure that it wouldn't be confused if the domain name
- # contains the word running.
- libvirtd_virsh $1 list | awk 'BEGIN { count = 0 } \
- $3 == "running" { count++ } \
- END { print count }'
-}
-
-libvirtd_net_list() {
- # The purpose of the awk is to avoid networks with 'active' in the name
- libvirtd_virsh $1 net-list | awk '$2 == "active" { print $1 }'
-}
-
-libvirtd_net_count() {
- # The purpose of the awk is to avoid networks with 'active' in the name
- libvirtd_virsh $1 net-list | awk 'BEGIN { count = 0 } \
- $2 == "active" { count++ } \
- END { print count }'
-}
-
-
-start() {
- ebegin "Starting libvirtd"
- start-stop-daemon --start \
- --env KRB5_KTNAME=/etc/libvirt/krb5.tab \
- --exec /usr/sbin/libvirtd -- -d ${LIBVIRTD_OPTS}
- eend $?
-}
-
-stop() {
- local counter=
- local vm_name=
- local net_name=
- local dom_id=
-
- ebegin "Stopping libvirtd"
- # try to shutdown all (KVM/Qemu) domains
- if [ "${LIBVIRTD_KVM_SHUTDOWN}" != "none" ] \
- && [ "$(libvirtd_dom_count qemu)" != "0" ] ; then
-
- einfo " Shutting down domain(s):"
- for dom_id in $(libvirtd_dom_list qemu) ; do
- vm_name="$(libvirtd_virsh qemu domname ${dom_id} | head -n 1)"
- einfo " ${vm_name}"
- libvirtd_virsh qemu ${LIBVIRTD_KVM_SHUTDOWN} ${dom_id} > /dev/null
- done
-
- if [ -n "${LIBVIRTD_KVM_SHUTDOWN_MAXWAIT}" ] ; then
- counter="${LIBVIRTD_KVM_SHUTDOWN_MAXWAIT}"
- else
- counter=500
- fi
-
- if [ "${LIBVIRTD_KVM_SHUTDOWN}" = "shutdown" ]; then
- einfo " Waiting ${counter} seconds while domains shutdown ..."
- DOM_COUNT="$(libvirtd_dom_count qemu)"
- while [ ${DOM_COUNT} -gt 0 ] && [ ${counter} -gt 0 ] ; do
- DOM_COUNT="$(libvirtd_dom_count qemu)"
- sleep 1
- counter=$((${counter} - 1))
- echo -n "."
- done
- fi
-
- if [ "$(libvirtd_dom_count qemu)" != "0" ] ; then
- eerror " !!! Some guests are still running, stopping anyway"
- fi
-
- fi
-
- if [ "${LIBVIRTD_KVM_NET_SHUTDOWN}" != "no" ] \
- && [ "$(libvirtd_net_count qemu)" != "0" ]; then
-
- einfo " Shutting down network(s):"
- for net_name in $(libvirtd_net_list qemu); do
- einfo " ${net_name}"
- libvirtd_virsh qemu net-destroy ${net_name} > /dev/null
- done
-
- if [ "$(libvirtd_net_count qemu)" != "0" ]; then
- eerror " !!! Some networks are still active, stopping anyway"
- fi
- fi
-
- # Now actually stop the daemon
- start-stop-daemon --stop --quiet --exec \
- /usr/sbin/libvirtd --pidfile=/var/run/libvirtd.pid
- eend $?
-}
-
-halt() {
- ebegin "Stopping libvirtd without shutting down your VMs"
- start-stop-daemon --stop --quiet --exec \
- /usr/sbin/libvirtd --pidfile=/var/run/libvirtd.pid
- eend $?
-}
-
-reload() {
- halt
- start
-}
diff --git a/app-emulation/libvirt/libvirt-1.1.0-r3.ebuild b/app-emulation/libvirt/libvirt-1.1.0-r3.ebuild
deleted file mode 100644
index 5952db7388c0..000000000000
--- a/app-emulation/libvirt/libvirt-1.1.0-r3.ebuild
+++ /dev/null
@@ -1,427 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.1.0-r3.ebuild,v 1.3 2013/08/02 13:39:00 cardoe Exp $
-
-EAPI=5
-
-BACKPORTS=cafcec2f
-AUTOTOOLIZE=yes
-
-MY_P="${P/_rc/-rc}"
-
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-
-inherit eutils python-single-r1 user autotools linux-info systemd
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="git://libvirt.org/libvirt.git"
- AUTOTOOLIZE=yes
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://libvirt.org/sources/${MY_P}.tar.gz
- ftp://libvirt.org/libvirt/${MY_P}.tar.gz
- ${BACKPORTS:+
- http://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
- KEYWORDS="amd64 ~x86"
-fi
-S="${WORKDIR}/${P%_rc*}"
-
-DESCRIPTION="C toolkit to manipulate virtual machines"
-HOMEPAGE="http://www.libvirt.org/"
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="audit avahi +caps firewalld fuse iscsi +libvirtd lvm lxc +macvtap nfs \
- nls numa openvz parted pcap phyp policykit python +qemu rbd sasl \
- selinux +udev uml +vepa virtualbox virt-network xen elibc_glibc \
- systemd"
-REQUIRED_USE="libvirtd? ( || ( lxc openvz qemu uml virtualbox xen ) )
- lxc? ( caps libvirtd )
- openvz? ( libvirtd )
- qemu? ( libvirtd )
- uml? ( libvirtd )
- vepa? ( macvtap )
- virtualbox? ( libvirtd )
- xen? ( libvirtd )
- virt-network? ( libvirtd )
- firewalld? ( virt-network )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-# gettext.sh command is used by the libvirt command wrappers, and it's
-# non-optional, so put it into RDEPEND.
-# We can use both libnl:1.1 and libnl:3, but if you have both installed, the
-# package will use 3 by default. Since we don't have slot pinning in an API,
-# we must go with the most recent
-RDEPEND="sys-libs/readline
- sys-libs/ncurses
- >=net-misc/curl-7.18.0
- dev-libs/libgcrypt
- >=dev-libs/libxml2-2.7.6
- dev-libs/libnl:3
- >=net-libs/gnutls-1.0.25
- net-libs/libssh2
- sys-apps/dmidecode
- >=sys-apps/util-linux-2.17
- sys-devel/gettext
- >=net-analyzer/netcat6-1.0-r2
- app-misc/scrub
- audit? ( sys-process/audit )
- avahi? ( >=net-dns/avahi-0.6[dbus] )
- caps? ( sys-libs/libcap-ng )
- fuse? ( >=sys-fs/fuse-2.8.6 )
- iscsi? ( sys-block/open-iscsi )
- lxc? ( sys-power/pm-utils )
- lvm? ( >=sys-fs/lvm2-2.02.48-r2 )
- nfs? ( net-fs/nfs-utils )
- numa? (
- >sys-process/numactl-2.0.2
- sys-process/numad
- )
- openvz? ( sys-kernel/openvz-sources )
- parted? (
- >=sys-block/parted-1.8[device-mapper]
- sys-fs/lvm2
- )
- pcap? ( >=net-libs/libpcap-1.0.0 )
- policykit? ( >=sys-auth/polkit-0.9 )
- python? ( ${PYTHON_DEPS} )
- qemu? (
- >=app-emulation/qemu-0.13.0
- dev-libs/yajl
- sys-power/pm-utils
- )
- rbd? ( sys-cluster/ceph )
- sasl? ( dev-libs/cyrus-sasl )
- selinux? ( >=sys-libs/libselinux-2.0.85 )
- virtualbox? ( || ( app-emulation/virtualbox >=app-emulation/virtualbox-bin-2.2.0 ) )
- xen? ( app-emulation/xen-tools app-emulation/xen )
- udev? ( virtual/udev >=x11-libs/libpciaccess-0.10.9 )
- virt-network? ( net-dns/dnsmasq
- >=net-firewall/iptables-1.4.10
- net-misc/radvd
- net-firewall/ebtables
- sys-apps/iproute2[-minimal]
- firewalld? ( net-firewall/firewalld )
- )
- elibc_glibc? ( || ( >=net-libs/libtirpc-0.2.2-r1 <sys-libs/glibc-2.14 ) )"
-# one? ( dev-libs/xmlrpc-c )
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- app-text/xhtml1
- dev-lang/perl
- dev-libs/libxslt"
-
-LXC_CONFIG_CHECK="
- ~CGROUPS
- ~CGROUP_FREEZER
- ~CGROUP_DEVICE
- ~CGROUP_CPUACCT
- ~CGROUP_SCHED
- ~CGROUP_PERF
- ~BLK_CGROUP
- ~NET_CLS_CGROUP
- ~NETPRIO_CGROUP
- ~CPUSETS
- ~RESOURCE_COUNTERS
- ~NAMESPACES
- ~UTS_NS
- ~IPC_NS
- ~PID_NS
- ~NET_NS
- ~DEVPTS_MULTIPLE_INSTANCES
- ~VETH
- ~MACVLAN
- ~POSIX_MQUEUE
- ~!GRKERNSEC_CHROOT_MOUNT
- ~!GRKERNSEC_CHROOT_DOUBLE
- ~!GRKERNSEC_CHROOT_PIVOT
- ~!GRKERNSEC_CHROOT_CHMOD
- ~!GRKERNSEC_CHROOT_CAPS
-"
-
-VIRTNET_CONFIG_CHECK="
- ~BRIDGE_NF_EBTABLES
- ~BRIDGE_EBT_MARK_T
- ~NETFILTER_ADVANCED
- ~NETFILTER_XT_TARGET_CHECKSUM
- ~NETFILTER_XT_CONNMARK
- ~NETFILTER_XT_MARK
-"
-
-MACVTAP_CONFIG_CHECK="~MACVTAP"
-
-pkg_setup() {
- enewgroup qemu 77
- enewuser qemu 77 -1 -1 qemu kvm
-
- # Some people used the masked ebuild which was not adding the qemu
- # user to the kvm group originally. This results in VMs failing to
- # start for some users. bug #430808
- egetent group kvm | grep -q qemu
- if [[ $? -ne 0 ]]; then
- gpasswd -a qemu kvm
- fi
-
- python-single-r1_pkg_setup
-
- # Handle specific kernel versions for different features
- kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
- kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP ~MEMCG_KMEM"
-
- CONFIG_CHECK=""
- use fuse && CONFIG_CHECK+=" ~FUSE_FS"
- use lxc && CONFIG_CHECK+="${LXC_CONFIG_CHECK}"
- use macvtap && CONFIG_CHECK+="${MACVTAP}"
- use virt-network && CONFIG_CHECK+="${VIRTNET_CONFIG_CHECK}"
- if [[ -n ${CONFIG_CHECK} ]]; then
- linux-info_pkg_setup
- fi
-}
-
-src_prepare() {
- touch "${S}/.mailmap"
- [[ -n ${BACKPORTS} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
- epatch
-
- if [[ ${PV} = *9999* ]]; then
-
- # git checkouts require bootstrapping to create the configure script.
- # Additionally the submodules must be cloned to the right locations
- # bug #377279
- ./bootstrap || die "bootstrap failed"
- (
- git submodule status | sed 's/^[ +-]//;s/ .*//'
- git hash-object bootstrap.conf
- ) >.git-module-status
- fi
-
- epatch_user
-
- [[ -n ${AUTOTOOLIZE} ]] && eautoreconf
-
- # Tweak the init script
- local avahi_init=
- local iscsi_init=
- local rbd_init=
- local firewalld_init=
- cp "${FILESDIR}/libvirtd.init-r12" "${S}/libvirtd.init"
- use avahi && avahi_init='avahi-daemon'
- use iscsi && iscsi_init='iscsid'
- use rbd && rbd_init='ceph'
- use firewalld && firewalld_init='need firewalld'
-
- sed -e "s/USE_FLAG_FIREWALLD/${firewalld_init}/" -i "${S}/libvirtd.init"
- sed -e "s/USE_FLAG_AVAHI/${avahi_init}/" -i "${S}/libvirtd.init"
- sed -e "s/USE_FLAG_ISCSI/${iscsi_init}/" -i "${S}/libvirtd.init"
- sed -e "s/USE_FLAG_RBD/${rbd_init}/" -i "${S}/libvirtd.init"
-}
-
-src_configure() {
- local myconf=""
-
- ## enable/disable daemon, otherwise client only utils
- myconf="${myconf} $(use_with libvirtd)"
-
- ## enable/disable the daemon using avahi to find VMs
- myconf="${myconf} $(use_with avahi)"
-
- ## hypervisors on the local host
- myconf="${myconf} $(use_with xen) $(use_with xen xen-inotify)"
- myconf+=" --without-xenapi"
- if use xen && has_version ">=app-emulation/xen-tools-4.2.0"; then
- myconf+=" --with-libxl"
- else
- myconf+=" --without-libxl"
- fi
- myconf="${myconf} $(use_with openvz)"
- myconf="${myconf} $(use_with lxc)"
- if use virtualbox && has_version app-emulation/virtualbox-ose; then
- myconf="${myconf} --with-vbox=/usr/lib/virtualbox-ose/"
- else
- myconf="${myconf} $(use_with virtualbox vbox)"
- fi
- myconf="${myconf} $(use_with uml)"
- myconf="${myconf} $(use_with qemu)"
- myconf="${myconf} $(use_with qemu yajl)" # Use QMP over HMP
- myconf="${myconf} $(use_with phyp)"
- myconf="${myconf} --with-esx"
- myconf="${myconf} --with-vmware"
-
- ## additional host drivers
- myconf="${myconf} $(use_with virt-network network)"
- myconf="${myconf} --with-storage-fs"
- myconf="${myconf} $(use_with lvm storage-lvm)"
- myconf="${myconf} $(use_with iscsi storage-iscsi)"
- myconf="${myconf} $(use_with parted storage-disk)"
- myconf="${myconf} $(use_with lvm storage-mpath)"
- myconf="${myconf} $(use_with rbd storage-rbd)"
- myconf="${myconf} $(use_with numa numactl)"
- myconf="${myconf} $(use_with numa numad)"
- myconf="${myconf} $(use_with selinux)"
- myconf="${myconf} $(use_with fuse)"
-
- # udev for device support details
- myconf="${myconf} $(use_with udev)"
-
- # linux capability support so we don't need privileged accounts
- myconf="${myconf} $(use_with caps capng)"
-
- ## auth stuff
- myconf="${myconf} $(use_with policykit polkit)"
- myconf="${myconf} $(use_with sasl)"
-
- # network bits
- myconf="${myconf} $(use_with macvtap)"
- myconf="${myconf} $(use_with pcap libpcap)"
- myconf="${myconf} $(use_with vepa virtualport)"
- myconf="${myconf} $(use_with firewalld)"
-
- ## other
- myconf="${myconf} $(use_enable nls)"
- myconf="${myconf} $(use_with python)"
-
- # user privilege bits fir qemu/kvm
- if use caps; then
- myconf="${myconf} --with-qemu-user=qemu"
- myconf="${myconf} --with-qemu-group=qemu"
- else
- myconf="${myconf} --with-qemu-user=root"
- myconf="${myconf} --with-qemu-group=root"
- fi
-
- # audit support
- myconf="${myconf} $(use_with audit)"
-
- ## stuff we don't yet support
- myconf="${myconf} --without-netcf"
-
- # we use udev over hal
- myconf="${myconf} --without-hal"
-
- # locking support
- myconf="${myconf} --without-sanlock"
-
- # systemd unit files
- use systemd && myconf="${myconf} --with-init-script=systemd"
-
- # this is a nasty trick to work around the problem in bug
- # #275073. The reason why we don't solve this properly is that
- # it'll require us to rebuild autotools (and we don't really want
- # to do that right now). The proper solution has been sent
- # upstream and should hopefully land in 0.7.7, in the mean time,
- # mime the same functionality with this.
- case ${CHOST} in
- *cygwin* | *mingw* )
- ;;
- *)
- ac_cv_prog_WINDRES=no
- ;;
- esac
-
- econf \
- ${myconf} \
- --disable-static \
- --docdir=/usr/share/doc/${PF} \
- --with-remote \
- --localstatedir=/var
-
- if [[ ${PV} = *9999* ]]; then
- # Restore gnulib's config.sub and config.guess
- # bug #377279
- (cd .gnulib && git reset --hard > /dev/null)
- fi
-}
-
-src_test() {
- # Explicitly allow parallel build of tests
- export VIR_TEST_DEBUG=1
- HOME="${T}" emake check || die "tests failed"
-}
-
-src_install() {
- emake install \
- DESTDIR="${D}" \
- HTML_DIR=/usr/share/doc/${PF}/html \
- DOCS_DIR=/usr/share/doc/${PF} \
- EXAMPLE_DIR=/usr/share/doc/${PF}/examples \
- SYSTEMD_UNIT_DIR="$(systemd_get_unitdir)" \
- || die "emake install failed"
-
- find "${D}" -name '*.la' -delete || die
-
- use libvirtd || return 0
- # From here, only libvirtd-related instructions, be warned!
-
- newinitd "${S}/libvirtd.init" libvirtd || die
- newconfd "${FILESDIR}/libvirtd.confd-r4" libvirtd || die
-
- keepdir /var/lib/libvirt/images
-
- use python && python_optimize
-}
-
-pkg_preinst() {
- # we only ever want to generate this once
- if [[ -e "${ROOT}"/etc/libvirt/qemu/networks/default.xml ]]; then
- rm -rf "${D}"/etc/libvirt/qemu/networks/default.xml
- fi
-
- # We really don't want to use or support old PolicyKit cause it
- # screws with the new polkit integration
- if has_version sys-auth/policykit; then
- rm -rf "${D}"/usr/share/PolicyKit/policy/org.libvirt.unix.policy
- fi
-
- # Only sysctl files ending in .conf work
- mv "${D}"/usr/lib/sysctl.d/libvirtd.conf "${D}"/etc/sysctl.d/libvirtd.conf
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/etc/libvirt/qemu/networks/default.xml ]]; then
- touch "${ROOT}"/etc/libvirt/qemu/networks/default.xml
- fi
-
- # support for dropped privileges
- if use qemu; then
- fperms 0750 "${EROOT}/var/lib/libvirt/qemu"
- fperms 0750 "${EROOT}/var/cache/libvirt/qemu"
- fi
-
- if use caps && use qemu; then
- fowners -R qemu:qemu "${EROOT}/var/lib/libvirt/qemu"
- fowners -R qemu:qemu "${EROOT}/var/cache/libvirt/qemu"
- elif use qemu; then
- fowners -R root:root "${EROOT}/var/lib/libvirt/qemu"
- fowners -R root:root "${EROOT}/var/cache/libvirt/qemu"
- fi
-
- if ! use policykit; then
- elog "To allow normal users to connect to libvirtd you must change the"
- elog "unix sock group and/or perms in /etc/libvirt/libvirtd.conf"
- fi
-
- use libvirtd || return 0
- # From here, only libvirtd-related instructions, be warned!
-
- elog
- elog "For the basic networking support (bridged and routed networks)"
- elog "you don't need any extra software. For more complex network modes"
- elog "including but not limited to NATed network, you can enable the"
- elog "'virt-network' USE flag."
- elog
- if has_version net-dns/dnsmasq; then
- ewarn "If you have a DNS server setup on your machine, you will have"
- ewarn "to configure /etc/dnsmasq.conf to enable the following settings: "
- ewarn " bind-interfaces"
- ewarn " interface or except-interface"
- ewarn
- ewarn "Otherwise you might have issues with your existing DNS server."
- fi
-
- if use caps && use qemu; then
- elog "libvirt will now start qemu/kvm VMs with non-root privileges."
- elog "Ensure any resources your VMs use are accessible by qemu:qemu"
- fi
-}