summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-19 17:51:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-19 17:51:49 +0000
commitd2c1f8d33cf0f6f1c67649b9e8d1cf3b3c55058d (patch)
tree123e58d960d6012bbbf6f2599633bd795c21f0d9 /app-emulation
parentVersion bump. Fixes bug #381399 and #381403. Thanks to Michał Górny for the... (diff)
downloadgentoo-2-d2c1f8d33cf0f6f1c67649b9e8d1cf3b3c55058d.tar.gz
gentoo-2-d2c1f8d33cf0f6f1c67649b9e8d1cf3b3c55058d.tar.bz2
gentoo-2-d2c1f8d33cf0f6f1c67649b9e8d1cf3b3c55058d.zip
Revision bump to fix two issues with the init script reported by Alexander Y. Fomichev (bug #387675 and #387679).
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/lxc/ChangeLog9
-rw-r--r--app-emulation/lxc/files/lxc.initd10
-rw-r--r--app-emulation/lxc/lxc-0.7.5-r3.ebuild (renamed from app-emulation/lxc/lxc-0.7.5-r2.ebuild)2
3 files changed, 16 insertions, 5 deletions
diff --git a/app-emulation/lxc/ChangeLog b/app-emulation/lxc/ChangeLog
index 992a2ecc8361..01e666fe8b5e 100644
--- a/app-emulation/lxc/ChangeLog
+++ b/app-emulation/lxc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/lxc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.28 2011/09/28 21:47:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.29 2011/10/19 17:51:49 flameeyes Exp $
+
+*lxc-0.7.5-r3 (19 Oct 2011)
+
+ 19 Oct 2011; Diego E. Pettenò <flameeyes@gentoo.org> -lxc-0.7.5-r2.ebuild,
+ +lxc-0.7.5-r3.ebuild, files/lxc.initd:
+ Revision bump to fix two issues with the init script reported by Alexander Y.
+ Fomichev (bug #387675 and #387679).
*lxc-0.7.5-r2 (28 Sep 2011)
diff --git a/app-emulation/lxc/files/lxc.initd b/app-emulation/lxc/files/lxc.initd
index 7275826025a1..fd70c72b3879 100644
--- a/app-emulation/lxc/files/lxc.initd
+++ b/app-emulation/lxc/files/lxc.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/files/lxc.initd,v 1.8 2011/09/28 21:47:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/files/lxc.initd,v 1.9 2011/10/19 17:51:48 flameeyes Exp $
CONTAINER=${SVCNAME#*.}
@@ -113,15 +113,19 @@ stop() {
init_pid=$(lxc-info -n ${CONTAINER} --pid | cut -d: -f 2)
+ if [ "${init_pid}" = "-1" ]; then
+ ewarn "${CONTAINER} doesn't seem to be running."
+ return 0
+ fi
+
ebegin "Shutting down system in ${CONTAINER}"
kill -INT ${init_pid}
eend $?
TIMEOUT=${TIMEOUT:-30}
i=0
- while [ -n "${missingprocs}" -a $i -lt ${TIMEOUT} ]; do
+ while [ -n "$(pgrep -P ${init_pid})" -a $i -lt ${TIMEOUT} ]; do
sleep 1
- missingprocs=$(pgrep -P ${init_pid})
i=$(expr $i + 1)
done
diff --git a/app-emulation/lxc/lxc-0.7.5-r2.ebuild b/app-emulation/lxc/lxc-0.7.5-r3.ebuild
index 991e418a521f..4b0e7913a9f8 100644
--- a/app-emulation/lxc/lxc-0.7.5-r2.ebuild
+++ b/app-emulation/lxc/lxc-0.7.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.7.5-r2.ebuild,v 1.1 2011/09/28 21:47:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.7.5-r3.ebuild,v 1.1 2011/10/19 17:51:49 flameeyes Exp $
EAPI="4"