summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-11 18:22:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-11 18:22:44 +0000
commiteeeb583a35fd3dae3ce810a13921400ea60a8a59 (patch)
tree94cc91a032ad54b17c5d7ca4d3c65d3d952e39bb /app-emulation
parentRemove virtual/alsa dependency. (diff)
downloadgentoo-2-eeeb583a35fd3dae3ce810a13921400ea60a8a59.tar.gz
gentoo-2-eeeb583a35fd3dae3ce810a13921400ea60a8a59.tar.bz2
gentoo-2-eeeb583a35fd3dae3ce810a13921400ea60a8a59.zip
Don't depend on virtual/alsa (those are drivers), depend properly on media-libs/alsa-lib.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/mol/ChangeLog7
-rw-r--r--app-emulation/mol/mol-0.9.71.1.ebuild44
-rw-r--r--app-emulation/mol/mol-0.9.72_pre1.ebuild44
-rw-r--r--app-emulation/mol/mol-0.9.72_pre2.ebuild44
4 files changed, 72 insertions, 67 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 309e409a0111..0c2ce1f99d7d 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.72 2007/02/11 15:11:34 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.73 2007/02/11 18:22:44 flameeyes Exp $
11 Feb 2007; Joseph Jezak <josejx@gentoo.org> mol-0.9.72_pre2.ebuild:
Marked ppc stable early for 2.6.19 stabilization.
+ 11 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> mol-0.9.71.1.ebuild,
+ mol-0.9.72_pre1.ebuild, mol-0.9.72_pre2.ebuild:
+ Don't depend on virtual/alsa (those are drivers), depend properly on
+ media-libs/alsa-lib.
+
25 Jan 2007; Marius Mauch <genone@gentoo.org> mol-0.9.71.1.ebuild,
mol-0.9.72_pre1.ebuild, mol-0.9.72_pre2.ebuild:
Replacing einfo with elog
diff --git a/app-emulation/mol/mol-0.9.71.1.ebuild b/app-emulation/mol/mol-0.9.71.1.ebuild
index ca1b58860e2f..366f5b7080cd 100644
--- a/app-emulation/mol/mol-0.9.71.1.ebuild
+++ b/app-emulation/mol/mol-0.9.71.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.71.1.ebuild,v 1.3 2007/01/25 22:15:36 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.71.1.ebuild,v 1.4 2007/02/11 18:22:44 flameeyes Exp $
inherit flag-o-matic eutils linux-mod
@@ -16,7 +16,7 @@ IUSE="vnc alsa oss fbcon X oldworld sheep debug dga usb pci"
MAKEOPTS="${MAKEOPTS} -j1"
RDEPEND="net-misc/dhcp
net-firewall/iptables
- alsa? ( virtual/alsa )
+ alsa? ( media-libs/alsa-lib )
vnc? ( net-misc/vnc )
X? ( || ( ( x11-libs/libXext
dga? ( x11-libs/libXxf86dga )
@@ -26,7 +26,7 @@ RDEPEND="net-misc/dhcp
)"
DEPEND="${RDEPEND}
X? ( || ( ( x11-libs/libXt
- x11-proto/xextproto
+ x11-proto/xextproto
dga? ( x11-proto/xf86dgaproto )
)
virtual/x11
@@ -63,16 +63,16 @@ src_compile() {
sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
sed -i "s:CONFIG_TAP=y:# CONFIG_TAP is not set:" .config-ppc
sed -i "s:CONFIG_TUN=y:# CONFIG_TUN is not set:" .config-ppc
- use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config-ppc
- use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config-ppc
- use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config-ppc
+ use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config-ppc
+ use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config-ppc
+ use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config-ppc
use oldworld || sed -i "s:CONFIG_OLDWORLD=y:# CONFIG_OLDWORLD is not set:" .config-ppc
- use sheep || sed -i "s:CONFIG_SHEEP=y:# CONFIG_SHEEP is not set:" .config-ppc
- use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config-ppc
- use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config-ppc
- use vnc || sed -i "s:CONFIG_VNC=y:# CONFIG_VNC is not set:" .config-ppc
- use dga || sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
- use usb || sed -i "s:CONFIG_USBDEV=y:# CONFIG_USBDEV is not set:" .config-ppc
+ use sheep || sed -i "s:CONFIG_SHEEP=y:# CONFIG_SHEEP is not set:" .config-ppc
+ use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config-ppc
+ use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config-ppc
+ use vnc || sed -i "s:CONFIG_VNC=y:# CONFIG_VNC is not set:" .config-ppc
+ use dga || sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
+ use usb || sed -i "s:CONFIG_USBDEV=y:# CONFIG_USBDEV is not set:" .config-ppc
use pci || sed -i "s:CONFIG_PCIPROXY=y:# CONFIG_PCIPROXY is not set:" .config-ppc
einfo "The configuration has been altered according to your USE-flags."
@@ -104,8 +104,8 @@ pkg_postinst() {
echo
elog "Mac-on-Linux is now installed. To run, use the command startmol."
elog "You might want to configure video modes first with molvconfig."
- elog "Other configuration is in /etc/molrc. For more info see:"
- elog " http://www.maconlinux.org"
+ elog "Other configuration is in /etc/molrc. For more info see:"
+ elog " http://www.maconlinux.org"
elog "Also try man molrc, man molvconfig, man startmol"
echo
ewarn "For networking and sound you might install the drivers in the"
@@ -114,15 +114,15 @@ pkg_postinst() {
ewarn "If errors with networking occur, make sure you have the following"
ewarn "kernel functions enabled:"
ewarn "For connecting to Linux:"
- ewarn " Universal TUN/TAP device driver support (CONFIG_TUN)"
+ ewarn " Universal TUN/TAP device driver support (CONFIG_TUN)"
ewarn "For the dhcp server:"
- ewarn " Packet Socket (CONFIG_PACKET)"
+ ewarn " Packet Socket (CONFIG_PACKET)"
ewarn "For NAT:"
- ewarn " Network packet filtering (CONFIG_NETFILTER)"
- ewarn " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
- ewarn " IP tables support (CONFIG_IP_NF_IPTABLES)"
- ewarn " Packet filtering (CONFIG_IP_NF_FILTER)"
- ewarn " Full NAT (CONFIG_IP_NF_NAT)"
- ewarn " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ ewarn " Network packet filtering (CONFIG_NETFILTER)"
+ ewarn " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ ewarn " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ ewarn " Packet filtering (CONFIG_IP_NF_FILTER)"
+ ewarn " Full NAT (CONFIG_IP_NF_NAT)"
+ ewarn " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
echo
}
diff --git a/app-emulation/mol/mol-0.9.72_pre1.ebuild b/app-emulation/mol/mol-0.9.72_pre1.ebuild
index e2b52937d3a3..0d7748ad5e5f 100644
--- a/app-emulation/mol/mol-0.9.72_pre1.ebuild
+++ b/app-emulation/mol/mol-0.9.72_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.72_pre1.ebuild,v 1.4 2007/01/25 22:15:36 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.72_pre1.ebuild,v 1.5 2007/02/11 18:22:44 flameeyes Exp $
inherit flag-o-matic eutils linux-mod toolchain-funcs
@@ -16,7 +16,7 @@ IUSE="vnc alsa oss fbcon X oldworld sheep debug dga usb pci"
MAKEOPTS="${MAKEOPTS} -j1"
RDEPEND="net-misc/dhcp
net-firewall/iptables
- alsa? ( virtual/alsa )
+ alsa? ( media-libs/alsa-lib )
vnc? ( net-misc/vnc )
X? ( || ( ( x11-libs/libXext
dga? ( x11-libs/libXxf86dga )
@@ -26,7 +26,7 @@ RDEPEND="net-misc/dhcp
)"
DEPEND="${RDEPEND}
X? ( || ( ( x11-libs/libXt
- x11-proto/xextproto
+ x11-proto/xextproto
dga? ( x11-proto/xf86dgaproto )
)
virtual/x11
@@ -64,16 +64,16 @@ src_compile() {
sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
sed -i "s:CONFIG_TAP=y:# CONFIG_TAP is not set:" .config-ppc
sed -i "s:CONFIG_TUN=y:# CONFIG_TUN is not set:" .config-ppc
- use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config-ppc
- use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config-ppc
- use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config-ppc
+ use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config-ppc
+ use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config-ppc
+ use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config-ppc
use oldworld || sed -i "s:CONFIG_OLDWORLD=y:# CONFIG_OLDWORLD is not set:" .config-ppc
- use sheep || sed -i "s:CONFIG_SHEEP=y:# CONFIG_SHEEP is not set:" .config-ppc
- use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config-ppc
- use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config-ppc
- use vnc || sed -i "s:CONFIG_VNC=y:# CONFIG_VNC is not set:" .config-ppc
- use dga || sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
- use usb || sed -i "s:CONFIG_USBDEV=y:# CONFIG_USBDEV is not set:" .config-ppc
+ use sheep || sed -i "s:CONFIG_SHEEP=y:# CONFIG_SHEEP is not set:" .config-ppc
+ use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config-ppc
+ use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config-ppc
+ use vnc || sed -i "s:CONFIG_VNC=y:# CONFIG_VNC is not set:" .config-ppc
+ use dga || sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
+ use usb || sed -i "s:CONFIG_USBDEV=y:# CONFIG_USBDEV is not set:" .config-ppc
use pci || sed -i "s:CONFIG_PCIPROXY=y:# CONFIG_PCIPROXY is not set:" .config-ppc
einfo "The configuration has been altered according to your USE-flags."
@@ -105,8 +105,8 @@ pkg_postinst() {
echo
elog "Mac-on-Linux is now installed. To run, use the command startmol."
elog "You might want to configure video modes first with molvconfig."
- elog "Other configuration is in /etc/molrc. For more info see:"
- elog " http://www.maconlinux.org"
+ elog "Other configuration is in /etc/molrc. For more info see:"
+ elog " http://www.maconlinux.org"
elog "Also try man molrc, man molvconfig, man startmol"
echo
ewarn "For networking and sound you might install the drivers in the"
@@ -115,15 +115,15 @@ pkg_postinst() {
ewarn "If errors with networking occur, make sure you have the following"
ewarn "kernel functions enabled:"
ewarn "For connecting to Linux:"
- ewarn " Universal TUN/TAP device driver support (CONFIG_TUN)"
+ ewarn " Universal TUN/TAP device driver support (CONFIG_TUN)"
ewarn "For the dhcp server:"
- ewarn " Packet Socket (CONFIG_PACKET)"
+ ewarn " Packet Socket (CONFIG_PACKET)"
ewarn "For NAT:"
- ewarn " Network packet filtering (CONFIG_NETFILTER)"
- ewarn " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
- ewarn " IP tables support (CONFIG_IP_NF_IPTABLES)"
- ewarn " Packet filtering (CONFIG_IP_NF_FILTER)"
- ewarn " Full NAT (CONFIG_IP_NF_NAT)"
- ewarn " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ ewarn " Network packet filtering (CONFIG_NETFILTER)"
+ ewarn " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ ewarn " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ ewarn " Packet filtering (CONFIG_IP_NF_FILTER)"
+ ewarn " Full NAT (CONFIG_IP_NF_NAT)"
+ ewarn " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
echo
}
diff --git a/app-emulation/mol/mol-0.9.72_pre2.ebuild b/app-emulation/mol/mol-0.9.72_pre2.ebuild
index aadb6aecdc17..f62d7c2c1e6d 100644
--- a/app-emulation/mol/mol-0.9.72_pre2.ebuild
+++ b/app-emulation/mol/mol-0.9.72_pre2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.72_pre2.ebuild,v 1.4 2007/02/11 15:11:34 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.72_pre2.ebuild,v 1.5 2007/02/11 18:22:44 flameeyes Exp $
inherit flag-o-matic eutils linux-mod
@@ -17,7 +17,7 @@ MAKEOPTS="${MAKEOPTS} -j1"
RDEPEND="net-misc/dhcp
sys-libs/zlib
net-firewall/iptables
- alsa? ( virtual/alsa )
+ alsa? ( media-libs/alsa-lib )
vnc? ( net-misc/vnc )
X? ( || ( ( x11-libs/libXext
dga? ( x11-libs/libXxf86dga )
@@ -27,7 +27,7 @@ RDEPEND="net-misc/dhcp
)"
DEPEND="${RDEPEND}
X? ( || ( ( x11-libs/libXt
- x11-proto/xextproto
+ x11-proto/xextproto
dga? ( x11-proto/xf86dgaproto )
)
virtual/x11
@@ -65,16 +65,16 @@ src_compile() {
sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
sed -i "s:CONFIG_TAP=y:# CONFIG_TAP is not set:" .config-ppc
- use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config-ppc
- use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config-ppc
- use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config-ppc
+ use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config-ppc
+ use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config-ppc
+ use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config-ppc
use oldworld || sed -i "s:CONFIG_OLDWORLD=y:# CONFIG_OLDWORLD is not set:" .config-ppc
- use sheep && sed -i "s:# CONFIG_SHEEP is not set:CONFIG_SHEEP=y:" .config-ppc
- use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config-ppc
- use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config-ppc
- use vnc || sed -i "s:CONFIG_VNC=y:# CONFIG_VNC is not set:" .config-ppc
- use dga || sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
- use usb || sed -i "s:CONFIG_USBDEV=y:# CONFIG_USBDEV is not set:" .config-ppc
+ use sheep && sed -i "s:# CONFIG_SHEEP is not set:CONFIG_SHEEP=y:" .config-ppc
+ use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config-ppc
+ use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config-ppc
+ use vnc || sed -i "s:CONFIG_VNC=y:# CONFIG_VNC is not set:" .config-ppc
+ use dga || sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
+ use usb || sed -i "s:CONFIG_USBDEV=y:# CONFIG_USBDEV is not set:" .config-ppc
use pci || sed -i "s:CONFIG_PCIPROXY=y:# CONFIG_PCIPROXY is not set:" .config-ppc
einfo "The configuration has been altered according to your USE-flags."
@@ -111,8 +111,8 @@ pkg_postinst() {
if use fbcon; then
elog "You might want to configure video modes first with molvconfig."
fi
- elog "Other configuration is in /etc/molrc. For more info see:"
- elog " http://www.maconlinux.org"
+ elog "Other configuration is in /etc/molrc. For more info see:"
+ elog " http://www.maconlinux.org"
elog "Also try man molrc, man molvconfig, man startmol"
echo
ewarn "For networking and sound you might install the drivers in the"
@@ -121,15 +121,15 @@ pkg_postinst() {
ewarn "If errors with networking occur, make sure you have the following"
ewarn "kernel functions enabled:"
ewarn "For connecting to Linux:"
- ewarn " Universal TUN/TAP device driver support (CONFIG_TUN)"
+ ewarn " Universal TUN/TAP device driver support (CONFIG_TUN)"
ewarn "For the dhcp server:"
- ewarn " Packet Socket (CONFIG_PACKET)"
+ ewarn " Packet Socket (CONFIG_PACKET)"
ewarn "For NAT:"
- ewarn " Network packet filtering (CONFIG_NETFILTER)"
- ewarn " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
- ewarn " IP tables support (CONFIG_IP_NF_IPTABLES)"
- ewarn " Packet filtering (CONFIG_IP_NF_FILTER)"
- ewarn " Full NAT (CONFIG_IP_NF_NAT)"
- ewarn " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ ewarn " Network packet filtering (CONFIG_NETFILTER)"
+ ewarn " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ ewarn " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ ewarn " Packet filtering (CONFIG_IP_NF_FILTER)"
+ ewarn " Full NAT (CONFIG_IP_NF_NAT)"
+ ewarn " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
echo
}