summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2007-09-20 17:16:01 +0000
committerMike Auty <ikelos@gentoo.org>2007-09-20 17:16:01 +0000
commitff9766fd435cb3e0a16283823db6fa3bc75da611 (patch)
tree2ec96ba801607fbb3ca0fd7a9a68747acf6740c1 /app-emulation
parentppc stable, bug #186716 (diff)
downloadgentoo-2-ff9766fd435cb3e0a16283823db6fa3bc75da611.tar.gz
gentoo-2-ff9766fd435cb3e0a16283823db6fa3bc75da611.tar.bz2
gentoo-2-ff9766fd435cb3e0a16283823db6fa3bc75da611.zip
Version bump for security issues (bug 193196).
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-server-console/ChangeLog8
-rw-r--r--app-emulation/vmware-server-console/files/digest-vmware-server-console-1.0.4.565289
-rw-r--r--app-emulation/vmware-server-console/vmware-server-console-1.0.4.56528.ebuild83
3 files changed, 99 insertions, 1 deletions
diff --git a/app-emulation/vmware-server-console/ChangeLog b/app-emulation/vmware-server-console/ChangeLog
index 95e58f0b898c..a88a9e22db02 100644
--- a/app-emulation/vmware-server-console/ChangeLog
+++ b/app-emulation/vmware-server-console/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vmware-server-console
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-server-console/ChangeLog,v 1.17 2007/07/22 09:38:14 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-server-console/ChangeLog,v 1.18 2007/09/20 17:16:01 ikelos Exp $
+
+*vmware-server-console-1.0.4.56528 (20 Sep 2007)
+
+ 20 Sep 2007; Mike Auty <ikelos@gentoo.org>
+ +vmware-server-console-1.0.4.56528.ebuild:
+ Version bump for security issues (bug 193196).
22 Jul 2007; David Shakaryan <omp@gentoo.org>
vmware-server-console-1.0.3.44356.ebuild:
diff --git a/app-emulation/vmware-server-console/files/digest-vmware-server-console-1.0.4.56528 b/app-emulation/vmware-server-console/files/digest-vmware-server-console-1.0.4.56528
new file mode 100644
index 000000000000..871ecb1f3b94
--- /dev/null
+++ b/app-emulation/vmware-server-console/files/digest-vmware-server-console-1.0.4.56528
@@ -0,0 +1,9 @@
+MD5 010d808baad4a87ba5931e1e8ad06351 VMware-server-linux-client-1.0.4-56528.zip 23337450
+RMD160 7183ba1d88c06bf9bbad74b01515f59598e64394 VMware-server-linux-client-1.0.4-56528.zip 23337450
+SHA256 259b19ea3b5d30d8d5700ca1ba2ff38e4b07ef82685b6dd711ca33f192ce8102 VMware-server-linux-client-1.0.4-56528.zip 23337450
+MD5 062f83a22822b6e4d4a176e3648c38d8 vmware-libcrypto.so.0.9.7l.tar.bz2 412159
+RMD160 89282ae9fc6e8921a47704bc9cd23cf70a6870e8 vmware-libcrypto.so.0.9.7l.tar.bz2 412159
+SHA256 fae52acf61415959cca763a715a2b61ec49f161a416d418d6a1faffce531db12 vmware-libcrypto.so.0.9.7l.tar.bz2 412159
+MD5 913acecb0f79113de958e6a70618be7f vmware-libssl.so.0.9.7l.tar.bz2 78244
+RMD160 195dd4808e60f81621e6ed12b843ded49c0fa747 vmware-libssl.so.0.9.7l.tar.bz2 78244
+SHA256 3e1e13196066dc5b77d3ef6b5df55a29156eba1f39661e40cd617b538220d089 vmware-libssl.so.0.9.7l.tar.bz2 78244
diff --git a/app-emulation/vmware-server-console/vmware-server-console-1.0.4.56528.ebuild b/app-emulation/vmware-server-console/vmware-server-console-1.0.4.56528.ebuild
new file mode 100644
index 000000000000..e9b719616acb
--- /dev/null
+++ b/app-emulation/vmware-server-console/vmware-server-console-1.0.4.56528.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-server-console/vmware-server-console-1.0.4.56528.ebuild,v 1.1 2007/09/20 17:16:01 ikelos Exp $
+
+# Unlike many other binary packages the user doesn't need to agree to a licence
+# to download VMWare. The agreeing to a licence is part of the configure step
+# which the user must run manually.
+
+inherit eutils versionator vmware
+
+MY_PN=${PN/vm/VM}
+MY_PV=$(replace_version_separator 3 '-')
+MY_P="${MY_PN}-${MY_PV}"
+FN="VMware-server-linux-client-${MY_PV}"
+S="${WORKDIR}/${PN}-distrib"
+
+DESCRIPTION="VMware Remote Console for Linux"
+HOMEPAGE="http://www.vmware.com/"
+SRC_URI="http://download3.vmware.com/software/vmserver/${FN}.zip
+ http://dev.gentoo.org/~wolf31o2/sources/dump/vmware-libssl.so.0.9.7l.tar.bz2
+ mirror://gentoo/vmware-libssl.so.0.9.7l.tar.bz2
+ http://dev.gentoo.org/~wolf31o2/sources/dump/vmware-libcrypto.so.0.9.7l.tar.bz2
+ mirror://gentoo/vmware-libcrypto.so.0.9.7l.tar.bz2"
+
+LICENSE="vmware"
+IUSE=""
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+
+DEPEND=">=sys-libs/glibc-2.3.5
+ virtual/os-headers
+ >=dev-lang/perl-5
+ >=sys-apps/portage-2.0.54
+ app-arch/unzip"
+
+# vmware-server-console should not use virtual/libc as this is a
+# precompiled binary package thats linked to glibc.
+RDEPEND=">=sys-libs/glibc-2.3.5
+ amd64? ( app-emulation/emul-linux-x86-gtklibs )
+ !amd64? ( x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXcursor
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXtst )
+ >=dev-lang/perl-5
+ !<sys-apps/dbus-0.62"
+
+etcdir="/etc/${PN}"
+ANY_ANY=""
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A}
+ unpack ./${MY_P}.tar.gz
+ cd ${S}
+ unpack vmware-libssl.so.0.9.7l.tar.bz2
+ unpack vmware-libcrypto.so.0.9.7l.tar.bz2
+}
+
+src_install() {
+ echo 'libdir = "'${VMWARE_INSTALL_DIR}'/lib"' > etc/config
+ vmware_src_install
+
+ make_desktop_entry ${PN} "VMWare Remote Console" ${PN}.png System
+
+ dodir /usr/bin
+ dosym ${VMWARE_INSTALL_DIR}/bin/${PN} /usr/bin/${PN}
+}
+
+pkg_config() {
+ einfo "Running ${ROOT}${dir}/bin/vmware-config-server-console.pl"
+ ${ROOT}${dir}/bin/vmware-config-server-console.pl
+}