summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2015-07-01 17:56:07 +0000
committerKristian Fiskerstrand <k_f@gentoo.org>2015-07-01 17:56:07 +0000
commit35736ca8f60f9009a9f3b22ffdef0229dc5bcf8e (patch)
treed0080adf66b0323799afac561130fab37b624b4e /app-eselect
parentRestrict to python 3.4 (diff)
downloadgentoo-2-35736ca8f60f9009a9f3b22ffdef0229dc5bcf8e.tar.gz
gentoo-2-35736ca8f60f9009a9f3b22ffdef0229dc5bcf8e.tar.bz2
gentoo-2-35736ca8f60f9009a9f3b22ffdef0229dc5bcf8e.zip
If pinentry-gnome3 exist, prefer this over the qt and gtk versions. The version will only exist if gnome-keyword is specified for pinentry build.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x250B7AFED6379D85!)
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-pinentry/ChangeLog9
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.6.ebuild23
-rw-r--r--app-eselect/eselect-pinentry/files/pinentry.eselect-0.613
3 files changed, 44 insertions, 1 deletions
diff --git a/app-eselect/eselect-pinentry/ChangeLog b/app-eselect/eselect-pinentry/ChangeLog
index 738652ac36ce..fe483196a189 100644
--- a/app-eselect/eselect-pinentry/ChangeLog
+++ b/app-eselect/eselect-pinentry/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-eselect/eselect-pinentry
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-eselect/eselect-pinentry/ChangeLog,v 1.3 2015/06/20 09:12:40 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-eselect/eselect-pinentry/ChangeLog,v 1.4 2015/07/01 17:56:07 k_f Exp $
+
+*eselect-pinentry-0.6 (01 Jul 2015)
+
+ 01 Jul 2015; Kristian Fiskerstrand <k_f@gentoo.org>
+ +eselect-pinentry-0.6.ebuild, +files/pinentry.eselect-0.6:
+ If pinentry-gnome3 exist, prefer this over the qt and gtk versions. The
+ version will only exist if gnome-keyword is specified for pinentry build.
20 Jun 2015; Alon Bar-Lev <alonbl@gentoo.org> -eselect-pinentry-0.3.ebuild,
-files/eselect-pinentry-0.3:
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.6.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.6.ebuild
new file mode 100644
index 000000000000..20fc84dafaf6
--- /dev/null
+++ b/app-eselect/eselect-pinentry/eselect-pinentry-0.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-eselect/eselect-pinentry/eselect-pinentry-0.6.ebuild,v 1.1 2015/07/01 17:56:07 k_f Exp $
+
+EAPI=5
+
+DESCRIPTION="Manage /usr/bin/pinentry symlink"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
+
+S=${FILESDIR}
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins pinentry.eselect-${PV} pinentry.eselect
+}
diff --git a/app-eselect/eselect-pinentry/files/pinentry.eselect-0.6 b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.6
new file mode 100644
index 000000000000..15e98a16d0dc
--- /dev/null
+++ b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.6
@@ -0,0 +1,13 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: pinentry.eselect-0.6,v 1.1 2015/07/01 17:56:07 k_f Exp $
+
+DESCRIPTION="Manage /usr/bin/pinentry implementation"
+MAINTAINER="ssuominen@gentoo.org"
+VERSION="0.5"
+
+SYMLINK_PATH=/usr/bin/pinentry
+SYMLINK_TARGETS=( pinentry-gnome3 pinentry-qt pinentry-gtk-2 pinentry-qt4 pinentry-curses )
+SYMLINK_DESCRIPTION='pinentry binary'
+
+inherit bin-symlink