summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-19 21:17:36 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-19 21:17:36 +0000
commitf8549ebc6be4cc22518e3290926c099339b62804 (patch)
tree31b2dc2529e1b3992632131bb7a9560f1a892275 /app-forensics/chkrootkit
parentVersion bump, security bug #155468. (diff)
downloadgentoo-2-f8549ebc6be4cc22518e3290926c099339b62804.tar.gz
gentoo-2-f8549ebc6be4cc22518e3290926c099339b62804.tar.bz2
gentoo-2-f8549ebc6be4cc22518e3290926c099339b62804.zip
Version bump, bug #154823
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'app-forensics/chkrootkit')
-rw-r--r--app-forensics/chkrootkit/ChangeLog11
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.47.ebuild56
-rw-r--r--app-forensics/chkrootkit/files/chkrootkit-0.47-add-missing-includes.diff10
-rw-r--r--app-forensics/chkrootkit/files/chkrootkit-0.47-makefile.diff71
-rw-r--r--app-forensics/chkrootkit/files/digest-chkrootkit-0.454
-rw-r--r--app-forensics/chkrootkit/files/digest-chkrootkit-0.46a4
-rw-r--r--app-forensics/chkrootkit/files/digest-chkrootkit-0.476
7 files changed, 159 insertions, 3 deletions
diff --git a/app-forensics/chkrootkit/ChangeLog b/app-forensics/chkrootkit/ChangeLog
index 87959d185801..a04f15ddc4f5 100644
--- a/app-forensics/chkrootkit/ChangeLog
+++ b/app-forensics/chkrootkit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-forensics/chkrootkit
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/ChangeLog,v 1.33 2005/10/28 17:22:27 ka0ttic Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/ChangeLog,v 1.34 2006/11/19 21:17:36 nyhm Exp $
+
+*chkrootkit-0.47 (19 Nov 2006)
+
+ 19 Nov 2006; Tristan Heaven <nyhm@gentoo.org>
+ +files/chkrootkit-0.47-add-missing-includes.diff,
+ +files/chkrootkit-0.47-makefile.diff, +chkrootkit-0.47.ebuild:
+ Version bump, bug #154823
*chkrootkit-0.46a (28 Oct 2005)
diff --git a/app-forensics/chkrootkit/chkrootkit-0.47.ebuild b/app-forensics/chkrootkit/chkrootkit-0.47.ebuild
new file mode 100644
index 000000000000..c84763a60800
--- /dev/null
+++ b/app-forensics/chkrootkit/chkrootkit-0.47.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/chkrootkit-0.47.ebuild,v 1.1 2006/11/19 21:17:36 nyhm Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a tool to locally check for signs of a rootkit"
+HOMEPAGE="http://www.chkrootkit.org/"
+SRC_URI="ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz
+ mirror://gentoo/${PN}-0.45-gentoo.diff.bz2"
+
+LICENSE="AMS"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # we can use the gentoo patch for 0.45 but it needs one change to apply
+ # cleanly -- certainly not enough to warrant using a separate 32k patch.
+ sed -e 's|\(xlogin\)|\^\1|' "${WORKDIR}"/${PN}-0.45-gentoo.diff > \
+ "${WORKDIR}"/${P}-gentoo.diff
+
+ epatch \
+ "${WORKDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-makefile.diff \
+ "${FILESDIR}"/${P}-add-missing-includes.diff
+
+ sed -i 's:${head} -:${head} -n :' chkrootkit || die "sed chkrootkit failed"
+ sed -i 's:/var/adm:/var/log:g' chklastlog.c || die "sed chklastlog.c failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) sense || die "emake sense failed"
+}
+
+src_install() {
+ dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc \
+ strings-static || die
+ dodoc ACKNOWLEDGMENTS README*
+
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/${PN}.cron ${PN} || die
+}
+
+pkg_postinst() {
+ echo
+ elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
+ elog
+ elog "Some applications, such as portsentry, will cause chkrootkit"
+ elog "to produce false positives. Read the chkrootkit FAQ at"
+ elog "http://www.chkrootkit.org/ for more information."
+ echo
+}
diff --git a/app-forensics/chkrootkit/files/chkrootkit-0.47-add-missing-includes.diff b/app-forensics/chkrootkit/files/chkrootkit-0.47-add-missing-includes.diff
new file mode 100644
index 000000000000..348ec0a84b1a
--- /dev/null
+++ b/app-forensics/chkrootkit/files/chkrootkit-0.47-add-missing-includes.diff
@@ -0,0 +1,10 @@
+--- chkwtmp.c
++++ chkwtmp.c
+@@ -21,6 +21,7 @@
+
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <string.h>
+ #include <utmp.h>
diff --git a/app-forensics/chkrootkit/files/chkrootkit-0.47-makefile.diff b/app-forensics/chkrootkit/files/chkrootkit-0.47-makefile.diff
new file mode 100644
index 000000000000..266fe1c186b0
--- /dev/null
+++ b/app-forensics/chkrootkit/files/chkrootkit-0.47-makefile.diff
@@ -0,0 +1,71 @@
+--- Makefile
++++ Makefile
+@@ -3,8 +3,8 @@
+ # (C) 1997-2006 Nelson Murilo, Pangeia Informatica, AMS Foundation and others.
+ #
+
+-CC = gcc
+-CFLAGS = -DHAVE_LASTLOG_H
++CC ?= gcc
++CFLAGS += -DHAVE_LASTLOG_H
+ STATIC = -static
+
+ ###
+@@ -29,48 +29,36 @@
+ #CFLAGS =
+
+
+-SRCS = chklastlog.c chkwtmp.c ifpromisc.c chkproc.c chkdirs.c check_wtmpx.c strings.c
++SRCS = chklastlog.c chkwtmp.c ifpromisc.c chkproc.c chkdirs.c strings.c
+
+-OBJS = chklastlog.o chkwtmp.o ifpromisc.o chkproc.o chkdirs.o check_wtmpx.o strings-static.o
++OBJS = chklastlog.o chkwtmp.o ifpromisc.o chkproc.o chkdirs.o strings-static.o
+
+ all:
+ @echo '*** stopping make sense ***'
+ @exec make sense
+
+-sense: chklastlog chkwtmp ifpromisc chkproc chkdirs check_wtmpx strings-static chkutmp
++sense: chklastlog chkwtmp ifpromisc chkproc chkdirs strings-static chkutmp
+
+ chklastlog: chklastlog.c
+- ${CC} ${CFLAGS} -o $@ chklastlog.c
+- @strip $@
++ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ chklastlog.c
+
+ chkwtmp: chkwtmp.c
+- ${CC} ${CFLAGS} -o $@ chkwtmp.c
+- @strip $@
++ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ chkwtmp.c
+
+ ifpromisc: ifpromisc.c
+ ${CC} ${CFLAGS} ${LDFLAGS} -D_FILE_OFFSET_BITS=64 -o $@ ifpromisc.c
+- @strip $@
+
+ chkproc: chkproc.c
+- ${CC} ${LDFLAGS} -o $@ chkproc.c
+- @strip $@
++ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ chkproc.c
+
+ chkdirs: chkdirs.c
+- ${CC} ${LDFLAGS} -o $@ chkdirs.c
+- @strip $@
+-
+-check_wtmpx: check_wtmpx.c
+- ${CC} ${LDFLAGS} -o $@ check_wtmpx.c
+- @strip $@
++ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ chkdirs.c
+
+ chkutmp: chkutmp.c
+- ${CC} ${LDFLAGS} -o $@ chkutmp.c
+- @strip $@
+-
++ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ chkutmp.c
+
+ strings-static: strings.c
+- ${CC} ${STATIC} ${LDFLAGS} -o $@ strings.c
+- @strip $@
++ ${CC} ${STATIC} ${CFLAGS} ${LDFLAGS} -o $@ strings.c
+
+ clean:
+ rm -f ${OBJS} core chklastlog chkwtmp ifpromisc chkproc chkdirs check_wtmpx strings-static chkutmp
diff --git a/app-forensics/chkrootkit/files/digest-chkrootkit-0.45 b/app-forensics/chkrootkit/files/digest-chkrootkit-0.45
index e7c39a8dc16c..8808b9a6f6b6 100644
--- a/app-forensics/chkrootkit/files/digest-chkrootkit-0.45
+++ b/app-forensics/chkrootkit/files/digest-chkrootkit-0.45
@@ -1,2 +1,4 @@
-MD5 57493e24ca81750a200d8bcb4049e858 chkrootkit-0.45.tar.gz 36359
MD5 ecac86c18a31fbf9897124e7c34def98 chkrootkit-0.45-gentoo.diff.bz2 3729
+RMD160 84c1ca6b0f791b0727a1e61d104b23b4b3a9eb68 chkrootkit-0.45-gentoo.diff.bz2 3729
+SHA256 ca26f4113c2e511f87179bc673faa198ab9b2e6d6de0134443ed301f0ebb1362 chkrootkit-0.45-gentoo.diff.bz2 3729
+MD5 57493e24ca81750a200d8bcb4049e858 chkrootkit-0.45.tar.gz 36359
diff --git a/app-forensics/chkrootkit/files/digest-chkrootkit-0.46a b/app-forensics/chkrootkit/files/digest-chkrootkit-0.46a
index 30230b725628..f3752791eb32 100644
--- a/app-forensics/chkrootkit/files/digest-chkrootkit-0.46a
+++ b/app-forensics/chkrootkit/files/digest-chkrootkit-0.46a
@@ -1,2 +1,6 @@
MD5 ecac86c18a31fbf9897124e7c34def98 chkrootkit-0.45-gentoo.diff.bz2 3729
+RMD160 84c1ca6b0f791b0727a1e61d104b23b4b3a9eb68 chkrootkit-0.45-gentoo.diff.bz2 3729
+SHA256 ca26f4113c2e511f87179bc673faa198ab9b2e6d6de0134443ed301f0ebb1362 chkrootkit-0.45-gentoo.diff.bz2 3729
MD5 b73fb9e365d2edcd031d65b16e965a18 chkrootkit-0.46a.tar.gz 37140
+RMD160 9016abfd7cd3d986aec86722c9a9b88dea7bf49b chkrootkit-0.46a.tar.gz 37140
+SHA256 ec23b4be57e08f6c28f646a447a8545f9c612fd4b296133ac9c3c3ac13e1d696 chkrootkit-0.46a.tar.gz 37140
diff --git a/app-forensics/chkrootkit/files/digest-chkrootkit-0.47 b/app-forensics/chkrootkit/files/digest-chkrootkit-0.47
new file mode 100644
index 000000000000..969b1d7ab554
--- /dev/null
+++ b/app-forensics/chkrootkit/files/digest-chkrootkit-0.47
@@ -0,0 +1,6 @@
+MD5 ecac86c18a31fbf9897124e7c34def98 chkrootkit-0.45-gentoo.diff.bz2 3729
+RMD160 84c1ca6b0f791b0727a1e61d104b23b4b3a9eb68 chkrootkit-0.45-gentoo.diff.bz2 3729
+SHA256 ca26f4113c2e511f87179bc673faa198ab9b2e6d6de0134443ed301f0ebb1362 chkrootkit-0.45-gentoo.diff.bz2 3729
+MD5 4c6455d202cef35395a673386e4bf01a chkrootkit-0.47.tar.gz 37791
+RMD160 291746f60d0cc3bcf0e63387f3d7ff16a4215d17 chkrootkit-0.47.tar.gz 37791
+SHA256 5a5aeb597769cc2843648858b95fc7abd3485ba7edd1800d69e0125220c6669f chkrootkit-0.47.tar.gz 37791