summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-03-24 01:33:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-03-24 01:33:49 +0000
commit29513815e69e6238e47e4bc754ab7b2c4cca1fc3 (patch)
tree3c17d54ea3af77eef58aef1070301bf2531ccc13 /app-forensics
parentVersion bump (diff)
downloadgentoo-2-29513815e69e6238e47e4bc754ab7b2c4cca1fc3.tar.gz
gentoo-2-29513815e69e6238e47e4bc754ab7b2c4cca1fc3.tar.bz2
gentoo-2-29513815e69e6238e47e4bc754ab7b2c4cca1fc3.zip
Version bump. Remove old ebuilds. Security bug #359769
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/openscap/ChangeLog9
-rw-r--r--app-forensics/openscap/files/openscap-0.7.1-sql-fix.patch26
-rw-r--r--app-forensics/openscap/openscap-0.6.4.ebuild65
-rw-r--r--app-forensics/openscap/openscap-0.7.1.ebuild (renamed from app-forensics/openscap/openscap-0.6.7.ebuild)8
4 files changed, 40 insertions, 68 deletions
diff --git a/app-forensics/openscap/ChangeLog b/app-forensics/openscap/ChangeLog
index 9aa2209e6b12..519e50ef7d60 100644
--- a/app-forensics/openscap/ChangeLog
+++ b/app-forensics/openscap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-forensics/openscap
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.2 2011/01/30 22:35:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.3 2011/03/24 01:33:49 hwoarang Exp $
+
+*openscap-0.7.1 (24 Mar 2011)
+
+ 24 Mar 2011; Markos Chandras <hwoarang@gentoo.org> -openscap-0.6.4.ebuild,
+ -openscap-0.6.7.ebuild, +openscap-0.7.1.ebuild,
+ +files/openscap-0.7.1-sql-fix.patch:
+ Version bump. Remove old ebuilds. Security bug #359769
*openscap-0.6.7 (30 Jan 2011)
diff --git a/app-forensics/openscap/files/openscap-0.7.1-sql-fix.patch b/app-forensics/openscap/files/openscap-0.7.1-sql-fix.patch
new file mode 100644
index 000000000000..abd247035b0c
--- /dev/null
+++ b/app-forensics/openscap/files/openscap-0.7.1-sql-fix.patch
@@ -0,0 +1,26 @@
+X-Git-Url: http://git.fedorahosted.org/git/?p=openscap.git;a=blobdiff_plain;f=src%2FOVAL%2Fprobes%2Findependent%2Fsql.c;h=ad7988c60ec344fa721e28b8aca59b9690cabbac;hp=0eb18a9a7cd0c03d3923c2b724eea23791e4ff25;hb=9eeceaecde0718cf28ffc8a672923f4f16b63c6a;hpb=dfad8e4db009182a3a2c3c2ba79563feefb09ada
+
+diff --git a/src/OVAL/probes/independent/sql.c b/src/OVAL/probes/independent/sql.c
+index 0eb18a9..ad7988c 100644
+--- a/src/OVAL/probes/independent/sql.c
++++ b/src/OVAL/probes/independent/sql.c
+@@ -242,8 +242,8 @@ __fail:
+ return (-1);
+ }
+
+-static SEXP_t *dbSQL_eval(const char *engine, const char *version,
+- const char *conn, const char *sql, SEXP_t *probe_out)
++static int dbSQL_eval(const char *engine, const char *version,
++ const char *conn, const char *sql, SEXP_t *probe_out)
+ {
+ int err = -1;
+ dbURIInfo_t uriInfo = { .host = NULL,
+@@ -350,7 +350,7 @@ __exit:
+ return (err);
+ }
+
+-int probe_main(SEXP_t *probe_in, SEXP_t *probe_out, void *arg)
++int probe_main(SEXP_t *probe_in, SEXP_t *probe_out, void *arg, SEXP_t *filters)
+ {
+ char *engine, *version, *conn, *sqlexp;
+ int err;
diff --git a/app-forensics/openscap/openscap-0.6.4.ebuild b/app-forensics/openscap/openscap-0.6.4.ebuild
deleted file mode 100644
index b32f7cd8c5ee..000000000000
--- a/app-forensics/openscap/openscap-0.6.4.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-0.6.4.ebuild,v 1.1 2010/11/05 23:49:24 hwoarang Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="2"
-
-inherit multilib python bash-completion
-
-DESCRIPTION="Framework which enables integration with the Security Content Automation Protocol (SCAP)"
-HOMEPAGE="http://www.open-scap.org/"
-SRC_URI="http://www.open-scap.org/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion doc nss perl python"
-
-RDEPEND="!nss? ( dev-libs/libgcrypt )
- nss? ( dev-libs/nss )
- dev-libs/libpcre
- dev-libs/libxml2
- net-misc/curl"
-DEPEND="${RDEPEND}
- perl? ( dev-lang/swig )
- python? ( dev-lang/swig )"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_configure() {
- local myconf
- if use python || use perl ; then
- myconf+=" --enable-bindings"
- else
- myconf+=" --disable-bindings"
- fi
- if use nss ; then
- myconf+=" --with-crypto=nss3"
- else
- myconf+=" --with-crypto=gcrypt"
- fi
- econf ${myconf}
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- #--enable-bindings enable all bindings, clean unwanted bindings
- if use python && ! use perl ; then
- rm -rf "${D}"/usr/$(get_libdir)/perl5 || die
- fi
- if ! use python && use perl ; then
- rm -rf "${D}"/$(python_get_sitedir) || die
- fi
- if use doc ; then
- dohtml -r docs/html/* || die
- dodoc docs/examples/* || die
- fi
- if ! use bash-completion ; then
- rm -rf "${D}"/etc/bash_completion.d || die
- fi
-}
diff --git a/app-forensics/openscap/openscap-0.6.7.ebuild b/app-forensics/openscap/openscap-0.7.1.ebuild
index 3b9ad3dbc16a..0ce238b2150e 100644
--- a/app-forensics/openscap/openscap-0.6.7.ebuild
+++ b/app-forensics/openscap/openscap-0.7.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-0.6.7.ebuild,v 1.1 2011/01/30 22:35:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-0.7.1.ebuild,v 1.1 2011/03/24 01:33:49 hwoarang Exp $
EAPI=3
PYTHON_DEPEND="2"
-inherit multilib python bash-completion
+inherit eutils multilib python bash-completion
DESCRIPTION="Framework which enables integration with the Security Content Automation Protocol (SCAP)"
HOMEPAGE="http://www.open-scap.org/"
@@ -32,6 +32,10 @@ pkg_setup() {
python_pkg_setup
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sql-fix.patch
+}
+
src_configure() {
local myconf
if use python || use perl ; then