summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2014-12-25 12:58:15 +0000
committerHanno Böck <hanno@gentoo.org>2014-12-25 12:58:15 +0000
commit4c665117e8360b1be55d36338ae84e749f37769b (patch)
treeb7e6531cb882149cf7db78fe5baf16b666e048e7 /app-forensics
parentAdd missing PYTHON_USEDEP. (diff)
downloadgentoo-2-4c665117e8360b1be55d36338ae84e749f37769b.tar.gz
gentoo-2-4c665117e8360b1be55d36338ae84e749f37769b.tar.bz2
gentoo-2-4c665117e8360b1be55d36338ae84e749f37769b.zip
afl bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BBB51E42)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afl/ChangeLog7
-rw-r--r--app-forensics/afl/afl-1.03b.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/app-forensics/afl/ChangeLog b/app-forensics/afl/ChangeLog
index 67fc3f64d40e..96156906bc85 100644
--- a/app-forensics/afl/ChangeLog
+++ b/app-forensics/afl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afl/ChangeLog,v 1.4 2014/12/10 00:36:21 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afl/ChangeLog,v 1.5 2014/12/25 12:58:15 hanno Exp $
+
+*afl-1.03b (25 Dec 2014)
+
+ 25 Dec 2014; <hanno@gentoo.org> +afl-1.03b.ebuild:
+ Bump.
*afl-0.89b (10 Dec 2014)
diff --git a/app-forensics/afl/afl-1.03b.ebuild b/app-forensics/afl/afl-1.03b.ebuild
new file mode 100644
index 000000000000..de6deb75a712
--- /dev/null
+++ b/app-forensics/afl/afl-1.03b.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afl/afl-1.03b.ebuild,v 1.1 2014/12/25 12:58:15 hanno Exp $
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+DESCRIPTION="american fuzzy lop - compile-time instrumentation fuzzer"
+HOMEPAGE="http://lcamtuf.coredump.cx/afl/"
+SRC_URI="http://lcamtuf.coredump.cx/afl/releases//${P}.tgz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND="sys-devel/gcc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ PREFIX="/usr" \
+ HELPER_PATH="/usr/$(get_libdir)/afl" \
+ DOC_PATH="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="/usr" \
+ HELPER_PATH="/usr/$(get_libdir)/afl" \
+ DOC_PATH="/usr/share/doc/${PF}" \
+ install
+}