summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-06-09 16:14:42 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-06-09 16:14:42 +0000
commitf8f57db487806d0aee8d94b52f15f6671158dd79 (patch)
treef8d785b74ffb6e60578f777f2c45dd1c1ee78a38 /app-forensics
parentfixed not-committed src_install (diff)
downloadgentoo-2-f8f57db487806d0aee8d94b52f15f6671158dd79.tar.gz
gentoo-2-f8f57db487806d0aee8d94b52f15f6671158dd79.tar.bz2
gentoo-2-f8f57db487806d0aee8d94b52f15f6671158dd79.zip
Fixed configure issue, bug #323187. Added audit USE flag.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/aide/ChangeLog8
-rw-r--r--app-forensics/aide/aide-0.14-r1.ebuild133
-rw-r--r--app-forensics/aide/files/aide-0.14-configure.patch38
-rw-r--r--app-forensics/aide/metadata.xml3
4 files changed, 181 insertions, 1 deletions
diff --git a/app-forensics/aide/ChangeLog b/app-forensics/aide/ChangeLog
index 1c0010ce5a62..0ebddf39a8fc 100644
--- a/app-forensics/aide/ChangeLog
+++ b/app-forensics/aide/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/aide
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/ChangeLog,v 1.47 2010/05/27 17:23:55 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/ChangeLog,v 1.48 2010/06/09 16:14:41 matsuu Exp $
+
+*aide-0.14-r1 (09 Jun 2010)
+
+ 09 Jun 2010; MATSUU Takuto <matsuu@gentoo.org> +aide-0.14-r1.ebuild,
+ +files/aide-0.14-configure.patch:
+ Fixed configure issue, bug #323187. Added audit USE flag.
*aide-0.14 (27 May 2010)
diff --git a/app-forensics/aide/aide-0.14-r1.ebuild b/app-forensics/aide/aide-0.14-r1.ebuild
new file mode 100644
index 000000000000..5fbf836feec7
--- /dev/null
+++ b/app-forensics/aide/aide-0.14-r1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.14-r1.ebuild,v 1.1 2010/06/09 16:14:41 matsuu Exp $
+
+EAPI="3"
+
+inherit autotools confutils eutils
+
+DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a replacement for Tripwire"
+HOMEPAGE="http://aide.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aide/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="acl audit curl mhash nls postgres selinux static xattr zlib"
+#IUSE="acl audit curl mhash nls postgres prelink selinux static xattr zlib"
+
+# libsandbox: Can't dlopen libc: (null)
+#RESTRICT="test"
+
+DEPEND="acl? ( virtual/acl )
+ audit? ( sys-process/audit )
+ curl? ( net-misc/curl )
+ mhash? ( >=app-crypt/mhash-0.9.2 )
+ !mhash? ( dev-libs/libgcrypt )
+ nls? ( virtual/libintl )
+ postgres? ( virtual/postgresql-base )
+ selinux? ( sys-libs/libselinux )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )"
+# prelink? ( sys-devel/prelink )
+
+RDEPEND="!static? ( ${DEPEND} )"
+
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/bison
+ sys-devel/flex"
+
+pkg_config() {
+ confutils_use_conflict mhash postgres
+ confutils_use_conflict curl static
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ # fix libgcrypt issue, bug #266175
+ epatch "${FILESDIR}/${PN}-0.13.1-libgrypt_init.patch"
+
+ # fix as-need issue, bug #271326
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ # fix zlib issue, bug #316665
+ epatch "${FILESDIR}/${PN}-0.13.1-zlib.patch"
+
+ # fix configure issue, bug #323187
+ epatch "${FILESDIR}/${P}-configure.patch"
+
+ if ! use selinux ; then
+ sed -i -e 's/\+selinux//' doc/aide.conf.in || die
+ fi
+
+ if ! use xattr ; then
+ sed -i -e 's/\+xattrs//' doc/aide.conf.in || die
+ fi
+
+ if ! use acl ; then
+ sed -i -e 's/\+acl//' doc/aide.conf.in || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with acl posix-acl) \
+ $(use_with audit) \
+ $(use_with curl) \
+ $(use_with !mhash gcrypt) \
+ $(use_with mhash mhash) \
+ $(use_with nls locale) \
+ $(use_with postgres psql) \
+ $(use_with selinux) \
+ $(use_enable static) \
+ $(use_with xattr) \
+ $(use_with zlib) \
+ --sysconfdir="${EPREFIX}/etc/aide" || die "econf failed"
+# $(use_with prelink)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man || die "emake install failed"
+
+ keepdir /var/lib/aide || die
+ fowners root:0 /var/lib/aide || die
+ fperms 0755 /var/lib/aide || die
+
+ keepdir /var/log/aide || die
+
+ insinto /etc/aide
+ doins "${FILESDIR}"/aide.conf || die
+
+ dosbin "${FILESDIR}"/aideinit || die
+
+ dodoc ChangeLog AUTHORS NEWS README "${FILESDIR}"/aide.cron || die
+ dohtml doc/manual.html || die
+}
+
+pkg_postinst() {
+ elog
+ elog "A sample configuration file has been installed as"
+ elog "/etc/aide/aide.conf. Please edit to meet your needs."
+ elog "Read the aide.conf(5) manual page for more information."
+ elog "A helper script, aideinit, has been installed and can"
+ elog "be used to make AIDE management easier. Please run"
+ elog "aideinit --help for more information"
+ elog
+
+ if use postgres; then
+ elog "Due to a bad assumption by aide, you must issue the following"
+ elog "command after the database initialization (aide --init ...):"
+ elog
+ elog 'psql -c "update pg_index set indisunique=false from pg_class \\ '
+ elog " where pg_class.relname='TABLE_pkey' and \ "
+ elog ' pg_class.oid=pg_index.indexrelid" -h HOSTNAME -p PORT DBASE USER'
+ elog
+ elog "where TABLE, HOSTNAME, PORT, DBASE, and USER are the same as"
+ elog "your aide.conf."
+ elog
+ fi
+}
diff --git a/app-forensics/aide/files/aide-0.14-configure.patch b/app-forensics/aide/files/aide-0.14-configure.patch
new file mode 100644
index 000000000000..54afd8c4f4c6
--- /dev/null
+++ b/app-forensics/aide/files/aide-0.14-configure.patch
@@ -0,0 +1,38 @@
+diff -Naur aide-0.14.orig/configure.in aide-0.14/configure.in
+--- aide-0.14.orig/configure.in 2010-02-26 17:25:29.000000000 +0900
++++ aide-0.14/configure.in 2010-06-09 14:24:43.000000000 +0900
+@@ -407,14 +407,14 @@
+ AC_ARG_WITH([zlib],
+ AC_HELP_STRING([--with-zlib],
+ [use zlib compression]),
+- ,
++ [with_zlib="$withval"],
+ [with_zlib=yes]
+ )
+
+ AC_ARG_WITH([curl],
+ AC_HELP_STRING([--with-curl],
+ [use curl for http,https and ftp backends]),
+- ,
++ [with_curl="$withval"],
+ [with_curl=no]
+ )
+
+@@ -422,7 +422,7 @@
+ AC_ARG_WITH([sun-acl],
+ [AC_HELP_STRING([--with-sun-acl],
+ [use ACL on solaris (no checking)])],
+- [],
++ [with_sun_acl="$withval"],
+ [with_sun_acl=no]
+ )
+
+@@ -440,7 +440,7 @@
+ AC_ARG_WITH([posix-acl],
+ [AC_HELP_STRING([--with-posix-acl],
+ [use POSIX ACLs (no checking)])],
+- [],
++ [with_posix_acl_support="$withval"],
+ [with_posix_acl_support=no]
+ )
+
diff --git a/app-forensics/aide/metadata.xml b/app-forensics/aide/metadata.xml
index 847fc3955a66..2a2155b4178d 100644
--- a/app-forensics/aide/metadata.xml
+++ b/app-forensics/aide/metadata.xml
@@ -5,4 +5,7 @@
<maintainer>
<email>matsuu@gentoo.org</email>
</maintainer>
+<use>
+ <flag name='audit'>Enable support for <pkg>sys-process/audit</pkg></flag>
+</use>
</pkgmetadata>