summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-15 13:10:01 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-15 13:10:01 +0000
commit8c5fc9c9f4465bb3bc29c34f95e90ea4e8914706 (patch)
tree240fbb0a49376594c6c4f71f1000ceb1aab4d3db /app-i18n/anthy
parentversion bump (diff)
downloadgentoo-2-8c5fc9c9f4465bb3bc29c34f95e90ea4e8914706.tar.gz
gentoo-2-8c5fc9c9f4465bb3bc29c34f95e90ea4e8914706.tar.bz2
gentoo-2-8c5fc9c9f4465bb3bc29c34f95e90ea4e8914706.zip
version bump
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/ChangeLog7
-rw-r--r--app-i18n/anthy/Manifest4
-rw-r--r--app-i18n/anthy/anthy-4515.ebuild80
-rw-r--r--app-i18n/anthy/files/digest-anthy-45151
4 files changed, 89 insertions, 3 deletions
diff --git a/app-i18n/anthy/ChangeLog b/app-i18n/anthy/ChangeLog
index a7e673b5643d..d64776a553a9 100644
--- a/app-i18n/anthy/ChangeLog
+++ b/app-i18n/anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.5 2003/09/12 22:22:06 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.6 2003/09/15 13:09:37 usata Exp $
+
+*anthy-4515 (15 Sep 2003)
+
+ 15 Sep 2003; Mamoru KOMACHI <usata@gentoo.org> anthy-4515.ebuild:
+ Version bumped
*anthy-4507 (11 Sep 2003)
diff --git a/app-i18n/anthy/Manifest b/app-i18n/anthy/Manifest
index 9a92c169669e..842ee2964880 100644
--- a/app-i18n/anthy/Manifest
+++ b/app-i18n/anthy/Manifest
@@ -1,8 +1,8 @@
MD5 c8705914e6d4b55d82ea00b4b299cc19 anthy-4300b.ebuild 1041
MD5 110027f473a759d42095c0b178b41f19 metadata.xml 846
-MD5 9762e1f3ce0c3555ee2e79e56fbfc303 ChangeLog 1517
+MD5 9de87e6c84f6e6715c969bda90a7df1a ChangeLog 1630
MD5 37faaf1168c495cd077d1cc376cc1537 anthy-4507.ebuild 1925
-MD5 56c939425e728c86e06495044dcf0001 anthy-4515.ebuild 1926
+MD5 e88d55217b9c935e727fd2b92a9b0e89 anthy-4515.ebuild 1926
MD5 83e271d277525e627be3756f01c7010e files/digest-anthy-4300b 64
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 7bbcd511928477630332c6bd34c6e528 files/digest-anthy-4507 63
diff --git a/app-i18n/anthy/anthy-4515.ebuild b/app-i18n/anthy/anthy-4515.ebuild
new file mode 100644
index 000000000000..a11f29c9dccd
--- /dev/null
+++ b/app-i18n/anthy/anthy-4515.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4515.ebuild,v 1.1 2003/09/15 13:09:37 usata Exp $
+
+IUSE="emacs"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/5939/${P}.tar.gz"
+
+# This branch, so-called anthy-ss (snapshot), is a development branch,
+# so it is not intended to be marked as stable. It will remain unstable
+# all the time unless there comes another -ss branch.
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+S="${WORKDIR}/${P}"
+
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )
+ >=app-dicts/canna-cannadic-0.95-r1"
+RDEPEND="virtual/glibc
+ emacs? ( virtual/emacs )"
+
+SITEFILE="50anthy-gentoo.el"
+SITELISP=/usr/share/emacs/site-lisp
+
+src_compile() {
+
+ local myconf cannadicdir
+ cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs \
+ || myconf="${myconf} EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode' ; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+ if has_version 'app-dicts/canna-2ch' ; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} --with-cannadic=${cannadicdir} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ if [ -n "` use emacs`" ] ; then
+ insinto ${SITELISP}
+ doins ${FILESDIR}/${SITEFILE}
+ fi
+
+ dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
+ doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+}
+
+pkg_postinst() {
+
+ if [ -n "` use emacs`" ] ; then
+ inherit elisp
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+
+ if [ -n "` use emacs`" ] ; then
+ inherit elisp
+ elisp-site-regen
+ fi
+}
diff --git a/app-i18n/anthy/files/digest-anthy-4515 b/app-i18n/anthy/files/digest-anthy-4515
new file mode 100644
index 000000000000..debf2a76268a
--- /dev/null
+++ b/app-i18n/anthy/files/digest-anthy-4515
@@ -0,0 +1 @@
+MD5 513205bed976d217d7e7e82907a4d3ef anthy-4515.tar.gz 1413445