summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-07 11:47:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-07 11:47:04 +0000
commit5c9c67db540375164729bc98508d75ffeaa91e93 (patch)
treeb11e2931763b9a3e9db774501f3f62a3c15f973b /app-i18n/fcitx
parentRemoved old versions. (diff)
downloadgentoo-2-5c9c67db540375164729bc98508d75ffeaa91e93.tar.gz
gentoo-2-5c9c67db540375164729bc98508d75ffeaa91e93.tar.bz2
gentoo-2-5c9c67db540375164729bc98508d75ffeaa91e93.zip
Add patch to fix building with --as-needed, closes bug #225211. Thanks to Hong Hao for reporting.
(Portage version: 2.1.5.4)
Diffstat (limited to 'app-i18n/fcitx')
-rw-r--r--app-i18n/fcitx/ChangeLog7
-rw-r--r--app-i18n/fcitx/fcitx-3.5_pre070703.ebuild12
-rw-r--r--app-i18n/fcitx/files/fcitx-3.5_pre070703-asneeded.patch11
3 files changed, 28 insertions, 2 deletions
diff --git a/app-i18n/fcitx/ChangeLog b/app-i18n/fcitx/ChangeLog
index db1c2aad3b52..e8dd0d3cc45e 100644
--- a/app-i18n/fcitx/ChangeLog
+++ b/app-i18n/fcitx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/fcitx
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.21 2008/01/19 01:13:34 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.22 2008/06/07 11:47:04 flameeyes Exp $
+
+ 07 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/fcitx-3.5_pre070703-asneeded.patch, fcitx-3.5_pre070703.ebuild:
+ Add patch to fix building with --as-needed, closes bug #225211. Thanks to
+ Hong Hao for reporting.
*fcitx-3.5_pre070703 (19 Jan 2008)
diff --git a/app-i18n/fcitx/fcitx-3.5_pre070703.ebuild b/app-i18n/fcitx/fcitx-3.5_pre070703.ebuild
index 2e61927ae85f..aee675aa68a2 100644
--- a/app-i18n/fcitx/fcitx-3.5_pre070703.ebuild
+++ b/app-i18n/fcitx/fcitx-3.5_pre070703.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.5_pre070703.ebuild,v 1.1 2008/01/19 01:13:34 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.5_pre070703.ebuild,v 1.2 2008/06/07 11:47:04 flameeyes Exp $
+
+inherit autotools
DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
HOMEPAGE="http://www.fcitx.org/"
@@ -21,6 +23,14 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P/_pre*}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautomake
+}
+
src_compile() {
econf $(use_enable truetype xft) || die "configure failed"
emake || die "make failed"
diff --git a/app-i18n/fcitx/files/fcitx-3.5_pre070703-asneeded.patch b/app-i18n/fcitx/files/fcitx-3.5_pre070703-asneeded.patch
new file mode 100644
index 000000000000..b1c012b1546b
--- /dev/null
+++ b/app-i18n/fcitx/files/fcitx-3.5_pre070703-asneeded.patch
@@ -0,0 +1,11 @@
+Index: fcitx-3.5/src/Makefile.am
+===================================================================
+--- fcitx-3.5.orig/src/Makefile.am
++++ fcitx-3.5/src/Makefile.am
+@@ -32,5 +32,4 @@ fcitx_SOURCES = IC.c IC.h \
+ fcitx.h extra.c extra.h \
+ internalVersion.c
+
+-fcitx_LDADD = ../lib/libXimd.a
+-fcitx_LDFLAGS = -lXpm
++fcitx_LDADD = ../lib/libXimd.a -lXpm