summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-01-31 08:42:41 +0000
committerBen de Groot <yngwin@gentoo.org>2013-01-31 08:42:41 +0000
commit89b27703b135b33070e0aaa3b5471fcc01c588bd (patch)
tree913eafac95fc868215e819847a93e4dd90a9b158 /app-i18n/fcitx
parentBump for #364261 (diff)
downloadgentoo-2-89b27703b135b33070e0aaa3b5471fcc01c588bd.tar.gz
gentoo-2-89b27703b135b33070e0aaa3b5471fcc01c588bd.tar.bz2
gentoo-2-89b27703b135b33070e0aaa3b5471fcc01c588bd.zip
Version bump, bug #454482. Thanks to Dennis Lan and Wang Jiajun for contributions.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-i18n/fcitx')
-rw-r--r--app-i18n/fcitx/ChangeLog11
-rw-r--r--app-i18n/fcitx/fcitx-4.2.7.ebuild126
-rw-r--r--app-i18n/fcitx/files/fcitx-4.2.7-gcc46-compatible.patch43
-rw-r--r--app-i18n/fcitx/metadata.xml26
4 files changed, 191 insertions, 15 deletions
diff --git a/app-i18n/fcitx/ChangeLog b/app-i18n/fcitx/ChangeLog
index 968b9d1e4014..7717eebf1481 100644
--- a/app-i18n/fcitx/ChangeLog
+++ b/app-i18n/fcitx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/fcitx
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.53 2012/10/29 08:48:14 yngwin Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.54 2013/01/31 08:42:40 yngwin Exp $
+
+*fcitx-4.2.7 (31 Jan 2013)
+
+ 31 Jan 2013; Ben de Groot <yngwin@gentoo.org> +fcitx-4.2.7.ebuild,
+ +files/fcitx-4.2.7-gcc46-compatible.patch, metadata.xml:
+ Version bump, bug #454482. Thanks to Dennis Lan and Wang Jiajun for
+ contributions.
29 Oct 2012; Ben de Groot <yngwin@gentoo.org>
+files/fcitx-4.2.6.1-offline.patch, fcitx-4.2.6.1.ebuild:
diff --git a/app-i18n/fcitx/fcitx-4.2.7.ebuild b/app-i18n/fcitx/fcitx-4.2.7.ebuild
new file mode 100644
index 000000000000..da7d09c5b54b
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-4.2.7.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-4.2.7.ebuild,v 1.1 2013/01/31 08:42:40 yngwin Exp $
+
+EAPI=5
+
+inherit cmake-utils eutils gnome2-utils fdo-mime multilib readme.gentoo
+
+DESCRIPTION="Flexible Contect-aware Input Tool with eXtension support"
+HOMEPAGE="http://www.fcitx.org/"
+SRC_URI="http://fcitx.googlecode.com/files/${P}_dict.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+X +autostart +cairo +dbus debug +enchant gtk gtk3 icu introspection lua
+nls opencc +pango qt4 snooper static-libs +table test +xml"
+
+RDEPEND="
+ X? (
+ x11-libs/libX11
+ x11-libs/libXinerama
+ )
+ cairo? (
+ x11-libs/cairo[X]
+ pango? ( x11-libs/pango[X] )
+ !pango? ( media-libs/fontconfig )
+ )
+ dbus? ( sys-apps/dbus )
+ enchant? ( app-text/enchant )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ dev-libs/dbus-glib
+ )
+ gtk3? (
+ x11-libs/gtk+:3
+ dev-libs/glib:2
+ dev-libs/dbus-glib
+ )
+ icu? ( dev-libs/icu )
+ introspection? ( dev-libs/gobject-introspection )
+ lua? ( dev-lang/lua )
+ opencc? ( app-i18n/opencc )
+ qt4? (
+ x11-libs/qt-gui:4[dbus,glib]
+ x11-libs/qt-dbus:4
+ )
+ xml? (
+ app-text/iso-codes
+ dev-libs/libxml2
+ x11-libs/libxkbfile
+ )"
+DEPEND="${RDEPEND}
+ virtual/libintl
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog README THANKS TODO
+ doc/pinyin.txt doc/cjkvinput.txt doc/API.txt doc/Develop_Readme )
+HTML_DOCS=( doc/wb_fh.htm )
+
+src_prepare() {
+ use autostart && DOC_CONTENTS="You have enabled the autostart USE flag,
+ which will let fcitx start automatically on XDG compatible desktop
+ environments, such as Gnome, KDE, LXDE, Razor-qt and Xfce. If you use
+ ~/.xinitrc to configure your desktop, make sure to include the fcitx
+ command to start it."
+ epatch "${FILESDIR}/${P}-gcc46-compatible.patch"
+ epatch_user
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DLIB_INSTALL_DIR=/usr/$(get_libdir)
+ $(cmake-utils_use_enable X X11)
+ $(cmake-utils_use_enable autostart XDGAUTOSTART)
+ $(cmake-utils_use_enable cairo CAIRO)
+ $(cmake-utils_use_enable dbus DBUS)
+ $(cmake-utils_use_enable debug DEBUG)
+ $(cmake-utils_use_enable enchant ENCHANT)
+ $(cmake-utils_use_enable gtk GTK2_IM_MODULE)
+ $(cmake-utils_use_enable gtk3 GTK3_IM_MODULE)
+ $(cmake-utils_use_enable icu ICU)
+ $(cmake-utils_use_enable introspection GIR)
+ $(cmake-utils_use_enable lua LUA)
+ $(cmake-utils_use_enable nls GETTEXT)
+ $(cmake-utils_use_enable opencc OPENCC)
+ $(cmake-utils_use_enable pango PANGO)
+ $(cmake-utils_use_enable qt4 QT)
+ $(cmake-utils_use_enable qt4 QT_IM_MODULE)
+ $(cmake-utils_use_enable qt4 QT_GUI)
+ $(cmake-utils_use_enable snooper SNOOPER)
+ $(cmake-utils_use_enable static-libs STATIC)
+ $(cmake-utils_use_enable table TABLE)
+ $(cmake-utils_use_enable test TEST)
+ $(cmake-utils_use_enable xml LIBXML2)"
+ if use gtk || use gtk3 || use qt4 ; then
+ mycmakeargs+=" -DENABLE_GLIB2=ON "
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -rf "${ED}"/usr/share/doc/${PN} || die
+ use autostart && readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ use gtk && gnome2_query_immodules_gtk2
+ use gtk3 && gnome2_query_immodules_gtk3
+ use autostart && readme.gentoo_pkg_postinst
+}
+
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ use gtk && gnome2_query_immodules_gtk2
+ use gtk3 && gnome2_query_immodules_gtk3
+}
diff --git a/app-i18n/fcitx/files/fcitx-4.2.7-gcc46-compatible.patch b/app-i18n/fcitx/files/fcitx-4.2.7-gcc46-compatible.patch
new file mode 100644
index 000000000000..218f0e8312cf
--- /dev/null
+++ b/app-i18n/fcitx/files/fcitx-4.2.7-gcc46-compatible.patch
@@ -0,0 +1,43 @@
+From 4c703e395b55e939f3ac1e4a4bf5cd36aa5b0abc Mon Sep 17 00:00:00 2001
+From: Weng Xuetian <wengxt@gmail.com>
+Date: Sat, 26 Jan 2013 14:40:00 -0500
+Subject: [PATCH] [fcitx] fix compatible with gcc 4.6
+
+---
+ src/lib/fcitx/module.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/lib/fcitx/module.h b/src/lib/fcitx/module.h
+index 28de64f..bae6601 100644
+--- a/src/lib/fcitx/module.h
++++ b/src/lib/fcitx/module.h
+@@ -109,7 +109,7 @@
+ void* FcitxModuleInvokeFunction(FcitxAddon* addon, int functionId, FcitxModuleFunctionArg args);
+ #define FcitxModuleInvokeVaArgs(addon, functionId, ARGV...) \
+ (FcitxModuleInvokeFunction(addon, functionId, \
+- (FcitxModuleFunctionArg){ .args = {ARGV} }))
++ (FcitxModuleFunctionArg){ {ARGV} }))
+
+ /**
+ * invoke inter module function with addon name, returns NULL when fails (the function itself can also return NULL)
+@@ -133,7 +133,7 @@
+ #define InvokeVaArgs(INST, MODULE, FUNC, ARGV...) \
+ ((MODULE##_##FUNC##_RETURNTYPE)FcitxModuleInvokeFunctionByName( \
+ INST, MODULE##_NAME, MODULE##_##FUNC, \
+- (FcitxModuleFunctionArg){ .args = {ARGV} }))
++ (FcitxModuleFunctionArg){ {ARGV} }))
+
+ /** add a function to a addon */
+ #define AddFunction(ADDON, Realname) \
+@@ -215,7 +215,7 @@
+ }
+
+ #define FCITX_DEF_MODULE_ARGS(var, ARGV...) \
+- FcitxModuleFunctionArg var = { .args = {ARGV} }
++ FcitxModuleFunctionArg var = { {ARGV} }
+ /* void *__##var##_array[] = {ARGV}; \ */
+ /* size_t __##var##_length = sizeof(__##var##_array) / sizeof(void*); \ */
+ /* FcitxModuleFunctionArg var[] = { { .n = __##var##_length, \ */
+--
+1.7.10
+
diff --git a/app-i18n/fcitx/metadata.xml b/app-i18n/fcitx/metadata.xml
index f3582285ca8a..5b402dfbcac1 100644
--- a/app-i18n/fcitx/metadata.xml
+++ b/app-i18n/fcitx/metadata.xml
@@ -1,17 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>cjk</herd>
- <maintainer>
- <email>qiaomuf@gentoo.org</email>
- <name>Mu Qiao</name>
- </maintainer>
- <use>
- <flag name="introspection">Enable GObject Introspection</flag>
- <flag name="gtk3">Use GTK+3 instead of 2</flag>
- <flag name='opencc'>Enable OpenCC for Chinese Transform</flag>
- <flag name='pango'>Enable support for <pkg>x11-libs/pango</pkg></flag>
- <flag name='snooper'>Enable Key Snooper for gtk app</flag>
- <flag name='table'>Enable Table IM</flag>
- </use>
+ <herd>cjk</herd>
+ <use>
+ <flag name='autostart'>Enable xdg-compatible autostart of fcitx</flag>
+ <flag name='enchant'>Use <pkg>app-text/enchant</pkg> for text prediction</flag>
+ <flag name='introspection'>Enable GObject Introspection</flag>
+ <flag name='gtk'>Install GTK2 IM module</flag>
+ <flag name='gtk3'>Install GTK3 IM module</flag>
+ <flag name='opencc'>Enable OpenCC for Chinese Transform</flag>
+ <flag name='pango'>Enable support for <pkg>x11-libs/pango</pkg></flag>
+ <flag name='qt4'>Install Qt4 IM module</flag>
+ <flag name='snooper'>Enable Key Snooper for GTK app</flag>
+ <flag name='table'>Enable Table IM</flag>
+ </use>
</pkgmetadata>