summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-21 17:04:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-21 17:04:39 +0000
commitff8a1eb1702229ebbb45aa49a5dbc020120fb7a3 (patch)
treed8d964d0a6d700a37f7b59afcabd514be8e2eb3b /app-i18n/ibus-hangul
parentAdd some DEPEND requirements. (diff)
downloadgentoo-2-ff8a1eb1702229ebbb45aa49a5dbc020120fb7a3.tar.gz
gentoo-2-ff8a1eb1702229ebbb45aa49a5dbc020120fb7a3.tar.bz2
gentoo-2-ff8a1eb1702229ebbb45aa49a5dbc020120fb7a3.zip
Empty py-compile script instead of symlinking it to /path/to/true for compability with recent automake. And well, mostly rewrite the ebuild
(Portage version: 2.2.0_alpha92/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/ibus-hangul')
-rw-r--r--app-i18n/ibus-hangul/ChangeLog6
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild33
2 files changed, 21 insertions, 18 deletions
diff --git a/app-i18n/ibus-hangul/ChangeLog b/app-i18n/ibus-hangul/ChangeLog
index 810df9c93011..96bb657d723e 100644
--- a/app-i18n/ibus-hangul/ChangeLog
+++ b/app-i18n/ibus-hangul/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/ibus-hangul
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.20 2012/03/21 15:58:43 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.21 2012/03/21 17:04:39 ssuominen Exp $
+
+ 21 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> ibus-hangul-1.4.0.ebuild:
+ Empty py-compile script instead of symlinking it to /path/to/true for
+ compability with recent automake.
21 Mar 2012; Thomas Kahle <tomka@gentoo.org> ibus-hangul-1.4.0.ebuild:
marked x86 per bug 407691
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild
index d48dbedf42bf..4d4654bef9af 100644
--- a/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild,v 1.3 2012/03/21 15:58:43 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.4.0.ebuild,v 1.4 2012/03/21 17:04:39 ssuominen Exp $
+
+EAPI=4
-EAPI="3"
PYTHON_DEPEND="2:2.5"
-inherit eutils python
+inherit python
DESCRIPTION="The Hangul engine for IBus input platform"
HOMEPAGE="http://code.google.com/p/ibus/"
@@ -16,14 +17,19 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
-RDEPEND=">=app-i18n/ibus-1.3.99
- dev-python/pygobject
- dev-python/pygtk
+RDEPEND=">=app-i18n/ibus-1.4
+ =dev-python/pygobject-2*
+ =dev-python/pygtk-2*
>=app-i18n/libhangul-0.1
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
- nls? ( >=sys-devel/gettext-0.17 )"
+ nls? (
+ dev-util/intltool
+ >=sys-devel/gettext-0.17
+ )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
pkg_setup() {
python_set_active_version 2
@@ -31,19 +37,12 @@ pkg_setup() {
}
src_prepare() {
- mv py-compile py-compile.orig || die
- ln -s "$(type -P true)" py-compile || die
- sed -i -e "s:python:$(PYTHON -2):" setup/ibus-setup-hangul.in || die
+ >py-compile
+ python_convert_shebangs 2 setup/ibus-setup-hangul.in
}
src_configure() {
- econf $(use_enable nls) || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog NEWS README || die
+ econf $(use_enable nls)
}
pkg_postinst() {