summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-03-22 04:01:54 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-03-22 04:01:54 +0000
commit77ffe99b1f3af6239cedec26c0af8e9702cd33ba (patch)
treea9d483d87a0eefa803c9cafa5e3c12532ceba4b2 /app-i18n/imhangul
parentVersion bumped, bug #263211. (diff)
downloadgentoo-2-77ffe99b1f3af6239cedec26c0af8e9702cd33ba.tar.gz
gentoo-2-77ffe99b1f3af6239cedec26c0af8e9702cd33ba.tar.bz2
gentoo-2-77ffe99b1f3af6239cedec26c0af8e9702cd33ba.zip
Version bumped, bug #263212. Fixed libdir handling.
(Portage version: 2.1.6.8/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/imhangul')
-rw-r--r--app-i18n/imhangul/ChangeLog9
-rw-r--r--app-i18n/imhangul/imhangul-0.9.14.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/app-i18n/imhangul/ChangeLog b/app-i18n/imhangul/ChangeLog
index 53666565cb09..f0b9a9a8f1a5 100644
--- a/app-i18n/imhangul/ChangeLog
+++ b/app-i18n/imhangul/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/imhangul
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/imhangul/ChangeLog,v 1.27 2007/02/21 22:04:17 peper Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imhangul/ChangeLog,v 1.28 2009/03/22 04:01:54 matsuu Exp $
+
+*imhangul-0.9.14 (22 Mar 2009)
+
+ 22 Mar 2009; MATSUU Takuto <matsuu@gentoo.org> +imhangul-0.9.14.ebuild:
+ Version bumped, bug #263212. Fixed libdir handling.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-i18n/imhangul/imhangul-0.9.14.ebuild b/app-i18n/imhangul/imhangul-0.9.14.ebuild
new file mode 100644
index 000000000000..5ed29700d283
--- /dev/null
+++ b/app-i18n/imhangul/imhangul-0.9.14.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imhangul/imhangul-0.9.14.ebuild,v 1.1 2009/03/22 04:01:54 matsuu Exp $
+
+inherit multilib
+
+DESCRIPTION="Gtk+-2.0 Hangul Input Modules"
+HOMEPAGE="http://kldp.net/projects/imhangul/"
+SRC_URI="http://kldp.net/frs/download.php/4944/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/libhangul-0.0.9
+ >=x11-libs/gtk+-2.2.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+get_gtk_confdir() {
+ if has_multilib_profile ; then
+ GTK2_CONFDIR="${GTK2_CONFDIR:=/etc/gtk-2.0/${CHOST}}"
+ else
+ GTK2_CONFDIR="${GTK2_CONFDIR:=/etc/gtk-2.0}"
+ fi
+ echo ${GTK2_CONFDIR}
+}
+
+src_compile() {
+ econf \
+ --with-gtk-im-module-dir=/usr/$(get_libdir)/gtk-2.0/immodules \
+ --with-gtk-im-module-file=$(get_gtk_confdir) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > "${ROOT}$(get_gtk_confdir)/gtk.immodules"
+
+ elog ""
+ elog "If you want to use one of the module as a default input method, "
+ elog ""
+ elog "export GTK_IM_MODULE=hangul2 # 2 input type"
+ elog "export GTK_IM_MODULE=hangul3f # 3 input type"
+ elog ""
+}
+
+pkg_postrm() {
+ gtk-query-immodules-2.0 > "${ROOT}$(get_gtk_confdir)/gtk.immodules"
+}