summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 03:57:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 03:57:06 +0000
commite52c9d605768abe32c83305894ce1d784722a985 (patch)
tree1dec21144ea485b482c4519709af2382d87dab4f /app-i18n/jless-iso254
parentadd inherit eutils (diff)
downloadgentoo-2-e52c9d605768abe32c83305894ce1d784722a985.tar.gz
gentoo-2-e52c9d605768abe32c83305894ce1d784722a985.tar.bz2
gentoo-2-e52c9d605768abe32c83305894ce1d784722a985.zip
add inherit eutils
Diffstat (limited to 'app-i18n/jless-iso254')
-rw-r--r--app-i18n/jless-iso254/jless-iso254-358.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/app-i18n/jless-iso254/jless-iso254-358.ebuild b/app-i18n/jless-iso254/jless-iso254-358.ebuild
index fbc755fa7dba..e3972c3c017b 100644
--- a/app-i18n/jless-iso254/jless-iso254-358.ebuild
+++ b/app-i18n/jless-iso254/jless-iso254-358.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jless-iso254/jless-iso254-358.ebuild,v 1.9 2003/11/18 07:21:20 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jless-iso254/jless-iso254-358.ebuild,v 1.10 2004/04/06 03:55:09 vapier Exp $
-IUSE=""
+inherit eutils
LESS_P="less-${PV}"
DESCRIPTION="Jam less is an enhancement of less which supports multibyte character"
+HOMEPAGE="http://www.flash.net/~marknu/less/ http://www.io.com/~kazushi/less/"
SRC_URI="mirror://gnu/less/${LESS_P}.tar.gz
http://www.io.com/~kazushi/less/${LESS_P}-iso254.patch.gz"
-HOMEPAGE="http://www.flash.net/~marknu/less/
- http://www.io.com/~kazushi/less/"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 alpha sparc ppc"
+KEYWORDS="x86 ppc sparc alpha"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2"
-S="${WORKDIR}/${LESS_P}"
+S=${WORKDIR}/${LESS_P}
src_unpack() {
@@ -29,37 +28,34 @@ src_unpack() {
}
src_compile() {
-
- local editor=$(. /etc/profile 2>/dev/null ; echo $EDITOR)
-
- econf --without-cs-regex \
+ econf \
+ --without-cs-regex \
--with-regex=auto \
--enable-msb \
--enable-jisx0213 \
- --with-editor=${editor} || die
+ --with-editor=${EDITOR} \
+ || die
emake || die
}
src_install() {
-
einstall binprefix=j manprefix=j || die
newbin ${FILESDIR}/lesspipe.sh-r1 jlesspipe.sh
- if [ ! -f /usr/bin/lesspipe.sh ] ; then
+ if [ ! -f ${ROOT}/usr/bin/lesspipe.sh ] ; then
dosym /usr/bin/jlesspipe.sh /usr/bin/lesspipe.sh
fi
insinto /etc/env.d
doins ${FILESDIR}/70jless
- dodoc COPYING LICENSE NEWS README*
+ dodoc NEWS README*
}
pkg_postinst() {
-
# for backward compatibility
- if [ ! -f /usr/bin/lesspipe.sh ] ; then
- ln -s /usr/bin/jlesspipe.sh /usr/bin/lesspipe.sh
+ if [ ! -f ${ROOT}/usr/bin/lesspipe.sh ] ; then
+ ln -s /usr/bin/jlesspipe.sh ${ROOT}/usr/bin/lesspipe.sh
fi
}