summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-06-21 17:41:43 +0000
committerMichael Januszewski <spock@gentoo.org>2004-06-21 17:41:43 +0000
commit30a882ed20bc4de43cee746913a411a660bc85bf (patch)
tree708cc7347cc19e5f6ae0a88877a2df1343d822aa /app-i18n/manpages-pl/manpages-pl-20040401.ebuild
parentFix use invocation (Manifest recommit) (diff)
downloadgentoo-2-30a882ed20bc4de43cee746913a411a660bc85bf.tar.gz
gentoo-2-30a882ed20bc4de43cee746913a411a660bc85bf.tar.bz2
gentoo-2-30a882ed20bc4de43cee746913a411a660bc85bf.zip
Initial commit.
Diffstat (limited to 'app-i18n/manpages-pl/manpages-pl-20040401.ebuild')
-rw-r--r--app-i18n/manpages-pl/manpages-pl-20040401.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-i18n/manpages-pl/manpages-pl-20040401.ebuild b/app-i18n/manpages-pl/manpages-pl-20040401.ebuild
new file mode 100644
index 000000000000..dc4d9c28fab2
--- /dev/null
+++ b/app-i18n/manpages-pl/manpages-pl-20040401.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/manpages-pl/manpages-pl-20040401.ebuild,v 1.1 2004/06/21 17:41:43 spock Exp $
+
+S="${WORKDIR}/pl_PL"
+
+DESCRIPTION="A collection of Polish translations of Linux manual pages."
+SRC_URI="http://ptm.linux.pl/man-PL${PV:6:2}-${PV:4:2}-${PV:0:4}.tar.gz"
+HOMEPAGE="http://ptm.linux.pl/"
+LICENSE="GPL-2"
+IUSE=""
+
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="sys-apps/man"
+DEPEND="sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s#\tputmsg.2 ##" -r man2/Makefile.am
+ sed -i -e "s#\tfprintf.3 ##" -e "s#\tMakefile.am ##" -r man3/Makefile.am
+}
+
+src_compile() {
+ ./autogen.sh \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO
+}