summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-01-04 16:56:11 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-01-04 16:56:11 +0000
commit3ddf36a0e3065fd9832f0ad5bb39ab0309accb6b (patch)
treec3d2b48e22a05911b031d0270e82501a1a11d41c /app-i18n/nkf/nkf-2.0.4.ebuild
parentAdd Tony Vroon's <tony@vroon.org> patch to force tar to NOT remove the leadin... (diff)
downloadgentoo-2-3ddf36a0e3065fd9832f0ad5bb39ab0309accb6b.tar.gz
gentoo-2-3ddf36a0e3065fd9832f0ad5bb39ab0309accb6b.tar.bz2
gentoo-2-3ddf36a0e3065fd9832f0ad5bb39ab0309accb6b.zip
Version bump. And clean up old versions.
Diffstat (limited to 'app-i18n/nkf/nkf-2.0.4.ebuild')
-rw-r--r--app-i18n/nkf/nkf-2.0.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-i18n/nkf/nkf-2.0.4.ebuild b/app-i18n/nkf/nkf-2.0.4.ebuild
new file mode 100644
index 000000000000..164b6d7768a0
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.4.ebuild,v 1.1 2004/01/04 16:56:11 nakano Exp $
+
+use perl && inherit perl-module
+
+MY_P="${PN}${PV//./}"
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+SRC_URI="http://www01.tcp-ip.or.jp/~furukawa/nkf_utf8/${MY_P}.tar.gz"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+DEPEND="virtual/glibc
+ $DEPEND"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="perl cjk"
+LICENSE="as-is"
+SLOT="0"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake CC=gcc CFLAGS="${CFLAGS}" nkf || die
+ if [ `use perl` ]; then
+ cd ${S}/NKF.mod
+ perl-module_src_compile
+ perl-module_src_test
+ fi
+}
+
+src_install () {
+ into /usr
+ dobin nkf
+ doman nkf.1
+ if [ `use cjk` ]; then
+ dodir /usr/share/man/ja/man1
+ insinto /usr/share/man/ja/man1
+ ./nkf -e nkf.1j > nkf.1
+ doins nkf.1
+ fi
+ dodoc INSTALL* nkf.doc
+ if [ `use perl` ]; then
+ cd ${S}/NKF.mod
+ perl-module_src_install
+ fi
+}