summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-16 18:23:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-16 18:23:26 +0000
commit559c653953eba2a2b8f82dfd7177ec428d8ea0f8 (patch)
treef16353a667cfea6ea171ec27b254fc940da64857 /app-i18n/scim-uim/scim-uim-0.1.4.ebuild
parentversion bump from upstream (diff)
downloadgentoo-2-559c653953eba2a2b8f82dfd7177ec428d8ea0f8.tar.gz
gentoo-2-559c653953eba2a2b8f82dfd7177ec428d8ea0f8.tar.bz2
gentoo-2-559c653953eba2a2b8f82dfd7177ec428d8ea0f8.zip
Add missing pkg-config depedency, thanks to Patrick Lauer for reporting in bug #151618.
Use autotools eclass to regenerate autotools, as the only libtoolize will be out of control. (Portage version: 2.1.2_pre3-r2)
Diffstat (limited to 'app-i18n/scim-uim/scim-uim-0.1.4.ebuild')
-rw-r--r--app-i18n/scim-uim/scim-uim-0.1.4.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/app-i18n/scim-uim/scim-uim-0.1.4.ebuild b/app-i18n/scim-uim/scim-uim-0.1.4.ebuild
index 99d804c7c372..9b4498a9b68c 100644
--- a/app-i18n/scim-uim/scim-uim-0.1.4.ebuild
+++ b/app-i18n/scim-uim/scim-uim-0.1.4.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-uim/scim-uim-0.1.4.ebuild,v 1.1 2006/02/10 22:58:24 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-uim/scim-uim-0.1.4.ebuild,v 1.2 2006/10/16 18:23:26 flameeyes Exp $
-inherit eutils
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
DESCRIPTION="scim-uim is an input module for Smart Common Input Method (SCIM) which uses uim as backend"
HOMEPAGE="http://www.scim-im.org/"
@@ -16,14 +19,14 @@ IUSE=""
RDEPEND="|| ( >=app-i18n/scim-0.99.8 >=app-i18n/scim-cvs-0.99.8 )
>=app-i18n/uim-0.3.9"
DEPEND="${RDEPEND}
- sys-devel/autoconf"
+ dev-util/pkgconfig"
src_unpack() {
unpack ${A}
cd ${S}
if has_version '=app-i18n/uim-0.4.5-r1' || has_version 'app-i18n/uim-svn' ; then
- sed -i -e "/^UIM_VERSION/s/=.*/=rev1650/" configure* || die
- libtoolize --copy --force || die
+ sed -i -e "/^UIM_VERSION/s/=.*/=rev1650/" configure.* || die
+ eautoreconf
fi
}
@@ -33,17 +36,17 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog README THANKS
}
pkg_postinst() {
einfo
- einfo "To use SCIM with both GTK2 and XIM, you should use the following"
- einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
einfo
- einfo "LANG='your_language' scim -d"
- einfo "export XMODIFIERS=@im=SCIM"
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
einfo
}