summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-08-25 10:17:30 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-08-25 10:17:30 +0000
commit79a667be5efa39359f73583c714b096b7cf51f2f (patch)
tree639becfb164ed73472bb9aaf759413513ba7374f /app-i18n/zhcon
parentSet +x on the cgi (Manifest recommit) (diff)
downloadgentoo-2-79a667be5efa39359f73583c714b096b7cf51f2f.tar.gz
gentoo-2-79a667be5efa39359f73583c714b096b7cf51f2f.tar.bz2
gentoo-2-79a667be5efa39359f73583c714b096b7cf51f2f.zip
Fixed compile problems with gcc-34. Bug #61381.
Diffstat (limited to 'app-i18n/zhcon')
-rw-r--r--app-i18n/zhcon/ChangeLog6
-rw-r--r--app-i18n/zhcon/files/zhcon-0.2.3-gcc34.patch49
-rw-r--r--app-i18n/zhcon/zhcon-0.2.3.ebuild4
3 files changed, 57 insertions, 2 deletions
diff --git a/app-i18n/zhcon/ChangeLog b/app-i18n/zhcon/ChangeLog
index afc53375d7a1..ef10d0e5a38b 100644
--- a/app-i18n/zhcon/ChangeLog
+++ b/app-i18n/zhcon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/zhcon
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/zhcon/ChangeLog,v 1.3 2004/06/24 21:57:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/zhcon/ChangeLog,v 1.4 2004/08/25 10:17:30 sekretarz Exp $
+
+ 25 Aug 2004; Karol Wojtaszek <sekretarz@gentoo.org>
+ +files/zhcon-0.2.3-gcc34.patch, zhcon-0.2.3.ebuild:
+ Fixed compile problems with gcc-34. Bug #61381. Thanks to Jackey Yang
25 Apr 2004; Mamoru KOMACHI <usata@gentoo.org> zhcon-0.2.3.ebuild:
Marked stable on x86
diff --git a/app-i18n/zhcon/files/zhcon-0.2.3-gcc34.patch b/app-i18n/zhcon/files/zhcon-0.2.3-gcc34.patch
new file mode 100644
index 000000000000..d44bc7d0d13d
--- /dev/null
+++ b/app-i18n/zhcon/files/zhcon-0.2.3-gcc34.patch
@@ -0,0 +1,49 @@
+diff -Naur zhcon-0.2.3.orig/config.h.in zhcon-0.2.3/config.h.in
+--- zhcon-0.2.3.orig/config.h.in 2003-04-13 07:05:29.000000000 +0200
++++ zhcon-0.2.3/config.h.in 2004-08-25 11:40:00.905785096 +0200
+@@ -275,11 +275,11 @@
+ #undef WORDS_BIGENDIAN
+
+ /* Define to empty if `const' does not conform to ANSI C. */
+-#undef const
++/*#undef const*/
+
+ /* Define as `__inline' if that's what the C compiler calls it, or to nothing
+ if it is not supported. */
+-#undef inline
++/*#undef inline*/
+
+ /* Define to `long' if <sys/types.h> does not define. */
+ #undef off_t
+diff -Naur zhcon-0.2.3.orig/src/display/fblinear24.cpp zhcon-0.2.3/src/display/fblinear24.cpp
+--- zhcon-0.2.3.orig/src/display/fblinear24.cpp 2002-05-12 05:58:28.000000000 +0200
++++ zhcon-0.2.3/src/display/fblinear24.cpp 2004-08-25 11:40:00.635826136 +0200
+@@ -203,11 +203,13 @@
+ d1 = (-(*cdat >> 3 & 1) & eorx) ^ bgx;
+ d2 = (-(*cdat >> 2 & 1) & eorx) ^ bgx;
+ fb_writel(d1 | (d2<<24), dest32++);
+- fb_writew(d2>>8, ((__u16*)dest32)++);
++ dest32 = (__u32*)((__u16*)dest32 + 1);
++ fb_writew(d3, dest32);
+ }
+ if (pFont->w & 1) {
+ d3 = (-(*cdat >> 1 & 1) & eorx) ^ bgx;
+- fb_writew(d3, ((__u16*)dest32)++);
++ dest32 = (__u32*)((__u16*)dest32 + 1);
++ fb_writew(d3, dest32);
+ fb_writeb(d3>>16, (__u8*)dest32);
+ }
+ cdat++;
+diff -Naur zhcon-0.2.3.orig/src/display/fblinear8.cpp zhcon-0.2.3/src/display/fblinear8.cpp
+--- zhcon-0.2.3.orig/src/display/fblinear8.cpp 2002-05-12 05:58:28.000000000 +0200
++++ zhcon-0.2.3/src/display/fblinear8.cpp 2004-08-25 11:40:00.641825224 +0200
+@@ -102,7 +102,8 @@
+ fb_writel((nibbletab_cfb8[*cdat >> 4] & eorx) ^ bgx, dest32++);
+ }
+ if (pFont->w & 2) {
+- fb_writew((nibbletab_cfb8[*cdat & 0xc] & eorx) ^ bgx, ((__u16*)dest32)++);
++ dest32 = (__u32*)((__u16*)dest32 + 1);
++ fb_writew((nibbletab_cfb8[*cdat & 0xc] & eorx) ^ bgx, dest32);
+ }
+ if (pFont->w & 1) {
+ fb_writeb((*cdat & 2) ? fg : bg, (__u8*)dest32);
diff --git a/app-i18n/zhcon/zhcon-0.2.3.ebuild b/app-i18n/zhcon/zhcon-0.2.3.ebuild
index c2298170a957..77897ee9ddae 100644
--- a/app-i18n/zhcon/zhcon-0.2.3.ebuild
+++ b/app-i18n/zhcon/zhcon-0.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/zhcon/zhcon-0.2.3.ebuild,v 1.5 2004/06/28 02:08:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/zhcon/zhcon-0.2.3.ebuild,v 1.6 2004/08/25 10:17:30 sekretarz Exp $
inherit eutils
@@ -21,6 +21,8 @@ src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-gentoo.diff
epatch ${FILESDIR}/${P}-assert-gentoo.diff
+
+ epatch ${FILESDIR}/${P}-gcc34.patch
}
src_compile() {