summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-05 07:19:04 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-05 07:19:04 +0000
commit05dd28012107019b981c5747fbbcb82aa0493034 (patch)
tree96f20a473053151f0e43983a970a7e0f262557ff /app-i18n
parentVersion bumped. This closes bug #80570. (diff)
downloadgentoo-2-05dd28012107019b981c5747fbbcb82aa0493034.tar.gz
gentoo-2-05dd28012107019b981c5747fbbcb82aa0493034.tar.bz2
gentoo-2-05dd28012107019b981c5747fbbcb82aa0493034.zip
Fixed incorrect conversion problem; bug #73977.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy/ChangeLog8
-rw-r--r--app-i18n/anthy/Manifest7
-rw-r--r--app-i18n/anthy/anthy-5900-r1.ebuild76
-rw-r--r--app-i18n/anthy/files/anthy-mkdic-gcc34.patch22
-rw-r--r--app-i18n/anthy/files/digest-anthy-5900-r11
5 files changed, 111 insertions, 3 deletions
diff --git a/app-i18n/anthy/ChangeLog b/app-i18n/anthy/ChangeLog
index 5864985a004c..fc5235df21d4 100644
--- a/app-i18n/anthy/ChangeLog
+++ b/app-i18n/anthy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/anthy
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.41 2005/01/02 21:01:54 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.42 2005/02/05 07:19:04 usata Exp $
+
+*anthy-5900-r1 (05 Feb 2005)
+
+ 05 Feb 2005; Mamoru KOMACHI <usata@gentoo.org>
+ +files/anthy-mkdic-gcc34.patch, +anthy-5900-r1.ebuild:
+ Fixed incorrect conversion problem; bug #73977.
02 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/app-i18n/anthy/Manifest b/app-i18n/anthy/Manifest
index 1d91f7aff188..2f7d1c5a3a91 100644
--- a/app-i18n/anthy/Manifest
+++ b/app-i18n/anthy/Manifest
@@ -1,9 +1,12 @@
MD5 e72151545883788d6f6f58897b1b7fd5 anthy-5900.ebuild 1525
-MD5 1de60bf0fab67ba591207d17b725109e anthy-5500.ebuild 1611
MD5 eaafd798bb83bfbfa5bc033c38a2a6a1 ChangeLog 5347
-MD5 62ce7f3bee5456885154291076eee2bd anthy-5100b.ebuild 1488
MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
+MD5 2ead0aa553655e6ed628915196872476 anthy-5900-r1.ebuild 1671
+MD5 62ce7f3bee5456885154291076eee2bd anthy-5100b.ebuild 1488
+MD5 1de60bf0fab67ba591207d17b725109e anthy-5500.ebuild 1611
MD5 5f13ff8fdbc22d40da3964a5a7639f6d files/digest-anthy-5900 63
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
+MD5 5f13ff8fdbc22d40da3964a5a7639f6d files/digest-anthy-5900-r1 63
MD5 0929884906bad3f7f4b85908b5425ba8 files/digest-anthy-5100b 64
MD5 a43bee494b9bf2ac632a52d8dd686722 files/digest-anthy-5500 63
+MD5 9ad5e85186b6813cb0e7a76976ed8fd3 files/anthy-mkdic-gcc34.patch 790
diff --git a/app-i18n/anthy/anthy-5900-r1.ebuild b/app-i18n/anthy/anthy-5900-r1.ebuild
new file mode 100644
index 000000000000..2bc42b200ad4
--- /dev/null
+++ b/app-i18n/anthy/anthy-5900-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-5900-r1.ebuild,v 1.1 2005/02/05 07:19:04 usata Exp $
+
+inherit elisp-common eutils
+
+IUSE="emacs ucs4"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/12071/${P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
+SLOT="0"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy-ss"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ if has_version '>=sys-devel/gcc-3.4' ; then
+ epatch ${FILESDIR}/anthy-mkdic-gcc34.patch
+ fi
+}
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-ucs4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.in
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.in
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy/files/anthy-mkdic-gcc34.patch b/app-i18n/anthy/files/anthy-mkdic-gcc34.patch
new file mode 100644
index 000000000000..b18c86893a94
--- /dev/null
+++ b/app-i18n/anthy/files/anthy-mkdic-gcc34.patch
@@ -0,0 +1,22 @@
+--- mkanthydic/mkdic.c.orig 2004-08-29 04:54:48.000000000 +0900
++++ mkanthydic/mkdic.c 2004-11-27 01:06:54.930846856 +0900
+@@ -455,7 +455,8 @@
+ (strcmp(ye->entries[i-1].word, we->word) ||
+ strcmp(ye->entries[i-1].wt, we->wt) ||
+ ye->entries[i-1].freq != we->freq)) {
+- count += fprintf(yomi_entry_out, "%s", we->wt);
++ fprintf(yomi_entry_out, "%s", we->wt);
++ count += strlen(we->wt);
+ if (we->freq > 1) {
+ count += fprintf(yomi_entry_out, "*%d", we->freq);
+ }
+@@ -464,7 +465,8 @@
+ /* 単語を出力する場所がこの単語のid */
+ we->offset = count + ye->offset;
+ /* 単語を出力する */
+- count += fprintf(yomi_entry_out, "%s", we->word);
++ fprintf(yomi_entry_out, "%s", we->word);
++ count += strlen(we->word);
+ }
+
+ fputc(0, yomi_entry_out); \ No newline at end of file
diff --git a/app-i18n/anthy/files/digest-anthy-5900-r1 b/app-i18n/anthy/files/digest-anthy-5900-r1
new file mode 100644
index 000000000000..dbdefd0061f4
--- /dev/null
+++ b/app-i18n/anthy/files/digest-anthy-5900-r1
@@ -0,0 +1 @@
+MD5 7f1a250c8b88b3792855fb43131ce8d3 anthy-5900.tar.gz 1566783