summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-10-17 02:10:11 +0000
committerNaohiro Aota <naota@gentoo.org>2012-10-17 02:10:11 +0000
commit206975b4bfc8a00f1a72266e7b4dca0e3b13feae (patch)
treeb6c8e5b8f16d4199c7799ca456d9a0d19f503c3b /app-i18n
parentstable ppc ppc64, bug #438146 (diff)
downloadgentoo-2-206975b4bfc8a00f1a72266e7b4dca0e3b13feae.tar.gz
gentoo-2-206975b4bfc8a00f1a72266e7b4dca0e3b13feae.tar.bz2
gentoo-2-206975b4bfc8a00f1a72266e7b4dca0e3b13feae.zip
Revbump to fix pkgconfig file.
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch17
-rw-r--r--app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild42
2 files changed, 59 insertions, 0 deletions
diff --git a/app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch b/app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch
new file mode 100644
index 000000000000..76dc4330c440
--- /dev/null
+++ b/app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch
@@ -0,0 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -70,11 +70,11 @@ set (DIR_SHARE ${DIR_PREFIX}/share)
+ set (DIR_BIN ${DIR_PREFIX}/bin)
+ set (DIR_ETC ${DIR_PREFIX}/etc)
+
+ if (DEFINED CMAKE_INSTALL_LIBDIR)
+- set (DIR_LIBRARY ${CMAKE_INSTALL_LIBDIR})
+- set (DIR_LIBRARY_STATIC ${CMAKE_INSTALL_LIBDIR})
++ set (DIR_LIBRARY ${DIR_PREFIX}/${CMAKE_INSTALL_LIBDIR})
++ set (DIR_LIBRARY_STATIC ${DIR_PREFIX}/${CMAKE_INSTALL_LIBDIR})
+ endif (DEFINED CMAKE_INSTALL_LIBDIR)
+
+ if (DEFINED SHARE_INSTALL_PREFIX)
+ set (DIR_SHARE ${SHARE_INSTALL_PREFIX})
+ endif (DEFINED SHARE_INSTALL_PREFIX)
diff --git a/app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild b/app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild
new file mode 100644
index 000000000000..338b3d2ae6f9
--- /dev/null
+++ b/app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild,v 1.1 2012/10/17 02:10:11 naota Exp $
+
+EAPI=4
+
+inherit cmake-utils multilib eutils
+
+DESCRIPTION="Libraries for Simplified-Traditional Chinese Conversion"
+HOMEPAGE="http://code.google.com/p/open-chinese-convert/"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS="AUTHORS README"
+
+src_prepare() {
+ sed -i \
+ -e "s:\${CMAKE_\(SHARED\|STATIC\)_LIBRARY_PREFIX}:\"$(get_libdir)\":" \
+ CMakeLists.txt || die
+ epatch "${FILESDIR}"/${P}-cmake-libdir.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable nls GETTEXT)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use static-libs || find "${ED}" -name '*.la' -o -name '*.a' -exec rm {} +
+}